Closed Thread
Results 1 to 3 of 3

Reload Thread: Alpine SPX-F17M Crossover help needed, or manual for them

  1. #1
    OnTheGreen's Avatar
    OnTheGreen is offline Member



    Join Date
    Mar 2006
    Location
    San Diego
    Posts
    126
    Post Thanks / Like
    Images
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Alpine SPX-F17M Crossover help needed, or manual for them

    Picked up a set of Alpine SPX-F17M crossovers to go with some Alpine 6.5" and 1" I have

    Crossovers are bi-ampable. But I would like to run them like standard crossover and am not sure how to wire them.

    They have WF (+&-) In and Out, TW (+&-) In and out.

    If someone had a manual for these or similar, that would be great too

    Thanks, Bryan







  2. #2
    nineball's Avatar
    nineball is offline too many toys...



    Join Date
    Feb 2008
    Location
    home
    Posts
    1,921
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    11 Post(s)

    Re: Alpine SPX-F17M Crossover help needed, or manual for them

    not hard to find at all. i think it took about 6 seconds on alpine's site.

    http://vault.alpine-usa.com/products...M_SPX-F17M.PDF





    Quote Originally Posted by eharri3 View Post
    I have 4 12s getting 2K watts rms and my front stage is 4 Walmart JVC coaxials running off 16 watts rms of head unit power. My sub sounds fine but my mids and highs don't sound very clear and start to distort long before my subs do. Anybody know why? Any suggestions?

  3. #3
    nineball's Avatar
    nineball is offline too many toys...



    Join Date
    Feb 2008
    Location
    home
    Posts
    1,921
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    11 Post(s)

    Re: Alpine SPX-F17M Crossover help needed, or manual for them

    not hard to find at all. i think it took about 6 seconds on alpine's site.

    http://vault.alpine-usa.com/products...M_SPX-F17M.PDF





    Quote Originally Posted by eharri3 View Post
    I have 4 12s getting 2K watts rms and my front stage is 4 Walmart JVC coaxials running off 16 watts rms of head unit power. My sub sounds fine but my mids and highs don't sound very clear and start to distort long before my subs do. Anybody know why? Any suggestions?

Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum