Closed Thread
Page 1 of 3 1 2 3 LastLast
Results 1 to 15 of 36

Reload Thread: My CTX65CS are lacking bass!

  1. #1
    mjbailey21's Avatar
    mjbailey21 is offline Getting back into it!



    Join Date
    Aug 2004
    Location
    Dallas, Tx
    Posts
    2,343
    Post Thanks / Like
    Mentioned
    0 Post(s)

    My CTX65CS are lacking bass!

    Hey All-
    Tried to research and look it up but I don't really know how to "search" for this question. Maybe you can help me.

    I recently purchased a Sax 125.2 to go with a pair of Image Dynamics 65CTXcs. The headunit is a Pioneer 450UB (or something similar).

    Only problem is, I can't figure out how to get some bass out of the speakers. I know these aren't subs, but I have no lows! The highs sounds good and mids sound pretty good but I am lacking lows/beats!

    On the amp, I set it to "full" instead of HPF or LPF. What else am I supposed to do?

    Thanks to all who help.



    References:
    HavingFun, Jaxzon315, Moe Lester, sbcaprice305, RickTC, Frito, DarrenE, BiaBia, Mr. Loki, Johnecon2001,Loud-n-Low, Zier

    GO COWBOYS!!!!




  2. #2
    mjbailey21's Avatar
    mjbailey21 is offline Getting back into it!

    Threadstarter


    Join Date
    Aug 2004
    Location
    Dallas, Tx
    Posts
    2,343
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: My CTX65CS are lacking bass!

    plzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzz help bump



    References:
    HavingFun, Jaxzon315, Moe Lester, sbcaprice305, RickTC, Frito, DarrenE, BiaBia, Mr. Loki, Johnecon2001,Loud-n-Low, Zier

    GO COWBOYS!!!!

  3. #3
    Join Date
    Sep 2008
    Location
    Virginia
    Posts
    10,711
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: My CTX65CS are lacking bass!

    How low are you looking, shouldnt be playing any less than like 70 so i think your expecting too much.




  4. #4
    Sir-Lancelot's Avatar
    Sir-Lancelot is offline Senior VIP Member



    Join Date
    Jun 2009
    Location
    South Carolina
    Age
    43
    Posts
    266
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: My CTX65CS are lacking bass!

    How are they installed.
    Sealing door holes and sound deadener helps mid bass a bunch. More tham anything else you could do.

    I would set the amp to 60 if you have subs.




  5. #5
    Side Show's Avatar
    Side Show is offline Bringin The Noise



    Join Date
    Aug 2007
    Location
    Australia
    Posts
    3,326
    Post Thanks / Like
    Mentioned
    1 Post(s)

    Re: My CTX65CS are lacking bass!

    OMG, set your hpf on your deck




  6. #6
    mjbailey21's Avatar
    mjbailey21 is offline Getting back into it!

    Threadstarter


    Join Date
    Aug 2004
    Location
    Dallas, Tx
    Posts
    2,343
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: My CTX65CS are lacking bass!

    lol thx guys taken care of!



    References:
    HavingFun, Jaxzon315, Moe Lester, sbcaprice305, RickTC, Frito, DarrenE, BiaBia, Mr. Loki, Johnecon2001,Loud-n-Low, Zier

    GO COWBOYS!!!!

  7. #7
    perfecxionX's Avatar
    perfecxionX is offline CarAudio.com Veteran



    Join Date
    Dec 2006
    Location
    indianapolis
    Posts
    2,564
    Post Thanks / Like
    Mentioned
    19 Post(s)

    Re: My CTX65CS are lacking bass!

    what turned out to be the cause of the problem?



    “Ignorance more frequently begets confidence than does knowledge" Charles Darwin

    refs---
    http://www.caraudio.com/forum/showthread.php?t=219529&highlight=perfecxionx
    http://www.caraudio.com/forum/showthread.php?t=259748
    http://www.diymobileaudio.com/forum/itrader.php?u=28091
    http://www.caraudioclassifieds.org/forum/itrader.php?u=916
    http://myworld.ebay.com/perfecxionx/

  8. #8
    Louisiana_CRX's Avatar
    Louisiana_CRX is offline dem shoes......



    Join Date
    Aug 2006
    Location
    Piney Hills of Louisiana
    Posts
    34,137
    Post Thanks / Like
    Images
    9
    Mentioned
    31 Post(s)

    Re: My CTX65CS are lacking bass!

    Quote Originally Posted by perfecxionX View Post
    what turned out to be the cause of the problem?
    x2




    Current 2010 Louisiana USACi State Records :

    Trunk 0-1000.................. 151.3
    StreetBeat 2................... 145.6
    Stock 1801-up.................153.8
    SuperStock 1801-up..........154.2
    Top three in 11 out of 26 power classes and Louisiana USACi Points Leader at 465

  9. #9
    mjbailey21's Avatar
    mjbailey21 is offline Getting back into it!

    Threadstarter


    Join Date
    Aug 2004
    Location
    Dallas, Tx
    Posts
    2,343
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: My CTX65CS are lacking bass!

    I'm actually working on a paper right now, so I haven't done anything yet .

    I think it is something to do with the radios HPF settings, as well as a few people telling me I should look into that as well..
    I well let you all know if that doesn't work out!



    References:
    HavingFun, Jaxzon315, Moe Lester, sbcaprice305, RickTC, Frito, DarrenE, BiaBia, Mr. Loki, Johnecon2001,Loud-n-Low, Zier

    GO COWBOYS!!!!

  10. #10
    mr.michael's Avatar
    mr.michael is offline BOB SAGGET!



    Join Date
    Oct 2008
    Location
    cA
    Posts
    1,115
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: My CTX65CS are lacking bass!

    lol mystery



    BOUGHT FROM RYANM923, HEADSHOK(CACO.COM)

  11. #11
    mjbailey21's Avatar
    mjbailey21 is offline Getting back into it!

    Threadstarter


    Join Date
    Aug 2004
    Location
    Dallas, Tx
    Posts
    2,343
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: My CTX65CS are lacking bass!

    Quote Originally Posted by Side Show View Post
    OMG, set your hpf on your deck
    OMG OMG OMG!



    References:
    HavingFun, Jaxzon315, Moe Lester, sbcaprice305, RickTC, Frito, DarrenE, BiaBia, Mr. Loki, Johnecon2001,Loud-n-Low, Zier

    GO COWBOYS!!!!

  12. #12
    mjbailey21's Avatar
    mjbailey21 is offline Getting back into it!

    Threadstarter


    Join Date
    Aug 2004
    Location
    Dallas, Tx
    Posts
    2,343
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: My CTX65CS are lacking bass!

    Still can't seem to figure it out, I've changed the HPF like the OMG guy above told me to do but that didn't help much.



    References:
    HavingFun, Jaxzon315, Moe Lester, sbcaprice305, RickTC, Frito, DarrenE, BiaBia, Mr. Loki, Johnecon2001,Loud-n-Low, Zier

    GO COWBOYS!!!!

  13. #13
    Go2Sleep's Avatar
    Go2Sleep is online now CarAudio.com Veteran



    Join Date
    Jan 2008
    Location
    Bay Area, CA
    Age
    26
    Posts
    3,380
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: My CTX65CS are lacking bass!

    are the mids even moving? take a vid and upload it here



    * (2) Morel Ultimo 12's * Hybrid Audio Legathia SE Front Stage * RF 360.3 DSP * Brax 2400 * JL Audio HD 1200/1 *

  14. #14
    Horsemanwill's Avatar
    Horsemanwill is offline CarAudio.com Veteran



    Join Date
    Aug 2008
    Location
    Junction City, Kansas
    Posts
    2,975
    Post Thanks / Like
    Images
    1
    Mentioned
    1 Post(s)

    Re: My CTX65CS are lacking bass!

    Quote Originally Posted by Sir-Lancelot View Post
    How are they installed.
    Sealing door holes and sound deadener helps mid bass a bunch. More tham anything else you could do.
    how do you have them installed?



    Pioneer Carrozzeria DEH P01
    Tru SB6
    Silver Flute W17RC38-08 6-1/2" Wool Cone
    Tru Steel S25
    ES Full body horns soon to come
    2x JBL W12GTI

  15. #15
    Sir-Lancelot's Avatar
    Sir-Lancelot is offline Senior VIP Member



    Join Date
    Jun 2009
    Location
    South Carolina
    Age
    43
    Posts
    266
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: My CTX65CS are lacking bass!

    Quote Originally Posted by Horsemanwill View Post
    how do you have them installed?
    Doors holes sealed and deadened with Damp Pro. 3/4" MDF rings and non hardening clay. About the only thing I did not do that was done on this thread http://www.caraudio.com/forum/showthread.php?t=95925 was to add the foam behind the mid.




Closed Thread
Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum