Closed Thread
Results 1 to 12 of 12

Reload Thread: SPX-17PRO burned

  1. #1
    HNaga's Avatar
    HNaga is offline Member



    Join Date
    Oct 2008
    Location
    Cairo
    Posts
    115
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    SPX-17PRO burned

    after wiring SPX-17PRO to PDX-5 , 5 minutes and right door tweeter had no sound
    I turned the HU wihich is CDA-9887 off , checked what happened I found the woofer became solid .

    I found that the guy who installed it , put + in - and - in +
    I was surprised , is that the high quality of Alpine , where is the protection.?

    Any way . what to do now?



    Alpine CDA-9887 with Imprint
    Alpine SPX-17PRO
    Infinity Reference 9613i
    Alpine PDX-5
    Infinity Kappa 120.3se




  2. #2
    alxmlr789's Avatar
    alxmlr789 is offline 6>5



    Join Date
    Dec 2006
    Location
    FL
    Age
    25
    Posts
    4,869
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: SPX-17PRO burned

    Quote Originally Posted by HNaga View Post
    after wiring SPX-17PRO to PDX-5 , 5 minutes and right door tweeter had no sound
    I turned the HU wihich is CDA-9887 off , checked what happened I found the woofer became solid .

    I found that the guy who installed it , put + in - and - in +
    I was surprised , is that the high quality of Alpine , where is the protection.?

    Any way . what to do now?
    There's your problem.

    The "quality" of alpine is gonna be just as good as your install. I've run alpine amps, so i have no complaints of their quality.

    That ***** pretty bad, but i'd go talk to your guy who installed it. See what he may have been thinking.



    Bought: Tweet02 (x2), bjfish11, pboulos(x3), baseballer1100, ibanender, Duece212, gitusum, jmanjr, Dalucifer, KPR10is, Megalomaniac, oxsign, jmanpc, hoss, 2002xlt, mobeious
    Sold: Mike dressure, Dejawiz, Lax916, Calikid, 88irocZ, lammy, Oxsign, Jblanford, JohnnyBASS, Rocky 59, Megalomaniac, tRdoc, 350_regal, oxsign, sundownz, dont smoke crack, Good*bad*Ugly*, ryanroma, 96TL, VQ35max, Deuce212, darkist240sx, Jhughes, SPY, Gongos, 04silverz, SirJoseph8989, Theothermike (x2), sgdenny, mgbcs, uncfanforlife07, NMBR1SPT, Nukeitall (x2), glasjaw, NeedDirections
    Traded: Rtilaree, mike dressure, megalomaniac, wheeler

    Feedback thread = http://www.caraudio.com/forum/showthread.php?t=224101

  3. #3
    HNaga's Avatar
    HNaga is offline Member

    Threadstarter


    Join Date
    Oct 2008
    Location
    Cairo
    Posts
    115
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: SPX-17PRO burned

    Quote Originally Posted by alxmlr789 View Post
    There's your problem.

    The "quality" of alpine is gonna be just as good as your install. I've run alpine amps, so i have no complaints of their quality.

    That ***** pretty bad, but i'd go talk to your guy who installed it. See what he may have been thinking.
    what should I expect from him? make international order and pay 500 USD?



    Alpine CDA-9887 with Imprint
    Alpine SPX-17PRO
    Infinity Reference 9613i
    Alpine PDX-5
    Infinity Kappa 120.3se

  4. #4
    HNaga's Avatar
    HNaga is offline Member

    Threadstarter


    Join Date
    Oct 2008
    Location
    Cairo
    Posts
    115
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: SPX-17PRO burned

    the problem is I can not even get the tweeter and the woofer as spare parts
    they are both discontinued in Alpine Parts site.

    should I contact Alpine support?



    Alpine CDA-9887 with Imprint
    Alpine SPX-17PRO
    Infinity Reference 9613i
    Alpine PDX-5
    Infinity Kappa 120.3se

  5. #5
    troy_audi0's Avatar
    troy_audi0 is offline Top 100 Installer



    Join Date
    Nov 2005
    Location
    Las Vegas, NV
    Posts
    1,195
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: SPX-17PRO burned

    Quote Originally Posted by HNaga View Post
    I found that the guy who installed it , put + in - and - in +
    I was surprised , is that the high quality of Alpine , where is the protection.?

    Any way . what to do now?
    That would be out of phase.. nothing more..
    I have 300wrms to mine from a JL HD600/4
    check tuning..



    www.Hybrid-audio.com
    Kenwood Nav
    Hybrid Audio L1 Pro SE, L3, L2x, L6
    Arc10 Ported
    Arc Audio 4200SE (Front Stage 110x4)
    Arc Audio 2150SE (Sub)

  6. #6
    HNaga's Avatar
    HNaga is offline Member

    Threadstarter


    Join Date
    Oct 2008
    Location
    Cairo
    Posts
    115
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: SPX-17PRO burned

    Quote Originally Posted by troy_audi0 View Post
    That would be out of phase.. nothing more..
    I have 300wrms to mine from a JL HD600/4
    check tuning..
    I hope so , but I think the tweeter is physically damaged , I checked it with DMM
    and switched the left and right tweeters
    and although the ohm of the woofer is OK , I can see the difference between it and the left woofer , I can not see any move from it.

    yes there is low sound but no as the right one.

    what else I can do?
    Last edited by HNaga; 05-24-2009 at 06:40 PM.



    Alpine CDA-9887 with Imprint
    Alpine SPX-17PRO
    Infinity Reference 9613i
    Alpine PDX-5
    Infinity Kappa 120.3se

  7. #7
    troy_audi0's Avatar
    troy_audi0 is offline Top 100 Installer



    Join Date
    Nov 2005
    Location
    Las Vegas, NV
    Posts
    1,195
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: SPX-17PRO burned

    Quote Originally Posted by HNaga View Post
    I hope so , but I think the tweeter is physically damaged , I checked it with DMM
    and switched the left and right tweeters
    and although the ohm of the woofer is OK but I can see the difference between it and the right woofer , I can not see any move from it.

    yes there is low sound but no as the right one.

    what else I can do?
    do you have a tone genorator?
    you checked that the speaker plays out of the door but not in the door?
    PDX may have clipped & blown the tweeter..
    disconect the mid from the xover & see if the tweet plays..
    then try the tweet pulled & see if the mid plays..
    also check the Jumpers to see if anything is misplaced...
    check dB settings on mid & tweet

    keep us posted..



    www.Hybrid-audio.com
    Kenwood Nav
    Hybrid Audio L1 Pro SE, L3, L2x, L6
    Arc10 Ported
    Arc Audio 4200SE (Front Stage 110x4)
    Arc Audio 2150SE (Sub)

  8. #8
    HNaga's Avatar
    HNaga is offline Member

    Threadstarter


    Join Date
    Oct 2008
    Location
    Cairo
    Posts
    115
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: SPX-17PRO burned

    no.
    woofer is playing but low sound and not detailed as the left one.
    PDX-5 is set to 0 db for all.

    All I did , is I took the damaged tweeter and put it in place of the left (working one) and it didn't work too.
    Jumpers are as they were when comp came , both jumpers are in their place.
    tweeters setting in the corssovers are both 0 db

    I changed only the phase jumpers left is set to 4 and right is set to 3
    the first time I played after installation , there tweeter was producing strange sound with the music something like clicking , chack chack.
    I reduced the sound to 10 in HU for 5 minutes and switch the car off.
    after 2 hours I tried again and there was no sound from the tweeter.

    I think if something wrong in the corssover , the tweeter should work with the other corssover.

    However I can not imagine what had happened , i think it's a short. but I think that the tweeter protection should work then.



    Alpine CDA-9887 with Imprint
    Alpine SPX-17PRO
    Infinity Reference 9613i
    Alpine PDX-5
    Infinity Kappa 120.3se

  9. #9
    troy_audi0's Avatar
    troy_audi0 is offline Top 100 Installer



    Join Date
    Nov 2005
    Location
    Las Vegas, NV
    Posts
    1,195
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: SPX-17PRO burned

    You get them from an Authorized dealer?
    send them back if you did..



    www.Hybrid-audio.com
    Kenwood Nav
    Hybrid Audio L1 Pro SE, L3, L2x, L6
    Arc10 Ported
    Arc Audio 4200SE (Front Stage 110x4)
    Arc Audio 2150SE (Sub)

  10. #10
    Trey803's Avatar
    Trey803 is offline GAMECOCKS



    Join Date
    Jan 2006
    Location
    SC
    Posts
    5,637
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    29 Post(s)

    Re: SPX-17PRO burned

    reversing the phase will not burn the coil......I have my tweeters wired this way because my components are off-axis



    HU: DEH-80PRS
    Doors Deadened
    Front Stage: Rainbow SLC 265
    Front Stage Amp: Image Dynamics i2600
    Sub: Dayton RSS210HF-4 8"
    Sub Amp: Image Dynamics i2300
    Wire: Knu

  11. #11
    HNaga's Avatar
    HNaga is offline Member

    Threadstarter


    Join Date
    Oct 2008
    Location
    Cairo
    Posts
    115
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: SPX-17PRO burned

    @troy_audi0
    I got them from DiscountCentralOnline‏ through Amazon.
    I contacted them and will see what will happen.

    @Trey803:
    what may burn them? I really want to know.



    Alpine CDA-9887 with Imprint
    Alpine SPX-17PRO
    Infinity Reference 9613i
    Alpine PDX-5
    Infinity Kappa 120.3se

  12. #12
    HNaga's Avatar
    HNaga is offline Member

    Threadstarter


    Join Date
    Oct 2008
    Location
    Cairo
    Posts
    115
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: SPX-17PRO burned

    Alpine replaced the woofer and the tweeter and the comp is working fine now.
    Thank all



    Alpine CDA-9887 with Imprint
    Alpine SPX-17PRO
    Infinity Reference 9613i
    Alpine PDX-5
    Infinity Kappa 120.3se

Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum