Closed Thread
Results 1 to 9 of 9

Reload Thread: Stock 6x9's taking 100 watts???

  1. #1
    stocker08's Avatar
    stocker08 is offline Drunk



    Join Date
    Jul 2007
    Location
    Minnesota
    Posts
    935
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    72 Post(s)

    Stock 6x9's taking 100 watts???

    I have a five channel amp that is running all 4 of my speakers and a sub. My rear speakers are just the regular stock 6x9's that come in a 2002 Buick Century. I have been giving them about 70 watts for a good year and now for the past few months, 100 watts since i revieved my new amp. I originally thought they would just blow and I would end up replacing them, but it hasn't happened, actually they dont sound bad at all.....

    Am i just wearing the **** out of them or what? I haven't heard them distort in the least....







  2. #2
    TurdFergueson2's Avatar
    TurdFergueson2 is offline Team D.O.A.



    Join Date
    Aug 2007
    Location
    Chicago
    Posts
    7,051
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    3 Post(s)

    Re: Stock 6x9's taking 100 watts???

    what amp?



    Sold to: Rc10Mike, Philpbak, pbnj123, WALKSUP, silvercookie, Sir Smoke Alot
    Bought from: Korn4life, chaunb3400, fasfocus, mlstrass, Bumpin Buick, wheeler8921, annarbor84

    Quote Originally Posted by Cameron_B View Post
    I pulled into the trailer park at around 3 am bumping my sony xplod 12 on sony amp. **** SLAMS!!!!!! Anways, I pulled up and it got all the girls wet.....I guess im an uncle and a dad now
    Quote Originally Posted by Cameron_B View Post
    Don't listen to all the haters, their shiz doesnt knock...EDIT: Ohh yea, and by the way....before you haters start mouthing, I got my SLAB from wall-mart....that ish doesnt bang it XPLODES. Yea..I run sony... Schoche -SP box with 4 inch PVC downfiring into pasenger wheel well. 5-6 inch streamers...

  3. #3
    SicAudio's Avatar
    SicAudio is offline did you fart dude?



    Join Date
    Apr 2009
    Location
    melting HO alts...
    Age
    43
    Posts
    6,202
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2 Post(s)

    Re: Stock 6x9's taking 100 watts???

    eventually they will wear out does your car have the premium sound option? if it does that would be why they sound decent and take the power ( for now lolz )

    also depending on the amp you may be only pushing 25 rms who knows




  4. #4
    01 S 10's Avatar
    01 S 10 is offline LOUD



    Join Date
    Jan 2008
    Location
    Central Florida
    Age
    27
    Posts
    4,278
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2 Post(s)

    Re: Stock 6x9's taking 100 watts???

    what amp?

    i had a set of Pioneer Premier 6x9's running off the back channels of my sax100.4 (so atleast 100w rms each) and they would get stinkyyyy and verrryyy hot if i pushed them. its hard to believe stock speakers are taking 100w RMS.



    -2005 GMC Sierra SLE crew cab
    -Pioneer Avic-d3, factory BOSE

  5. #5
    SicAudio's Avatar
    SicAudio is offline did you fart dude?



    Join Date
    Apr 2009
    Location
    melting HO alts...
    Age
    43
    Posts
    6,202
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2 Post(s)

    Re: Stock 6x9's taking 100 watts???

    I am willing to bet that they are 8ohm speakers ( very unlikely ) or the amp isn't really 100 watts or anywhere close to it .
    just my .02 cents




  6. #6
    stocker08's Avatar
    stocker08 is offline Drunk

    Threadstarter


    Join Date
    Jul 2007
    Location
    Minnesota
    Posts
    935
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    72 Post(s)

    Re: Stock 6x9's taking 100 watts???

    They were running off an Alpine MRP-F450 and then i got rid of that and now i have them running off a U.S. Amps Xterminator 5500x




  7. #7
    thevic24's Avatar
    thevic24 is offline my silence is deadly...



    Join Date
    Apr 2007
    Location
    right behind you
    Posts
    5,822
    Post Thanks / Like
    Images
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    363 Post(s)

    Re: Stock 6x9's taking 100 watts???

    Quote Originally Posted by SicAudio View Post
    I am willing to bet that they are 8ohm speakers ( very unlikely ) or the amp isn't really 100 watts or anywhere close to it .
    just my .02 cents
    my wifes olds came with 6ohm 6x9's stock so that could be what he has. they only lasted about 4 months before one of the coils burned.



    Silently stalking you through glass....

  8. #8
    01 S 10's Avatar
    01 S 10 is offline LOUD



    Join Date
    Jan 2008
    Location
    Central Florida
    Age
    27
    Posts
    4,278
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2 Post(s)

    Re: Stock 6x9's taking 100 watts???

    what are the specs on that amp? or a link to specs..



    -2005 GMC Sierra SLE crew cab
    -Pioneer Avic-d3, factory BOSE

  9. #9
    stocker08's Avatar
    stocker08 is offline Drunk

    Threadstarter


    Join Date
    Jul 2007
    Location
    Minnesota
    Posts
    935
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    72 Post(s)

    Re: Stock 6x9's taking 100 watts???





Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum