Closed Thread
Results 1 to 12 of 12

Reload Thread: Just installed speaks 720prs not good!!

  1. #1
    tryan77's Avatar
    tryan77 is offline Senior VIP Member



    Join Date
    Feb 2009
    Location
    Milwaukee
    Posts
    189
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Just installed speaks 720prs not good!!

    I just installed a pair of pioneer 720prs components in my 07 Explorer and they sound great...until i turn them up. The woofer is slapping on the door panel. I did not use any mdf spacers but i did you use the 6.5 converter kit which is very thin. I have no idea how to fix this. Spent all friggen day wirin these puppies in and now i have to deal with this Any ideas?







  2. #2
    James Bang's Avatar
    James Bang is offline Hand/Ear Coordination



    Join Date
    Aug 2005
    Location
    ^
    Age
    30
    Posts
    13,016
    Post Thanks / Like
    Images
    8
    Mentioned
    0 Post(s)

    Re: Just installed speaks 720prs not good!!

    So is it the speakers that doesn't sound good or your install?




  3. #3
    tryan77's Avatar
    tryan77 is offline Senior VIP Member

    Threadstarter


    Join Date
    Feb 2009
    Location
    Milwaukee
    Posts
    189
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Just installed speaks 720prs not good!!

    The speaker sounds good but when I turn them up and the bass hits the woofer is slapping on the door panel.




  4. #4
    bamaboy's Avatar
    bamaboy is offline War Eagle!!!



    Join Date
    Oct 2004
    Location
    Auburn, Alabama
    Age
    25
    Posts
    7,206
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Just installed speaks 720prs not good!!

    if it will fit-put the grill on the speaker, put door panel back on...the end




    04 Explorer
    Kenwood DDX812
    RF 3Sixty.2
    T6004
    T4002
    T40001bd
    Hertz MLK-2 running Active
    Hertz HCX165
    4x DC Audio LVL 4 12"s

    Summer 09' Build...Operation:Pull Wall out, put new subs in DONE!
    Build
    Photobucket
    now with video

  5. #5
    tryan77's Avatar
    tryan77 is offline Senior VIP Member

    Threadstarter


    Join Date
    Feb 2009
    Location
    Milwaukee
    Posts
    189
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Just installed speaks 720prs not good!!

    Quote Originally Posted by bamaboy View Post
    if it will fit-put the grill on the speaker, put door panel back on...the end
    Dammit I had it on there but i was worried that the panel wouldnt fit back on. Youre the man.

    You win 1,000 car audio internetz.

    Thanks man.




  6. #6
    mcsoul's Avatar
    mcsoul is offline such is life



    Join Date
    Mar 2008
    Location
    dfw
    Posts
    4,427
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Just installed speaks 720prs not good!!

    Here's what I did, birch rings with PE gasket tape on either side:




    ________________________
    Car: 2004 Nissan Altima 3.5 manual
    Head unit: Alpine CDA-9815 (running active)
    Midbass: Morel HU-621 Hybrid Uniflow 8 ohms
    Mid Amp: Audison lrx 4.300 bridged 2x140w @ 8 ohms
    Doors: 24ft Damplifier Pro, Second Skin D-flex pads, eggcrate foam, sealed up.
    Tweeter: SEAS 27TFFNC
    High Amp: Audison Lrx-2.150
    Subs: Two RE SE 12 d4's
    Box: 4 cubes net at 30hz
    Sub Amp: Sound Stream Van Gough 1600.2
    Electrical: Knu Flex 1/0, Batcap 2000 in back
    Rear Deck: No 6x9's just holes and grills

  7. #7
    tryan77's Avatar
    tryan77 is offline Senior VIP Member

    Threadstarter


    Join Date
    Feb 2009
    Location
    Milwaukee
    Posts
    189
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Just installed speaks 720prs not good!!

    Quote Originally Posted by mcsoul View Post
    Here's what I did, birch rings with PE gasket tape on either side:

    Yeah but that wouldnt work in my app and it would actually make it worse because then the woofer would be slammed up against the panel. You must have alot of space between your door and the panel.




  8. #8
    James Bang's Avatar
    James Bang is offline Hand/Ear Coordination



    Join Date
    Aug 2005
    Location
    ^
    Age
    30
    Posts
    13,016
    Post Thanks / Like
    Images
    8
    Mentioned
    0 Post(s)

    Re: Just installed speaks 720prs not good!!

    Quote Originally Posted by bamaboy View Post
    if it will fit-put the grill on the speaker, put door panel back on...the end
    too practical/logical.




  9. #9
    tryan77's Avatar
    tryan77 is offline Senior VIP Member

    Threadstarter


    Join Date
    Feb 2009
    Location
    Milwaukee
    Posts
    189
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Just installed speaks 720prs not good!!

    Quote Originally Posted by James Bang View Post
    too practical/logical.
    No kidding.




  10. #10
    Xprime4's Avatar
    Xprime4 is offline ****in' canadian



    Join Date
    Jul 2008
    Location
    Quebec, Canada
    Age
    28
    Posts
    2,728
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Just installed speaks 720prs not good!!

    any pics would help ... mdf adaptor are easy to make too




  11. #11
    theothermike's Avatar
    theothermike is offline I HAVE NO LIFE, CA = LIFE



    Join Date
    May 2006
    Location
    Tampa
    Posts
    1,557
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Just installed speaks 720prs not good!!

    sounds like on ur door panel the stock cup is still installed. some thin plastic lining around the grill on the inside.

    cut this off. (i use utility knife with fresh blade and some patience) or u can use an angle grinder to wear off the plastic.

    then reinstall.

    Mike



    System:
    Fronts:ID Oem's & TBI Hdss Front Amps: Sundown Sax 100.2 & 100.4
    Subwoofer: 2x 12" Fi X D4s Sub Amps: Sundown Saz 1500D
    Headunit: Alpine CDA-9887 Batteries / Alternator: Powermaster / Mechman
    Deadener: Raamat BXT Ensolite Alarm: Clifford 50.5x
    References:
    -Premieraudio-Sundownz-Iamamp3pimp-Kpr10is-Jmanpc- MemphisLove-Greekpower-The 727 Kid-Gixxer9-Mobieous-Audiobahnuser18-Thewes-Steveyhustle-Gymfreak101-go_go_thrash

  12. #12
    mcsoul's Avatar
    mcsoul is offline such is life



    Join Date
    Mar 2008
    Location
    dfw
    Posts
    4,427
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Just installed speaks 720prs not good!!

    Quote Originally Posted by tryan77 View Post
    Yeah but that wouldnt work in my app and it would actually make it worse because then the woofer would be slammed up against the panel. You must have alot of space between your door and the panel.
    I do have decent space. Sorry my brain's not working today
    most days actually.



    ________________________
    Car: 2004 Nissan Altima 3.5 manual
    Head unit: Alpine CDA-9815 (running active)
    Midbass: Morel HU-621 Hybrid Uniflow 8 ohms
    Mid Amp: Audison lrx 4.300 bridged 2x140w @ 8 ohms
    Doors: 24ft Damplifier Pro, Second Skin D-flex pads, eggcrate foam, sealed up.
    Tweeter: SEAS 27TFFNC
    High Amp: Audison Lrx-2.150
    Subs: Two RE SE 12 d4's
    Box: 4 cubes net at 30hz
    Sub Amp: Sound Stream Van Gough 1600.2
    Electrical: Knu Flex 1/0, Batcap 2000 in back
    Rear Deck: No 6x9's just holes and grills

Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum