Closed Thread
Results 1 to 3 of 3

Reload Thread: SPX-13Ref Help !!!!!

  1. #1
    killahsharksjc's Avatar
    killahsharksjc is offline Senior VIP Member



    Join Date
    Mar 2005
    Location
    San Jose
    Age
    35
    Posts
    277
    Post Thanks / Like
    Mentioned
    0 Post(s)

    SPX-13Ref Help !!!!!

    Heres the system http://www.caraudio.com/forum/showthread.php?t=380102

    My problem is I only had them hooked up for 2 days and one of my mid woofers cracked on the alum cone. Its not blown just cracked My gain is set at 1/4 up I cranked it up twice and they seamed like they wanted more power. They sound great. Maybe lacking in the midbass a tad. I bought them from another CA member so warranty is probably out the question. I emailed Pacparts for a replacement but no word back from them till Monday. They have the spx-13pro mid. Would that make up for the Ref mid? Would it work with the crossover that i have. I dont know what to do. So any advice would be appreciated. Thanks







  2. #2
    killahsharksjc's Avatar
    killahsharksjc is offline Senior VIP Member

    Threadstarter


    Join Date
    Mar 2005
    Location
    San Jose
    Age
    35
    Posts
    277
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: SPX-13Ref Help !!!!!





  3. #3
    killahsharksjc's Avatar
    killahsharksjc is offline Senior VIP Member

    Threadstarter


    Join Date
    Mar 2005
    Location
    San Jose
    Age
    35
    Posts
    277
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: SPX-13Ref Help !!!!!





Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum