Closed Thread
Results 1 to 3 of 3

Reload Thread: I have engine noise / static coming from one speaker? Any ideas

  1. #1
    Sierra08!'s Avatar
    Sierra08! is offline Senior VIP Member



    Join Date
    Jul 2008
    Location
    New Orleans, LA
    Posts
    182
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    I have engine noise / static coming from one speaker? Any ideas

    Just installed a JL 4channel, the front right speaker has noticeable static not really engine noise, so I switched the one RCA to rear and then that one has the same noise, could it bee one bad RCA?







  2. #2
    helotaxi's Avatar
    helotaxi is offline Kilroy was Here



    Join Date
    Dec 2003
    Location
    South Central (New Mexico that is...)
    Age
    39
    Posts
    8,933
    Post Thanks / Like
    Images
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: I have engine noise / static coming from one speaker? Any ideas

    Sounds like a bad RCA. Check to make sure that the RCA connector is fully screwed together.



    Artificial Intelligence is no match for Natural Stupidity.

    Never underestimate the power of stupid people in large numbers.

    Life's tough...it's even tougher when you're stupid.

  3. #3
    Sierra08!'s Avatar
    Sierra08! is offline Senior VIP Member

    Threadstarter


    Join Date
    Jul 2008
    Location
    New Orleans, LA
    Posts
    182
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: I have engine noise / static coming from one speaker? Any ideas

    Tried that, one was loose thou, screwed tighter, and still the same, I might have to run a new rca to see if that fixes it




Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum