Closed Thread
Results 1 to 13 of 13

Reload Thread: PG RSD's dont sound good when turned up.

  1. #1
    Tearlessj's Avatar
    Tearlessj is offline Junior Member



    Join Date
    Oct 2008
    Location
    Memphis TN
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)

    PG RSD's dont sound good when turned up.

    Ok Im running the PG RSD 65cs in the front and the PG RSD6.5 coaxial in the back. All powered by a Alpine MRP F550.

    RMS Power @ 4 ohms: 4 x 90W RMS (4ohms, 14.4V, 0.08% THD)

    With the gain set at 0 front and rear. Frequency set at 45 for the front and 65 in the rear. When I crank my headunit all the way, it sounds like its distorting a little. I know some guys pushing way more power than this. Why do mine do this? Any settings i should mess with?







  2. #2
    Stephen_c's Avatar
    Stephen_c is offline MR. Crunk



    Join Date
    Aug 2008
    Location
    downtown
    Age
    25
    Posts
    1,768
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: PG RSD's dont sound good when turned up.

    maybe you headunit is causing it.

    i can go to 32 of 35 on my kenwood before it distorts.




  3. #3
    Twistid's Avatar
    Twistid is offline 150.5



    Join Date
    Jun 2004
    Location
    in a space out of sound
    Posts
    9,588
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: PG RSD's dont sound good when turned up.

    Quote Originally Posted by Tearlessj View Post
    Ok Im running the PG RSD 65cs in the front and the PG RSD6.5 coaxial in the back. All powered by a Alpine MRP F550.

    RMS Power @ 4 ohms: 4 x 90W RMS (4ohms, 14.4V, 0.08% THD)

    With the gain set at 0 front and rear. Frequency set at 45 for the front and 65 in the rear. When I crank my headunit all the way, it sounds like its distorting a little. I know some guys pushing way more power than this. Why do mine do this? Any settings i should mess with?
    Don't turn your headunit all the way up



    "A modest little person, with much to be modest about."
    Winston Churchill

    REFS: Spicmonster(buyer), playa1(buyer), splthunder(buyer), 949runner (seller), dbman150 (trade), pbulous (trade), bumpin97jeep(trade) , spudracer326 (seller) , 99stanggt (seller) , xplicitACTS (trade) ... and forgetting a few others
    BHCSAOWKF

  4. #4
    Innovative:Cory's Avatar
    Innovative:Cory is offline CarAudio.com Elite



    Join Date
    Apr 2008
    Location
    Southern Indiana
    Age
    33
    Posts
    603
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: PG RSD's dont sound good when turned up.

    Quote Originally Posted by Tearlessj View Post
    Ok Im running the PG RSD 65cs in the front and the PG RSD6.5 coaxial in the back. All powered by a Alpine MRP F550.

    RMS Power @ 4 ohms: 4 x 90W RMS (4ohms, 14.4V, 0.08% THD)

    With the gain set at 0 front and rear. Frequency set at 45 for the front and 65 in the rear. When I crank my headunit all the way, it sounds like its distorting a little. I know some guys pushing way more power than this. Why do mine do this? Any settings i should mess with?

    1 you answered your own question

    2 the volume knob, button



    Refs:

    Rhoughton1, Captincheesey,Snoopdan,

    Sold to: 1980Supreme, KH971, fatboyracing(couple of times)

    Bought from: Brian GT PRO, Aztec

  5. #5
    mlstrass's Avatar
    mlstrass is offline Shaggy DOA



    Join Date
    Jul 2006
    Location
    Illinois
    Posts
    10,403
    Post Thanks / Like
    Mentioned
    28 Post(s)

    Re: PG RSD's dont sound good when turned up.

    also might need to set the HPF higher if you want to push them that hard...




  6. #6
    skateboardkid's Avatar
    skateboardkid is offline CarAudio.com Elite



    Join Date
    Nov 2007
    Location
    Ashland oregon
    Posts
    1,430
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: PG RSD's dont sound good when turned up.

    set your HU volume to about 3/4 and then turn up your gains untill they distort or they are loud enough, set your frequency at like 60Hz and see if you can stand them at 80Hz for both of them, they are being crossed over around 80-100Hz when you see people pushing 150 to each speaker.



    “It takes only one drink to get me drunk. The trouble is, I can't remember if it's the thirteenth or the fourteenth.”
    -Benjamin Frankin

    Quote Originally Posted by FoxPro5 View Post
    True midbass begins when the impact is so accurate and realistic that it sounds like someone is beating on the front part of your dash with a baseball bat.

  7. #7
    tcguy85's Avatar
    tcguy85 is offline CarAudio.com Veteran



    Join Date
    Feb 2007
    Location
    Hyde Park, NY
    Age
    29
    Posts
    3,527
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: PG RSD's dont sound good when turned up.

    use an 80hz crossover point instead of the 45hz. that's your main problem. but also set your amps gains at 3/4 volume on the HU.



    07 Scion tC: 880PRS, ID OEM 6.5" mids, Seas neo alum tweets, DD S4 and DD C2a amps, Dayton Ref H.O. 10(.7net, tuned to 30hz)

    HT: Samsung PN58B560 - 80gig PS3 - Yamaha RX-V2500 - Infinity Alpha 50 mains - Alpha center - Harmon Kardon HKB6 rears, Epik Sentinel & ED eQ.2.

  8. #8
    SSS 18734's Avatar
    SSS 18734 is offline Dollar Menu Millionaire



    Join Date
    Mar 2005
    Location
    Kansas City, MO
    Posts
    5,457
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: PG RSD's dont sound good when turned up.

    By 45 do you mean you have your HPF set at 45hz?

    If so, set to to about 60-80 like others here have mentioned. That should help quite a bit.



    Bought From:
    Absolutnockout, zachzchw, Untouchable11, j3bus2k3 (x2), 92c1v1c, jeeper07, acubsfan, bkjt05, Goldenknob, Goindef154, Basscourt2009, TeamSouthrnBass, oldschoolboomer, 99grandprixGT
    Sold to:
    Gearguy2001 (American Bass SQ780)
    Tw1st3d13 (2 Fi BL 15's)

  9. #9
    smgreen20's Avatar
    smgreen20 is offline phoenixphorum-com



    Join Date
    Apr 2005
    Location
    Lafayette,IN
    Age
    37
    Posts
    1,170
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: PG RSD's dont sound good when turned up.

    I gave mine (actively) 75w to the tweets, 100 to the mids, no problems at all. I have friends that are pushing way more then that to them w/o problems. My initial thought was w/the majority, set the HP at 63 Hz at a min of 12 dB/oct.




    My install
    http://phoenixphorum.com/viewtopic.php?f=10&t=16998

  10. #10
    redcalimp5's Avatar
    redcalimp5 is offline Loud 'N Clear



    Join Date
    Oct 2007
    Location
    So Cal
    Posts
    933
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: PG RSD's dont sound good when turned up.

    They don't sound good at high volumes because they're an $80 set of components.



    Alpine~Rainbow

    Refs~
    6spdcoupe, mlstrass, kmanian, F150Truck'in, PremierAudio, jblayz1, dbrown, BoondockSaints, jacka, flava30, hessdawg, ebrunn, JayRich, Blinkdogo2

  11. #11
    smgreen20's Avatar
    smgreen20 is offline phoenixphorum-com



    Join Date
    Apr 2005
    Location
    Lafayette,IN
    Age
    37
    Posts
    1,170
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: PG RSD's dont sound good when turned up.

    I bought a set of Dynaudios for $100. Does that mean they don't sound good. *Store closed the doors*

    Some people need to get over that "I paid more so mine's better" mentality.

    The xover is the week link in that set. That's what is limiting the power you can give them. BUT, it will still take more then what it's rated for. All in all, you're xover point was to low. That's the real reason why.




    My install
    http://phoenixphorum.com/viewtopic.php?f=10&t=16998

  12. #12
    Slammed's Avatar
    Slammed is offline Benny Lava



    Join Date
    Apr 2004
    Location
    Gotham City, NY
    Age
    33
    Posts
    29,319
    Post Thanks / Like
    Images
    7
    Mentioned
    20 Post(s)

    Re: PG RSD's dont sound good when turned up.

    Quote Originally Posted by redcalimp5 View Post
    They don't sound good at high volumes because they're an $80 set of components.







    Honda H/U - PG RSD65 - Seas Neo - Audiocontrol LC6 - Blaupunkt BX-01E - MTX 405 Amplifer - 03 E15K (32hz)

  13. #13
    Slammed's Avatar
    Slammed is offline Benny Lava



    Join Date
    Apr 2004
    Location
    Gotham City, NY
    Age
    33
    Posts
    29,319
    Post Thanks / Like
    Images
    7
    Mentioned
    20 Post(s)

    Re: PG RSD's dont sound good when turned up.

    Quote Originally Posted by tcguy85 View Post
    use an 80hz crossover point instead of the 45hz. that's your main problem. but also set your amps gains at 3/4 volume on the HU.





    Honda H/U - PG RSD65 - Seas Neo - Audiocontrol LC6 - Blaupunkt BX-01E - MTX 405 Amplifer - 03 E15K (32hz)

Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum