Closed Thread
Results 1 to 3 of 3

Reload Thread: Tweeter Problem

  1. #1
    Alpineforever's Avatar
    Alpineforever is offline CarAudio.com Elite



    Join Date
    Feb 2008
    Location
    Austin/Arlington TX
    Age
    24
    Posts
    668
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Tweeter Problem

    My right tweeter recently cut out but it's not blown or anything, it works just fine as long as something is in contact with the cone (i.e. it works when i gently touch the cone with my finger or any other object, but as soon as i release my hand it stops playing). However it stops working as soon as I'm not in contact with the cone. Is there a reason it does this and is there anything i can do to fix it? It is the tweeter from my PG RSD set thats in my sig. It also works if I apply pressure to the speaker wire connected to that tweeter.

    Any help is appreciated







  2. #2
    Alpineforever's Avatar
    Alpineforever is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Feb 2008
    Location
    Austin/Arlington TX
    Age
    24
    Posts
    668
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Tweeter Problem

    has no one ever had this happen to them before, wtf is up?




  3. #3
    Buck's Avatar
    Buck is offline always low Buck is a Supporting Member of the forum!



    Join Date
    May 2008
    Location
    Nashville
    Posts
    18,378
    Post Thanks / Like
    Mentioned
    253 Post(s)

    Re: Tweeter Problem

    thats strange. maybe just get some new tweeters



    Alpine - ASE (local) - Batcap - C&D Tech - CT Sounds - DC - eD - Excessive Amperage - Rainbow

Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum