Closed Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 16

Reload Thread: New Tweeters blown already?

  1. #1
    PuZo's Avatar
    PuZo is offline Senior VIP Member



    Join Date
    Jan 2008
    Location
    Toronto, Canada
    Posts
    409
    Post Thanks / Like
    Mentioned
    0 Post(s)

    New Tweeters blown already?

    I just got a set of phoenix gold rsd's and hook them up. They are 65 w rms and my amp is 60rms per channel. It is a 4 chan amp, so I bridged 2 channels together. I was listening to it and everything was going good, then all of a sudden the tweeters are gone, cant hear them anymore. How could they have blown so easily/quickly? I didnt put it high at all.







  2. #2
    dragnix's Avatar
    dragnix is offline LXIX



    Join Date
    Dec 2006
    Location
    Socal cuz i'm So cool
    Posts
    19,635
    Post Thanks / Like
    Mentioned
    21 Post(s)

    Re: New Tweeters blown already?

    perhaps you have gained turned on too high?




  3. #3
    edzy's Avatar
    edzy is offline SPL Ninja



    Join Date
    Feb 2007
    Location
    Where you live
    Posts
    2,188
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: New Tweeters blown already?

    "They are 65 w rms and my amp is 60rms per channel. It is a 4 chan amp, so I bridged 2 channels together"
    Depending on what amp it is, bridged is twice the wattage, so maybe you put 120 watts on the 65 watt speakers. And you had the gain too high.



    Nothing to see here, Move along.

  4. #4
    PuZo's Avatar
    PuZo is offline Senior VIP Member

    Threadstarter


    Join Date
    Jan 2008
    Location
    Toronto, Canada
    Posts
    409
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: New Tweeters blown already?

    so is it too late or can I turn down the gain?




  5. #5
    edzy's Avatar
    edzy is offline SPL Ninja



    Join Date
    Feb 2007
    Location
    Where you live
    Posts
    2,188
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: New Tweeters blown already?

    set the gain correctly, it may need to go up or down, depends on the HU voltage. its not a volume knob. and yes, its too late for the tweets.



    Nothing to see here, Move along.

  6. #6
    PuZo's Avatar
    PuZo is offline Senior VIP Member

    Threadstarter


    Join Date
    Jan 2008
    Location
    Toronto, Canada
    Posts
    409
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: New Tweeters blown already?

    is it possible to buy replacement tweets from somewhere?




  7. #7
    Towncar's Avatar
    Towncar is offline CarAudio.com Veteran



    Join Date
    Dec 2005
    Location
    who knows
    Posts
    4,346
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: New Tweeters blown already?

    Quote Originally Posted by PuZo View Post
    is it possible to buy replacement tweets from somewhere?
    Call pg, they should have them. Sounds pretty wierd that both tweets would go out at the same time.




  8. #8
    king ranch's Avatar
    king ranch is offline Banned



    Join Date
    Dec 2007
    Location
    fl
    Posts
    5,671
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: New Tweeters blown already?

    how did you set the gains and where was the gain knob at like halfway or more




  9. #9
    mokedaddy's Avatar
    mokedaddy is offline professional idiot



    Join Date
    Apr 2005
    Location
    Siccmade house
    Age
    35
    Posts
    4,902
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: New Tweeters blown already?

    Quote Originally Posted by king ranch View Post
    how did you set the gains and where was the gain knob at like halfway or more
    Completely irrelevant question. That is install dependent.



    'a man without enemies, is a man without character'


  10. #10
    DjiNN's Avatar
    DjiNN is offline Posts but still a NooB



    Join Date
    Jun 2006
    Location
    Brooklyn, NY
    Age
    30
    Posts
    1,476
    Post Thanks / Like
    Images
    1
    Mentioned
    0 Post(s)

    Re: New Tweeters blown already?

    ive had my PG's in for a week and im putting ~150w per side .. and they sound great .. def more midbass compared to the Rainbows i had ..



    Vehicle : Subaru Impreza 2010


    Refs : 6spdcoupe, gl0ck

  11. #11
    PuZo's Avatar
    PuZo is offline Senior VIP Member

    Threadstarter


    Join Date
    Jan 2008
    Location
    Toronto, Canada
    Posts
    409
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: New Tweeters blown already?

    I had the full 60watts rms per chan going, so bridged is around 120, and the the hpf I set to 80 and that all I know about the controls on the amp.




  12. #12
    king ranch's Avatar
    king ranch is offline Banned



    Join Date
    Dec 2007
    Location
    fl
    Posts
    5,671
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: New Tweeters blown already?

    how did u set your gains




  13. #13
    king ranch's Avatar
    king ranch is offline Banned



    Join Date
    Dec 2007
    Location
    fl
    Posts
    5,671
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: New Tweeters blown already?

    u set by ear or dmm




  14. #14
    coledawg's Avatar
    coledawg is offline Where the Hell am I?



    Join Date
    Aug 2007
    Location
    Macon,GA
    Posts
    495
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: New Tweeters blown already?

    try looking at speaker wires and all wires one might came loose on the amp or crossover



    Sub- 1 12" Type R wired to 1ohm in Custom Ported Box
    Amp- TXi7508 Hifonics
    Front Amp- Pr100.2 Memphis
    Front Fill- Memphis 15-MSYNC6
    Rear Fill- Rockford Fosgate P163C 6.5s
    HU- Eclipse 3200
    all 4 gauge and Tsnaumi Fused Distro Block
    1998 Honda Accord EX V6

  15. #15
    mazzasec's Avatar
    mazzasec is offline Banned



    Join Date
    Dec 2007
    Location
    ATL
    Posts
    6,875
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: New Tweeters blown already?

    i thought this was a common problem with the RSD's
    edit: just found the threads to seems to be common

    http://www.caraudio.com/forum/showth...t=blew+tweeter

    http://www.caraudio.com/forum/showth...t=blew+tweeter




Closed Thread
Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum