Closed Thread
Results 1 to 7 of 7

Reload Thread: Pioneer Rev's installed.....power question

  1. #1
    snowboardracer's Avatar
    snowboardracer is offline Junior Member



    Join Date
    Jan 2008
    Location
    PA
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Pioneer Rev's installed.....power question

    I just installed a set of Pioneer Rev's (6x8) coaxials in my rear deck. I'm waiting to install the front two when I make my required spacer -- these things are deep!

    They sound GREAT! When I fade and balance all the sound from my stock HU (18x4 with ford Mach amp), the bass is TREMENDOUS coming from the one rear speaker. When it is faded all the way to both back speakers, the bass disappears. If it is balanced all left (or right), the REV in the back sounds great with good bass, the front speaker (infinity reference) sounds decent as well.

    Would the REVs sound that good x4 if I amped them? Or do they just need broken in? Am I correct in assuming that putting all the sound to one speaker is giving the speaker the entire wattage my Mach amp can output (60~80 watts)?

    If so, if I should amp them, they are 60 rms each. Any suggestion for a great amp? Would the JL 300/4 @ 75x4 be too much? Thanks!







  2. #2
    ls2poweredgoat's Avatar
    ls2poweredgoat is offline Womanizer



    Join Date
    May 2007
    Location
    Port St. Lucie FL
    Posts
    5,447
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Pioneer Rev's installed.....power question

    Amp them!



    No advertising in sigs

  3. #3
    BEAVER.989's Avatar
    BEAVER.989 is offline CarAudio.com Elite



    Join Date
    Apr 2006
    Location
    Michigan
    Posts
    779
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Pioneer Rev's installed.....power question

    Am I correct in assuming that putting all the sound to one speaker is giving the speaker the entire wattage my Mach amp can output (60~80 watts)?
    No. But you should amp them.



    Alpine CDA-9887 - PG Xenon 100.4 - PG Xenon 600.1 - IDQ10V3(1.3cft. @ 28hz) - Polk SR6501 mids - Seas Neo's - Knuconceptz - RAAMAudio
    Common sense is far from common.

  4. #4
    99StangGt's Avatar
    99StangGt is offline CarAudio.com Elite



    Join Date
    Mar 2005
    Location
    Oregon
    Age
    50
    Posts
    1,303
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Pioneer Rev's installed.....power question

    Check and make sure the phase is correct . If wrong the bass is lost when running the balance in the middle and comes back when balance turned to the right or left.




  5. #5
    snowboardracer's Avatar
    snowboardracer is offline Junior Member

    Threadstarter


    Join Date
    Jan 2008
    Location
    PA
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Pioneer Rev's installed.....power question

    Thank you so much! The speakers were out of phase. I can't believe i had them wired up wrong...ugh. They sound AMAZING now! I can't wait to get my spacers done to put in the fronts.




  6. #6
    Join Date
    May 2007
    Location
    boston
    Posts
    45
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Pioneer Rev's installed.....power question

    fading and balancing is not giving all the power to one speaker its taking it away from the others. i belive you have one of the rears out of phase (pos and neg backwards) recheck your wireing.
    ps. any speaker sounds better with a good amp powering them



    edit: missed the post above me




  7. #7
    LaserRed38's Avatar
    LaserRed38 is offline CarAudio.com Veteran



    Join Date
    Nov 2007
    Location
    Bay Area, CA
    Posts
    2,337
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    34 Post(s)

    Re: Pioneer Rev's installed.....power question

    Do you have a Mustang? If so...why did you even get rear speakers?



    2005 Escape XLT Sport
    Alpine CDA-9835 - Audison LRx5.1k - Hertz MLK 2 TM - Hertz ML1600 - Hertz HX300
    Audison Wiring - Optima Red Top - Dynamat Extreme
    Refs
    [Bought from] dcmcki, 90accordman, MikeyB, itzme218, redcalimp5, SVT_RELAMPAGO, Johnny_Drama, RollinGTO, Fast1One, tc3k101, ramk1018, Brian_Smith06, John_Pionke, BigOso, TeamPSI, pickup1, PatFitz9, pro-rabbit, oldschoolboomer
    [Sold to] darqnez, tipnitty, Mugatu0, MrChow, nineball, SocialStealth, macq32, .livin.loud., slappinX, GlassEyez, Jeremy M, Honez
    [Traded with] James Bang, MovnZ28

Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum