Closed Thread
Results 1 to 2 of 2

Reload Thread: Tweets hook up? And ground loop?

  1. #1
    DirtyP's Avatar
    DirtyP is offline Member



    Join Date
    Feb 2007
    Location
    new london , ct
    Posts
    59
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Tweets hook up? And ground loop?

    I have a extra pair of tweets and was thinking of putting them in the rear with the 6 x 9s.

    Will they work like this or will I need a crossover?

    And I have a ground loop isolater, I was looking for something to stop this popping noise in the subs. It only does this with one amp but its the stronger one. It starts as soon as the deck comes on and doesnt change with volume.

    Will this fix this?



    http://www.waronyou.com
    http://www.motorcycletrader.info
    http://www.sectlandscaping.com




  2. #2
    Daishi's Avatar
    Daishi is offline Member



    Join Date
    Nov 2006
    Location
    Jersey
    Posts
    126
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Tweets hook up? And ground loop?

    try it out couldnt hurt.. I had a similar grounding issue accept i was getting a whine out of my tweets.. i had perfect grounds and everything.. Everything i did i wasnt able to get rid of the whine then i got a loop isolator and it went away.. it was the last choice or else i would of had to kill myself lol.



    References:
    Baseballer1100(x2),dvrmstrng, RedlineAccord


    System:
    Pioneer DEH-P880PRS
    6.5" Rainbow Germaniums
    Us Amps MD22
    2 12" Fi SSDS
    2x Hifonics BXi 1206D
    4.2 cu ft Ported box
    Kinetik 1400

Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum