Closed Thread
Results 1 to 4 of 4

Reload Thread: Crossover help

  1. #1
    nwo504's Avatar
    nwo504 is offline Member



    Join Date
    Feb 2003
    Location
    New Orleans
    Posts
    113
    Post Thanks / Like
    Images
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Crossover help

    One of my crossovers isnt allowing my tweeter to play at all. The mids works fine but no higs come through at all. I thought it was the tweeter itself but i sitched crossovers from my left speakers and the tweeter played just fine. What could be wrong with it?? Its a kicker SS system



    --system--
    HU: alpine
    FroNt PEAKERS: Kicker SS56.2
    ReAR (fill): stock 6.9s"
    AMP1: Kicker KX200.2
    AMP2: AudioBahn a8002t amp
    SUB : Kicker L7 12" Solo-baric
    AUX: Apple Ipod 20 GiG 4th Gen




  2. #2
    mike dressure's Avatar
    mike dressure is offline enthusiast



    Join Date
    Dec 2006
    Location
    mt home-boise Idaho
    Posts
    4,131
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Crossover help

    could be a manufaturer defect, terminal could be loose, etc.




  3. #3
    Rich B's Avatar
    Rich B is offline CarAudio.com Veteran



    Join Date
    Oct 2006
    Location
    *under the rainbow*
    Posts
    6,302
    Post Thanks / Like
    Images
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    161 Post(s)

    Re: Crossover help

    Some crossovers have what amounts to a small lightbulb inside the case acting as a fuse for tweeter protection in case its cranked up too loud.

    You might have blown that, but you'll have to open up the crossover casing to verify it if your manual doesnt mention it.




  4. #4
    nwo504's Avatar
    nwo504 is offline Member

    Threadstarter


    Join Date
    Feb 2003
    Location
    New Orleans
    Posts
    113
    Post Thanks / Like
    Images
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Crossover help

    It used to work perfectly until I took thme out to put them in the new car. Theres this blue diode that fell off the xover. should i just solder it back on or get a new replacement crossover?



    --system--
    HU: alpine
    FroNt PEAKERS: Kicker SS56.2
    ReAR (fill): stock 6.9s"
    AMP1: Kicker KX200.2
    AMP2: AudioBahn a8002t amp
    SUB : Kicker L7 12" Solo-baric
    AUX: Apple Ipod 20 GiG 4th Gen

Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum