Closed Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 16

Reload Thread: Tweeter problem.

  1. #1
    the727kid's Avatar
    the727kid is offline CarAudio.com Veteran



    Join Date
    Jul 2006
    Location
    St. Pete, FL
    Posts
    2,941
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Tweeter problem.

    Ok, like it says, this happens only at high volumes and only on certain songs. Seems to only occur on bass notes as well, also it is only the right tweeter. These 2 things have led me to believe either A. clipping or B. crossovers too low. First off I lowered my gains, they are bridged off a 300/4, which should be set at around 150watts, they are set at around 110 right now. Didn't help. Then I raised my crossovers from 80hz to 93hz, did not help at all either. Now I am at a standpoint, only one tweeter does it, any ideas? I might try switching the wires on the amp to see if it is the amp its self (the side those speakers are hooked up to has already gone bad and been in for repair).



    Alarm: Viper 5902
    HU: Stock
    Front Stage:
    Tweeters: Image Dynamics CD1-Pro Mini Horns
    Mids: Sundown Neo Pro 8"
    Subs: (2) 15" Dayton HF ran IB
    Amps: (2) Kicker IX 500.4 (1) Kicker IX 1000.1
    Processor: JBL MS-8




  2. #2
    albarran9's Avatar
    albarran9 is offline Senior VIP Member



    Join Date
    May 2005
    Location
    AR
    Age
    25
    Posts
    421
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Tweeter problem.

    Let me know how it goes with the trouble shooting cuz i have the same problem with my alpine type r tweeter. its allways the right tweeter that sounds like its blown on some songs with certain high pitch notes, but sounds good with other songs that dont go as high. i have already replaced the tweeter twice. once with an alpine amp and then with an mtx amp and the right tweet keeps on blowing. the left one still sounds like new.



    /////Alpine HU
    CDT CL-61A W/T-24 tweeters
    /////Alpine MRP-T220 Amp
    MTX 311D Amp
    MTX 12" MZS Subwoofers

  3. #3
    the727kid's Avatar
    the727kid is offline CarAudio.com Veteran

    Threadstarter


    Join Date
    Jul 2006
    Location
    St. Pete, FL
    Posts
    2,941
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Tweeter problem.

    It's not the highs it pops on for me though, its mainly when the bass hits, cuz if I play a songs intro thats real high its good and then on some bass notes it will pop.



    Alarm: Viper 5902
    HU: Stock
    Front Stage:
    Tweeters: Image Dynamics CD1-Pro Mini Horns
    Mids: Sundown Neo Pro 8"
    Subs: (2) 15" Dayton HF ran IB
    Amps: (2) Kicker IX 500.4 (1) Kicker IX 1000.1
    Processor: JBL MS-8

  4. #4
    albarran9's Avatar
    albarran9 is offline Senior VIP Member



    Join Date
    May 2005
    Location
    AR
    Age
    25
    Posts
    421
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Tweeter problem.

    well a tweet shouldnt be playing low notes in the first place. thats probably what is wrong with the set up. maybe a bass blocker on the tweet would help from the low notes from getting to the tweet?



    /////Alpine HU
    CDT CL-61A W/T-24 tweeters
    /////Alpine MRP-T220 Amp
    MTX 311D Amp
    MTX 12" MZS Subwoofers

  5. #5
    the727kid's Avatar
    the727kid is offline CarAudio.com Veteran

    Threadstarter


    Join Date
    Jul 2006
    Location
    St. Pete, FL
    Posts
    2,941
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Tweeter problem.

    Bump, any ideas? I may change the wiring leading to the x-over next week when I put in the battery and new box.



    Alarm: Viper 5902
    HU: Stock
    Front Stage:
    Tweeters: Image Dynamics CD1-Pro Mini Horns
    Mids: Sundown Neo Pro 8"
    Subs: (2) 15" Dayton HF ran IB
    Amps: (2) Kicker IX 500.4 (1) Kicker IX 1000.1
    Processor: JBL MS-8

  6. #6
    the727kid's Avatar
    the727kid is offline CarAudio.com Veteran

    Threadstarter


    Join Date
    Jul 2006
    Location
    St. Pete, FL
    Posts
    2,941
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Tweeter problem.

    ****, ya'll all experts and no one knows?



    Alarm: Viper 5902
    HU: Stock
    Front Stage:
    Tweeters: Image Dynamics CD1-Pro Mini Horns
    Mids: Sundown Neo Pro 8"
    Subs: (2) 15" Dayton HF ran IB
    Amps: (2) Kicker IX 500.4 (1) Kicker IX 1000.1
    Processor: JBL MS-8

  7. #7
    3.5Max6spd's Avatar
    3.5Max6spd is offline yo mama no wear no draws



    Join Date
    Jun 2004
    Location
    Dirty Jersey
    Age
    37
    Posts
    3,767
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Tweeter problem.

    Perhaps because you are not clear....is it the tweeter? or is it the midbass? bass notes?

    If you are straining the tweeter with certain material at high volumes, use the higher xover point for the tweeter provided in your xover. AND set the gains ACCORDINGLY, with a DMM or scope....bridged amps have a tendency to not put out easily even power without careful gain setting.



    rainbow....homemade sounds best
    DYNAUDIO E S O T E C....Mobile Fidelity

    Panasonic Vacuum Tube
    TRU Technology SSLD6
    TRU Technology STEEL S44 & S500
    DYNAUDIO Esotec System 362
    Dynaudio MW190 12" (x2) IB
    Stinger Expert/Esoteric Audio Isopath/Cascade


    Refs-NE14MX , jdavis37, anarchy57, mj121983 , ll kadoy ll, TheBigDu , cdj ,Kawasaki STX-R ,Fdeez ,Ksin291,meangta, lil azn 06, HAVINGFUN, Loud1500, Flipx99 , jjunior887 ,mastarecoil ,slammed , T3mpest ,westerbud, Airman21, bconn587, LexNBimmer,namike, alphakenny1, HebrewHammer,chadillac,remiserg, purerx7tt, OCURIEL, coneO,Igno,Iluvzmzm,godzukiduce,CrazedCat,skylar11 2,
    bose301s,qwertvt

  8. #8
    the727kid's Avatar
    the727kid is offline CarAudio.com Veteran

    Threadstarter


    Join Date
    Jul 2006
    Location
    St. Pete, FL
    Posts
    2,941
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Tweeter problem.

    I am almost 100% sure it is the right tweeter on bass notes, I can go check in a little once the neighbors have left for work. Using a higher xover point in the crossover I don't think would work because both xovers are teh same and only the right one does it. And my gains are set lower than accordingly (was set proper but popped more, so I lowered).



    Alarm: Viper 5902
    HU: Stock
    Front Stage:
    Tweeters: Image Dynamics CD1-Pro Mini Horns
    Mids: Sundown Neo Pro 8"
    Subs: (2) 15" Dayton HF ran IB
    Amps: (2) Kicker IX 500.4 (1) Kicker IX 1000.1
    Processor: JBL MS-8

  9. #9
    3.5Max6spd's Avatar
    3.5Max6spd is offline yo mama no wear no draws



    Join Date
    Jun 2004
    Location
    Dirty Jersey
    Age
    37
    Posts
    3,767
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Tweeter problem.

    Quote Originally Posted by the727kid View Post
    I am almost 100% sure it is the right tweeter on bass notes, I can go check in a little once the neighbors have left for work. Using a higher xover point in the crossover I don't think would work because both xovers are teh same and only the right one does it. And my gains are set lower than accordingly (was set proper but popped more, so I lowered).
    How did you set the gain? If by eye, its not a proper way of doing so. You may be clipping one side and not the other if your output is staggered. Did you read anything I wrote?



    rainbow....homemade sounds best
    DYNAUDIO E S O T E C....Mobile Fidelity

    Panasonic Vacuum Tube
    TRU Technology SSLD6
    TRU Technology STEEL S44 & S500
    DYNAUDIO Esotec System 362
    Dynaudio MW190 12" (x2) IB
    Stinger Expert/Esoteric Audio Isopath/Cascade


    Refs-NE14MX , jdavis37, anarchy57, mj121983 , ll kadoy ll, TheBigDu , cdj ,Kawasaki STX-R ,Fdeez ,Ksin291,meangta, lil azn 06, HAVINGFUN, Loud1500, Flipx99 , jjunior887 ,mastarecoil ,slammed , T3mpest ,westerbud, Airman21, bconn587, LexNBimmer,namike, alphakenny1, HebrewHammer,chadillac,remiserg, purerx7tt, OCURIEL, coneO,Igno,Iluvzmzm,godzukiduce,CrazedCat,skylar11 2,
    bose301s,qwertvt

  10. #10
    the727kid's Avatar
    the727kid is offline CarAudio.com Veteran

    Threadstarter


    Join Date
    Jul 2006
    Location
    St. Pete, FL
    Posts
    2,941
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Tweeter problem.

    I set it with a DMM, Yea I read what you wrote lol.



    Alarm: Viper 5902
    HU: Stock
    Front Stage:
    Tweeters: Image Dynamics CD1-Pro Mini Horns
    Mids: Sundown Neo Pro 8"
    Subs: (2) 15" Dayton HF ran IB
    Amps: (2) Kicker IX 500.4 (1) Kicker IX 1000.1
    Processor: JBL MS-8

  11. #11
    3.5Max6spd's Avatar
    3.5Max6spd is offline yo mama no wear no draws



    Join Date
    Jun 2004
    Location
    Dirty Jersey
    Age
    37
    Posts
    3,767
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Tweeter problem.

    Well, you may want to try changing that xover point on the passive xover and see what happens-if its set to the lowest value. Also have you checked to see that all jumpers are tightly secured'?



    rainbow....homemade sounds best
    DYNAUDIO E S O T E C....Mobile Fidelity

    Panasonic Vacuum Tube
    TRU Technology SSLD6
    TRU Technology STEEL S44 & S500
    DYNAUDIO Esotec System 362
    Dynaudio MW190 12" (x2) IB
    Stinger Expert/Esoteric Audio Isopath/Cascade


    Refs-NE14MX , jdavis37, anarchy57, mj121983 , ll kadoy ll, TheBigDu , cdj ,Kawasaki STX-R ,Fdeez ,Ksin291,meangta, lil azn 06, HAVINGFUN, Loud1500, Flipx99 , jjunior887 ,mastarecoil ,slammed , T3mpest ,westerbud, Airman21, bconn587, LexNBimmer,namike, alphakenny1, HebrewHammer,chadillac,remiserg, purerx7tt, OCURIEL, coneO,Igno,Iluvzmzm,godzukiduce,CrazedCat,skylar11 2,
    bose301s,qwertvt

  12. #12
    the727kid's Avatar
    the727kid is offline CarAudio.com Veteran

    Threadstarter


    Join Date
    Jul 2006
    Location
    St. Pete, FL
    Posts
    2,941
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Tweeter problem.

    Will check everything you listed and get back to you.



    Alarm: Viper 5902
    HU: Stock
    Front Stage:
    Tweeters: Image Dynamics CD1-Pro Mini Horns
    Mids: Sundown Neo Pro 8"
    Subs: (2) 15" Dayton HF ran IB
    Amps: (2) Kicker IX 500.4 (1) Kicker IX 1000.1
    Processor: JBL MS-8

  13. #13
    the727kid's Avatar
    the727kid is offline CarAudio.com Veteran

    Threadstarter


    Join Date
    Jul 2006
    Location
    St. Pete, FL
    Posts
    2,941
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Tweeter problem.

    Alright, well I'm an idiot lol. I checked it and listened carfully it is the mid-bass (currently have the Eclipse mid-bass in and not the Germs), turned up the crossover on the HU to 180hz(****, thats high) and it went away.



    Alarm: Viper 5902
    HU: Stock
    Front Stage:
    Tweeters: Image Dynamics CD1-Pro Mini Horns
    Mids: Sundown Neo Pro 8"
    Subs: (2) 15" Dayton HF ran IB
    Amps: (2) Kicker IX 500.4 (1) Kicker IX 1000.1
    Processor: JBL MS-8

  14. #14
    MrSwiss's Avatar
    MrSwiss is offline CarAudio.com Elite



    Join Date
    Mar 2005
    Location
    detroit
    Posts
    870
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Tweeter problem.

    if its poppin it is obviously the low notes. high notes that are too strong will only distort, not pop it. Try a "bass blocker". Right now i have some inline crossovers to rememdy this.



    92 buick lesabre
    Kenwood excelon x-790
    AA polys fiberglassed in the doors | LPG 25nfa, column
    off brand 6x9's boxed in rear deck
    rl-p 15 sealed 1000wrms @ 2 ohms =P
    PA sl4-1000 4 ch
    PG 15.0.1.

  15. #15
    the727kid's Avatar
    the727kid is offline CarAudio.com Veteran

    Threadstarter


    Join Date
    Jul 2006
    Location
    St. Pete, FL
    Posts
    2,941
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Tweeter problem.

    Don't need one, my HU can basically block it with its crossovers, plus the Germs are going in soon and I doubt those will pop lol.



    Alarm: Viper 5902
    HU: Stock
    Front Stage:
    Tweeters: Image Dynamics CD1-Pro Mini Horns
    Mids: Sundown Neo Pro 8"
    Subs: (2) 15" Dayton HF ran IB
    Amps: (2) Kicker IX 500.4 (1) Kicker IX 1000.1
    Processor: JBL MS-8

Closed Thread
Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum