Closed Thread
Results 1 to 2 of 2

Reload Thread: tweeters cutting out

  1. #1
    Join Date
    May 2006
    Location
    south burbs
    Posts
    58
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    tweeters cutting out

    a couple weeks ago i bought some cadence cvlt10 tweeters. these teeters take 100watts rms and came with their own crossovers and everything. i have a presision power 400 watt 4 channel amplifier. this amp supposedly does 50x4 so i have one tweeter hooked up per channel. yesterday these tweeters started cutting out at high volumes so i would turn it down and the tweeters would come on again..could it be that im pushing them too hard or maybe all the vibration from the subs?







  2. #2
    CBRworm's Avatar
    CBRworm is offline Member



    Join Date
    Jul 2006
    Location
    South Florida
    Posts
    62
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: tweeters cutting out

    There is probably some protection built into the crossover that is cutting power to them to save them.



    '06 G35 6MT Sedan - now bose free -- Alpine IVA-W200 w/ H701, C701, and TR7

    DLS Iridium IR3 and IR1 and Adire Extremis 6.8 front stage
    Arc Audio 4150XXk for mids and tweets
    Arc Audio 4150XXK Bridged for all 4 midbass's
    Adire Extremis 6.8 back doors for added kick.
    JL12W6V2 in a 1cf sealed w/ PDX1.1000
    everythings deadened.

    Refs: Bodegabay, 250+ (100%) on ebay with same username.

    04 CBR1000RR - SOUND SYSTEM BY MICRON

Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum