Closed Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 20

Reload Thread: Tweeters problem....

  1. #1
    gramus_666's Avatar
    gramus_666 is offline Junior Member



    Join Date
    Aug 2006
    Location
    brantforf
    Posts
    6
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Tweeters problem....

    Hi

    Im not very expirienced with tweeters so i decide not to invest lots of money in the one i bought. What came out is that the build in croosover they have in makingmy midllerange a tweeter in serial connection (both tweeter and speaker are 4 Ohm so thats the only possible way as im not using any amps to power the speakers just Cd deck) i donno how to solve that problem because its pointless to connect them like that + the tweeter is actually making more noise than clear sound, i donno if thats the quality ove here or quality of the connection but system is way clearer without those tweeters and im powering old (13y/o) stock speakers in my car ( ive tried all posible speakers on the market and stock once works best i donno y).

    Cheers Luke.







  2. #2
    6spdcoupe's Avatar
    6spdcoupe is offline tends to get a bit cranky



    Join Date
    Jul 2004
    Location
    In the armpit of the US
    Age
    40
    Posts
    12,821
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Tweeters problem....

    Huh?




    DVI-9990/TMI-M990/PXI-H990
    TRU Billet 2200 ..Dyn Esotar 1200
    TRU Billet 4100 ..Dyn Esotar110/Esotar430
    TRU Billet 4100 ..DYN MD182s

    Refs:
    Way to many to list, seriously. I lost count when it passed 100

  3. #3
    azbass's Avatar
    azbass is offline the salty ca.com mod



    Join Date
    Sep 2004
    Location
    Long Beach, CA
    Posts
    34,922
    Post Thanks / Like
    Images
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Tweeters problem....

    what?




  4. #4
    smd4life's Avatar
    smd4life is offline NOTHING ABOUT MEADE



    Join Date
    Feb 2006
    Location
    TN
    Posts
    7,558
    Post Thanks / Like
    Images
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    3 Post(s)

    Re: Tweeters problem....

    Quote Originally Posted by gramus_666 View Post
    Hi

    Im not very expirienced with tweeters so i decide not to invest lots of money in the one i bought. What came out is that the build in croosover they have in makingmy midllerange a tweeter in serial connection (both tweeter and speaker are 4 Ohm so thats the only possible way as im not using any amps to power the speakers just Cd deck) i donno how to solve that problem because its pointless to connect them like that + the tweeter is actually making more noise than clear sound, i donno if thats the quality ove here or quality of the connection but system is way clearer without those tweeters and im powering old (13y/o) stock speakers in my car ( ive tried all posible speakers on the market and stock once works best i donno y).

    Cheers Luke.
    wow your a baddass

    but seriously whats the problem?




    Quote Originally Posted by thevic24 View Post
    And with this.....I will use this as an excuse to drink another beer....
    __________________________________________________ __________________________________________________ ____________________________________________
    Ref's:memphissoul4u, scottiej(x3), bassaddictj, jeepinTN(x2), Blados,lincolnls(slc720052), ssbogger, stuckinok(x2), matrxx dude, BoostedPontiac, fintheman, dbornotdb, mr. tibbs, lakota, iceteebone, WantedIsHere(HypnoticCure), Cahm Rohn, Bring97, Brian Owens, snoopysnooper, sdsport92064, annarbor84, tv559, RetroAudioinc, FJF, 01 S 10, oddiofile, stupify

  5. #5
    mikeyboc's Avatar
    mikeyboc is offline CarAudio.com Veteran



    Join Date
    Oct 2005
    Location
    Sugar Land, TX
    Age
    35
    Posts
    2,075
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Tweeters problem....





  6. #6
    phantom240's Avatar
    phantom240 is offline ALL YOUR INTERNETZ



    Join Date
    Aug 2005
    Location
    Southeast Louisiana
    Age
    26
    Posts
    5,712
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    9 Post(s)

    Re: Tweeters problem....

    Quote Originally Posted by gramus_666 View Post
    Hi

    Im not very expirienced with tweeters so i decide not to invest lots of money in the one i bought. What came out is that the build in croosover they have in makingmy midllerange a tweeter in serial connection (both tweeter and speaker are 4 Ohm so thats the only possible way as im not using any amps to power the speakers just Cd deck) i donno how to solve that problem because its pointless to connect them like that + the tweeter is actually making more noise than clear sound, i donno if thats the quality ove here or quality of the connection but system is way clearer without those tweeters and im powering old (13y/o) stock speakers in my car ( ive tried all posible speakers on the market and stock once works best i donno y).

    Cheers Luke.
    ya know... even though we guys hate periods (as us with gfs know already) they can come in handy... like when youre trying to say something meaningful. Just a thought though...




























    and btw Grammar > u



    Quote Originally Posted by 18lexusowner View Post
    If your not a liberal cockbag than it's funny.
    Refs: Lostsoul, DaGh0st, Jadeaudio, mhschiefs806, revrider1, GavinVoy, maximpakt

  7. #7
    gramus_666's Avatar
    gramus_666 is offline Junior Member

    Threadstarter


    Join Date
    Aug 2006
    Location
    brantforf
    Posts
    6
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Tweeters problem....

    The problem is that the tweeter is making my middle range speaker pick up only freequency from built in crossover in the tweeter (serial connection).

    Sry for the last post. When i reread it now i cannot understand it myself :]




  8. #8
    azbass's Avatar
    azbass is offline the salty ca.com mod



    Join Date
    Sep 2004
    Location
    Long Beach, CA
    Posts
    34,922
    Post Thanks / Like
    Images
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Tweeters problem....

    is the mid and tweet wired to a passive crossover?




  9. #9
    phantom240's Avatar
    phantom240 is offline ALL YOUR INTERNETZ



    Join Date
    Aug 2005
    Location
    Southeast Louisiana
    Age
    26
    Posts
    5,712
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    9 Post(s)

    Re: Tweeters problem....

    Its because youre retarded. Did you wire the tweet BEFORE or AFTER the midrange? Also, as I think about this, wiring it in series is what your problem is. Its acting like those gay *** "bass blockers" wire it in parallel, and if you toast the HU, it must have ****** or u bought ****** tweeters.



    Quote Originally Posted by 18lexusowner View Post
    If your not a liberal cockbag than it's funny.
    Refs: Lostsoul, DaGh0st, Jadeaudio, mhschiefs806, revrider1, GavinVoy, maximpakt

  10. #10
    heyman421's Avatar
    heyman421 is offline Veteran Camel Master



    Join Date
    Jan 2006
    Location
    Akron, OH
    Posts
    4,170
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Tweeters problem....

    holy ****, that was hard to read

    can someone let me know if it's worth it?




  11. #11
    gramus_666's Avatar
    gramus_666 is offline Junior Member

    Threadstarter


    Join Date
    Aug 2006
    Location
    brantforf
    Posts
    6
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Tweeters problem....

    the crossover is build in inside the tweeters and i have no info bout it what so ever. and im not retarded u moron before u put an insult u can ask, well i wired them both ways (BEFORE and After,, ive tried everything beside wiring them in parralel cuz that can fry my Cd deck)

    so far only azbass is ok, the rest is just smartmouth ********* that dont have a life and spend their time on posting stupid posts ( ill recomend some worning and bans for those ppl)




  12. #12
    6spdcoupe's Avatar
    6spdcoupe is offline tends to get a bit cranky



    Join Date
    Jul 2004
    Location
    In the armpit of the US
    Age
    40
    Posts
    12,821
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Tweeters problem....

    maybe if you provided us with what Kind of drivers they are we could be helpful ! Even pics maybe? You do have a camera no?




    DVI-9990/TMI-M990/PXI-H990
    TRU Billet 2200 ..Dyn Esotar 1200
    TRU Billet 4100 ..Dyn Esotar110/Esotar430
    TRU Billet 4100 ..DYN MD182s

    Refs:
    Way to many to list, seriously. I lost count when it passed 100

  13. #13
    LoudCrownVic's Avatar
    LoudCrownVic is offline 1/1 of Team Team Team



    Join Date
    Dec 2003
    Location
    Scales Bump, IL
    Age
    29
    Posts
    6,122
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Tweeters problem....

    Trying to understand this scrambled logic makes me want to pee myself.



    I com to lern bout car awww-deeeee-ohhhhhs!
    Truck: 1998 Ford Ranger SC 2.5L 4 cyl 5 spd
    Mods- 195/60R15 Cooper Cobra Tires on stock rims
    System: HU- Eclipse CD8454, 2 Dayton RS180 7" midbass, Optimus 3" Horn Tweets hotglued to the dash, 3 12" JL W6v1's downfiring sealed, PPI PCX2200 @ 4 ohms, Alpine MRV-F545 mids and highs, 2 layers of Raamat on the doors.
    What's in Store:
    2 more Dayton RS180 7" midbass, 2 Bolender Grabender Neo planar tweets

  14. #14
    gramus_666's Avatar
    gramus_666 is offline Junior Member

    Threadstarter


    Join Date
    Aug 2006
    Location
    brantforf
    Posts
    6
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Tweeters problem....

    no offence but for **** sackes i was just talking bout pointless posts and here they are again. go and pee yourself if that turns you on,

    Anyway the tweeters are cheap very cheap without the brand name ( i didnt want to invest lots of money cuz im just trying to see if tweeters make some significant difference to the system, so far the quality is poor (lots of noise) prob cuz they are cheap)

    And the question is :

    Is there a way to connect those tweeters to the system so it will work like they should work??

    im runing Pioneer Premier DEH-P8MP, stock speakers (explanation in 1st post), Visonik Digital Amp VXD709 800W, 12" Visonic Competition Sub 1000W if that can help

    If thats complicated next time ill include manual.




  15. #15
    phantom240's Avatar
    phantom240 is offline ALL YOUR INTERNETZ



    Join Date
    Aug 2005
    Location
    Southeast Louisiana
    Age
    26
    Posts
    5,712
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    9 Post(s)

    Re: Tweeters problem....

    Im pretty sure its because youre running in series.



    Quote Originally Posted by 18lexusowner View Post
    If your not a liberal cockbag than it's funny.
    Refs: Lostsoul, DaGh0st, Jadeaudio, mhschiefs806, revrider1, GavinVoy, maximpakt

Closed Thread
Page 1 of 2 1 2 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum