Closed Thread
Results 1 to 5 of 5

Reload Thread: Problem w/speakers or crossover?

  1. #1
    Phrozt's Avatar
    Phrozt is offline The Drunken Snowman



    Join Date
    Mar 2006
    Location
    Decatur, IL
    Age
    30
    Posts
    1,307
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Problem w/speakers or crossover?

    So I thought one of my speakers blew (which would ****, because I bought them BRAND new and have had them installed for only about 2 months), but something else happened the other day that might make me think different.

    To start, they were making a very metallic rattle when certain lows hit (I'm talking about my 60.5cs midrange comps BTW). I turned down the volume, and they were ok..

    however, recently, I tried this, and they were not hitting the metallic rattle often, because I had the volume low, but when it *did* hit the level, it just kept on rattling... It was a constant rattle/vibration that had nothing to do w/the beat of the song whatsoever. Only way to kill it was to turn the HU to standby. Turning the volume up or down after it started this constant rattle had absolutely no effect on the volume of the rattle or the consistancy. I turned the volume all the way to 0 and it was still rattling just as loud and just as constant.


    Is this a prob w/the speaker or the crossover?? Something else maybe?



    My stock system in my 01 Dodge Intrepid ES sounds GREAT!!

    Which is why I'm replacing it with this:
    HU: Kenwood Excelon x790...............................................Wiring:
    Components: Infinity Kappa 60.7cs..................................Stinger 0 gauge kit
    6x9s: Infinity Kappa 693.7i...............................................Stinger Helix interconnects
    Main Amp: MA Audio M489I..............................................Sub(s): Yet to be determined!
    .................................................. ......................................Sub Amp(s): Yet to be determined!

    Running total: $949.65




  2. #2
    Phrozt's Avatar
    Phrozt is offline The Drunken Snowman

    Threadstarter


    Join Date
    Mar 2006
    Location
    Decatur, IL
    Age
    30
    Posts
    1,307
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Problem w/speakers or crossover?

    Extra info:

    I've taken the speaker out and manually inspected it and it *looks* fine...

    The cone is completely connected to the spider all the way around, and the glue looks intact...



    My stock system in my 01 Dodge Intrepid ES sounds GREAT!!

    Which is why I'm replacing it with this:
    HU: Kenwood Excelon x790...............................................Wiring:
    Components: Infinity Kappa 60.7cs..................................Stinger 0 gauge kit
    6x9s: Infinity Kappa 693.7i...............................................Stinger Helix interconnects
    Main Amp: MA Audio M489I..............................................Sub(s): Yet to be determined!
    .................................................. ......................................Sub Amp(s): Yet to be determined!

    Running total: $949.65

  3. #3
    squeak9798's Avatar
    squeak9798 is offline Banned



    Join Date
    Jun 2004
    Location
    USA
    Posts
    26,300
    Post Thanks / Like
    Images
    16
    Mentioned
    0 Post(s)

    Re: Problem w/speakers or crossover?

    Assuming this is happening to only a single speaker.....swap the speakers to the other side. Does the sound follow the speaker to the opposite side of the car, or stay on one consistent side? Then swap the crossovers to the opposite sides, does the problem follow the crossovers or stay on one consistent side?

    That will answer your question as to where the problem lies.




  4. #4
    Phrozt's Avatar
    Phrozt is offline The Drunken Snowman

    Threadstarter


    Join Date
    Mar 2006
    Location
    Decatur, IL
    Age
    30
    Posts
    1,307
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Problem w/speakers or crossover?

    very true... guess I didn't think about that...

    I can troubleshoot a computer, but I'm new to the "common sense" of the audio world...



    My stock system in my 01 Dodge Intrepid ES sounds GREAT!!

    Which is why I'm replacing it with this:
    HU: Kenwood Excelon x790...............................................Wiring:
    Components: Infinity Kappa 60.7cs..................................Stinger 0 gauge kit
    6x9s: Infinity Kappa 693.7i...............................................Stinger Helix interconnects
    Main Amp: MA Audio M489I..............................................Sub(s): Yet to be determined!
    .................................................. ......................................Sub Amp(s): Yet to be determined!

    Running total: $949.65

  5. #5
    Phrozt's Avatar
    Phrozt is offline The Drunken Snowman

    Threadstarter


    Join Date
    Mar 2006
    Location
    Decatur, IL
    Age
    30
    Posts
    1,307
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Problem w/speakers or crossover?

    Wasn't the speaker or the crossover.. it was the battery.

    Replaced it w/an optima red top and I'm good to go.

    However, I do believe some damage was sustained, because at very high volumes, the speaker in question still craps out ion the same way, though not continuous



    My stock system in my 01 Dodge Intrepid ES sounds GREAT!!

    Which is why I'm replacing it with this:
    HU: Kenwood Excelon x790...............................................Wiring:
    Components: Infinity Kappa 60.7cs..................................Stinger 0 gauge kit
    6x9s: Infinity Kappa 693.7i...............................................Stinger Helix interconnects
    Main Amp: MA Audio M489I..............................................Sub(s): Yet to be determined!
    .................................................. ......................................Sub Amp(s): Yet to be determined!

    Running total: $949.65

Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum