Closed Thread
Results 1 to 6 of 6

Reload Thread: 1992 Deville Question!!

  1. #1
    lionel2's Avatar
    lionel2 is offline CarAudio.com Elite



    Join Date
    Feb 2006
    Location
    PA
    Posts
    574
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    1992 Deville Question!!

    I am doing an odd job on a 1992 caddy deville with a bose sound package and the rear 6x9's are not functioning properly...the passenger side 6x9 works but the other driver side does not and the one that does work sounds crappy like static..whats the problem??..is the speaker blown and the other is getting too much power?? should i replace both of them...the wiring is wierd...red..orange..all types of colors..but only a pos and neg wiring...how do you drop those speakers out..down or up threw carpet under rear glass??...umm..any help will be appreciated..thanks







  2. #2
    lionel2's Avatar
    lionel2 is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Feb 2006
    Location
    PA
    Posts
    574
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: 1992 Deville Question!!

    anyone??




  3. #3
    Join Date
    May 2006
    Location
    bloomingdale IL
    Posts
    909
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: 1992 Deville Question!!

    Are they ran off the h/u or an amp?
    Ive replaced my stock 6x9's in the back of a 91 deville. PM me if you need help and i can guide you.



    2000 Contour SVT
    Kenwood KDC-MP632U
    speakers- PG RSD 6CS
    front amp- Kenwood KAC-PS150
    sub- .......
    amp- hifonics1606d

    Refs- Prowler573,awahl63, iamaw30, pboulos, unbonyr, trevor87 (no money involved, just sent a fuse to him).

  4. #4
    lionel2's Avatar
    lionel2 is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Feb 2006
    Location
    PA
    Posts
    574
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: 1992 Deville Question!!

    I cannot find replace bose 6x9's anywhere...can't i just pop in some pioneer 6x9's or something??..anyone know where to get Bose 6x9's??




  5. #5
    Join Date
    May 2006
    Location
    bloomingdale IL
    Posts
    909
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: 1992 Deville Question!!

    Just buy any aftermarket 6x9's. Pioneers are fine. The kenwoods i have have pretty good bass/midbass. Anyone will work. Did you get to them yet?



    2000 Contour SVT
    Kenwood KDC-MP632U
    speakers- PG RSD 6CS
    front amp- Kenwood KAC-PS150
    sub- .......
    amp- hifonics1606d

    Refs- Prowler573,awahl63, iamaw30, pboulos, unbonyr, trevor87 (no money involved, just sent a fuse to him).

  6. #6
    lionel2's Avatar
    lionel2 is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Feb 2006
    Location
    PA
    Posts
    574
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: 1992 Deville Question!!

    i found the problem...there is nothing wrong with the speakers...they just are not getting any power..the amp is blown or channels are anyway...only the driver front speaker works fine..the rest static..thanks




Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum