Closed Thread
Results 1 to 15 of 15

Reload Thread: BA SL60 Mids popping

  1. #1
    Join Date
    Mar 2004
    Location
    Frostburg, MD
    Age
    33
    Posts
    1,937
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)

    BA SL60 Mids popping

    Just replaced my front CDT-CL61's, with a set of BA SL60's. While the tweeters sound great, the mids give a popping sound when they are turned up. Basically as if they are not able to produce the midbass. The rms rating on these is only 10 less than my CDT's, (80 vs 90), and I cant imagine with an amp that puts out a max of 110w per side I would be overpowering them. Anyone have any suggestions? I'm using the auto eq feature on my 880prs. The center of these mids looks as if they have a allen screw which suggests some sort of adjustment can be done possibly?



    03'CivicEx (5spd)
    Premier 880PRS
    Rainbow SLC6.5 (front)
    Boston SL60 mids (rear)
    2X PG RSD 12'
    Rockford Power 851X 4chan
    Concept CD-2410 Mono




  2. #2
    PollyCranopolis's Avatar
    PollyCranopolis is offline Bees!

    Threadstarter


    Join Date
    Mar 2004
    Location
    Frostburg, MD
    Age
    33
    Posts
    1,937
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)

    Re: BA SL60 Mids popping

    I figured out I might have the crossovers wired wrong. I have the "In" lines both going into the tweeter in on both crossovers. It looks like form the manual that 1 crossover has the in going into the tweet, and the other crossover in goes into the mid. Going to switch them around a later today. Just hope I didnt **** anything up.


    Also, I must say I've never had more trouble installing tweeters in my life. The tweet turns into the base, which you have to connect with a center screw after the wires and base are attached. The tweet was a ***** to turn in, as were the speaker wires to connect to the base without coming disconnected. I ended up scaring up the tweet grills, as I had to use a pair of grips they were so hard to turn. Boston needs to take a serious look at the mounting setup for this set.




    03'CivicEx (5spd)
    Premier 880PRS
    Rainbow SLC6.5 (front)
    Boston SL60 mids (rear)
    2X PG RSD 12'
    Rockford Power 851X 4chan
    Concept CD-2410 Mono

  3. #3
    flakko's Avatar
    flakko is offline Veteran (my butt)



    Join Date
    Aug 2004
    Location
    So Cal
    Age
    28
    Posts
    10,477
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: BA SL60 Mids popping

    1. you are playing them too low

    2. you are giving them a clipped signal

    3. you are overpowering them

    im guessing either 1 or 2




    1998 Acura TL 3.2L
    Crappy Sansui DVD player
    Stock Speakers
    ----------------------------------------------------------------------
    "Hi ladies, my name is Wo-Hen Nankan"

    "I like you. You have balls. I like balls."

  4. #4
    PollyCranopolis's Avatar
    PollyCranopolis is offline Bees!

    Threadstarter


    Join Date
    Mar 2004
    Location
    Frostburg, MD
    Age
    33
    Posts
    1,937
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)

    Re: BA SL60 Mids popping

    What do you mean "playing them too low?" You mean setting the xover point on the HU? I have mine on 80, which should be more than acceptable.

    Re a clipped signal, I did set the gains with a DMM. 80rms=80*4=320sqrt=17.88. Set the gains using the correct procedure. Of course even going by the book, the gains is set 85% of the way up to achieve the calculated voltage. I understand that setting them this way will not always keep the amp from clipping. The CDT's did fine though, even with a slightly higher gain setting.



    03'CivicEx (5spd)
    Premier 880PRS
    Rainbow SLC6.5 (front)
    Boston SL60 mids (rear)
    2X PG RSD 12'
    Rockford Power 851X 4chan
    Concept CD-2410 Mono

  5. #5
    flakko's Avatar
    flakko is offline Veteran (my butt)



    Join Date
    Aug 2004
    Location
    So Cal
    Age
    28
    Posts
    10,477
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: BA SL60 Mids popping

    playing too low meaning frequency. raise the xover a bit. also try turning the gains down a little as well.




    1998 Acura TL 3.2L
    Crappy Sansui DVD player
    Stock Speakers
    ----------------------------------------------------------------------
    "Hi ladies, my name is Wo-Hen Nankan"

    "I like you. You have balls. I like balls."

  6. #6
    PollyCranopolis's Avatar
    PollyCranopolis is offline Bees!

    Threadstarter


    Join Date
    Mar 2004
    Location
    Frostburg, MD
    Age
    33
    Posts
    1,937
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)

    Re: BA SL60 Mids popping

    Like I mentioned earlier, the input lines go into each passive on a diffrent side. One inputs into the tweeter side, and the second inputs into the 2nd passive on the mid. Think this may be the problem? I currently have the inputs going into the tweet on both passives.




    03'CivicEx (5spd)
    Premier 880PRS
    Rainbow SLC6.5 (front)
    Boston SL60 mids (rear)
    2X PG RSD 12'
    Rockford Power 851X 4chan
    Concept CD-2410 Mono

  7. #7
    flakko's Avatar
    flakko is offline Veteran (my butt)



    Join Date
    Aug 2004
    Location
    So Cal
    Age
    28
    Posts
    10,477
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: BA SL60 Mids popping

    noooo the high pass change that the mids are playing too low xit over around 80-100 and turn your gains down that helps too




    1998 Acura TL 3.2L
    Crappy Sansui DVD player
    Stock Speakers
    ----------------------------------------------------------------------
    "Hi ladies, my name is Wo-Hen Nankan"

    "I like you. You have balls. I like balls."

  8. #8
    PollyCranopolis's Avatar
    PollyCranopolis is offline Bees!

    Threadstarter


    Join Date
    Mar 2004
    Location
    Frostburg, MD
    Age
    33
    Posts
    1,937
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)

    Re: BA SL60 Mids popping

    After sticking my head down by the mid, I discovered they were distorting pretty bad. Basically anything over a quarter turn on the gains makes them distort like crazy. Funny how my CDT Cl-61's with a passive only about a 3rd of the size can run all day, distortion free, with the gain set twice as high. The Cl-61's also slaughter the BA's as far as midbass. Somthing doesnt seem right here.



    03'CivicEx (5spd)
    Premier 880PRS
    Rainbow SLC6.5 (front)
    Boston SL60 mids (rear)
    2X PG RSD 12'
    Rockford Power 851X 4chan
    Concept CD-2410 Mono

  9. #9
    PollyCranopolis's Avatar
    PollyCranopolis is offline Bees!

    Threadstarter


    Join Date
    Mar 2004
    Location
    Frostburg, MD
    Age
    33
    Posts
    1,937
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)

    Re: BA SL60 Mids popping

    If I turn the gain down to acceptable levels I lose the pop. Good. Just makes me wonder why I wasnt able to detect distortion in the CDT's with the gain jacked all that time. You can definitely tell with this set! Thats a good thing. Doesnt get quite as loud as I'm used to, but they do sound **** good. The only problem is that when I get my next sub amp, the BA's just are not going to be able to keep up. They can't keep up now with me giving 400w to 1 15.



    03'CivicEx (5spd)
    Premier 880PRS
    Rainbow SLC6.5 (front)
    Boston SL60 mids (rear)
    2X PG RSD 12'
    Rockford Power 851X 4chan
    Concept CD-2410 Mono

  10. #10
    flakko's Avatar
    flakko is offline Veteran (my butt)



    Join Date
    Aug 2004
    Location
    So Cal
    Age
    28
    Posts
    10,477
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: BA SL60 Mids popping

    well the SL60's ARE the lowend BA...




    1998 Acura TL 3.2L
    Crappy Sansui DVD player
    Stock Speakers
    ----------------------------------------------------------------------
    "Hi ladies, my name is Wo-Hen Nankan"

    "I like you. You have balls. I like balls."

  11. #11
    Kickerkitty's Avatar
    Kickerkitty is offline CarAudio.com Elite



    Join Date
    Jan 2006
    Location
    kk
    Age
    33
    Posts
    554
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: BA SL60 Mids popping

    Quote Originally Posted by flakko
    well the SL60's ARE the lowend BA...
    Yea, they're for cheap people.




  12. #12
    PollyCranopolis's Avatar
    PollyCranopolis is offline Bees!

    Threadstarter


    Join Date
    Mar 2004
    Location
    Frostburg, MD
    Age
    33
    Posts
    1,937
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)

    Re: BA SL60 Mids popping

    Gee thanks. Anyway, I've found the big thing here with the BA's vs the CDT's is the auto eq on the 880prs. With the feature disabled, both sets can be cranked up relatively loud, and maintain good sq. With the auto eq on, there is no comparison. The CDT's whoop the Bostons. The BA's sound like popcorn if you turn them up with the auto eq enabled, whilst the CDT's handle like a dream, with hardley no noticable distortion and acceptable midbass. I'm hooked on the auto eq. I am amazed at how two entry level sets from two reputable companies can perform so diffrent. I'm going to have to look into CDT a little further, as I like what I hear. I hope to god ba pros dont experience the same issues.



    03'CivicEx (5spd)
    Premier 880PRS
    Rainbow SLC6.5 (front)
    Boston SL60 mids (rear)
    2X PG RSD 12'
    Rockford Power 851X 4chan
    Concept CD-2410 Mono

  13. #13
    Kickerkitty's Avatar
    Kickerkitty is offline CarAudio.com Elite



    Join Date
    Jan 2006
    Location
    kk
    Age
    33
    Posts
    554
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: BA SL60 Mids popping

    Quote Originally Posted by gymway
    I hope to god ba pros dont experience the same issues.


    lol@that




  14. #14
    konechiwa's Avatar
    konechiwa is offline Jeepers



    Join Date
    May 2006
    Location
    Seattle, WA
    Age
    24
    Posts
    3,602
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: BA SL60 Mids popping

    so then why did you get rid of your CDT's?




  15. #15
    PollyCranopolis's Avatar
    PollyCranopolis is offline Bees!

    Threadstarter


    Join Date
    Mar 2004
    Location
    Frostburg, MD
    Age
    33
    Posts
    1,937
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)

    Re: BA SL60 Mids popping

    I didn't. I'ma put them back up front. Use the BA's for rear fill. I'm glad I got them for cheap.:P
    Last edited by PollyCranopolis; 06-29-2006 at 08:38 PM.



    03'CivicEx (5spd)
    Premier 880PRS
    Rainbow SLC6.5 (front)
    Boston SL60 mids (rear)
    2X PG RSD 12'
    Rockford Power 851X 4chan
    Concept CD-2410 Mono

Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum