Closed Thread
Results 1 to 10 of 10

Reload Thread: What have I done - mistake

  1. #1
    Macdog's Avatar
    Macdog is offline Junior Member



    Join Date
    Jun 2006
    Location
    NC
    Posts
    7
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    What have I done - mistake

    First post -

    I have a few extra bucks and wanted to upgrade the sound in my car. I went to a local dealer and asked for suggestions for a component set with good, balanced, neutral sound. He recommended JL XR650-csi which I agreed to do. Now the problem... I hate the way they sound. I've taken my car in and had the crossovers changed which helped some, but they still sound horrible. The midrange has a hollow,metallic sound to them

    I'm taking the car back in and we're going to work some more to see what's going on, but I don't think I'll get the sound I'm looking for. He also suggested possibly switching to a set of Focals, don't know the model, if we can't get the JL's right.

    I know I sould've listened first, but I also know that speakers on a sound board will not sound the same as in a car.

    Suggestions on speakers please.... I'm not into really loud music - anymore. I'm looking for neutral, accurate midrange - not bright, not muddy.







  2. #2
    Fast1one's Avatar
    Fast1one is offline CarAudio.com Veteran



    Join Date
    Apr 2006
    Location
    California
    Posts
    4,628
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: What have I done - mistake

    Budget please



    References: Lax916, AcidicDreams , Altima98 , mr Tibbs, Majette, giantgloworm, mattmcss, riogigalo, mysilver02alty, Woc47, Hintzyboy, oglejust, APitBullT, foreman, jhubbell, tmcilroy, pioneerpimp, Dre_ATL

    Plus a ton more I never added, lol. If you are not on the list and you had a pleasant transaction with me, PM me!!!

  3. #3
    60ndown's Avatar
    60ndown is offline CarAudio.com Veteran



    Join Date
    Jun 2005
    Location
    ca
    Posts
    3,590
    Post Thanks / Like
    Images
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: What have I done - mistake

    my xrs sound good, there is an adjustment for both the tweter and the midrange in the x over, did you try adjusting them? also, it takes a while to adjust to a new sound after getting used to a particular sound,, give it a few days before you pass judgement




  4. #4
    Macdog's Avatar
    Macdog is offline Junior Member

    Threadstarter


    Join Date
    Jun 2006
    Location
    NC
    Posts
    7
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: What have I done - mistake

    Thanks for the replies.

    Budget - $400 - $500

    I've adjusted the tweeter and midrange settings in the crossover. It helped some, but voices still don't sound natural especially female voices. I'm not sure I can get used to that sound.

    I don't have much experience in the car audio world, but have been a home theater nut for over 10 years.




  5. #5
    Fast1one's Avatar
    Fast1one is offline CarAudio.com Veteran



    Join Date
    Apr 2006
    Location
    California
    Posts
    4,628
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: What have I done - mistake

    Your right in the budget for Rainbow Germs



    References: Lax916, AcidicDreams , Altima98 , mr Tibbs, Majette, giantgloworm, mattmcss, riogigalo, mysilver02alty, Woc47, Hintzyboy, oglejust, APitBullT, foreman, jhubbell, tmcilroy, pioneerpimp, Dre_ATL

    Plus a ton more I never added, lol. If you are not on the list and you had a pleasant transaction with me, PM me!!!

  6. #6
    Macdog's Avatar
    Macdog is offline Junior Member

    Threadstarter


    Join Date
    Jun 2006
    Location
    NC
    Posts
    7
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: What have I done - mistake

    Showing my ignorance here...Never heard of Rainbow speakers.




  7. #7
    Fast1one's Avatar
    Fast1one is offline CarAudio.com Veteran



    Join Date
    Apr 2006
    Location
    California
    Posts
    4,628
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: What have I done - mistake

    ^^^Some of the best....ranging from 100 bucks to 12 grand Search the speaker forum and contact 6speedcoupe



    References: Lax916, AcidicDreams , Altima98 , mr Tibbs, Majette, giantgloworm, mattmcss, riogigalo, mysilver02alty, Woc47, Hintzyboy, oglejust, APitBullT, foreman, jhubbell, tmcilroy, pioneerpimp, Dre_ATL

    Plus a ton more I never added, lol. If you are not on the list and you had a pleasant transaction with me, PM me!!!

  8. #8
    bryantxii's Avatar
    bryantxii is offline Member



    Join Date
    May 2006
    Location
    midwest
    Posts
    130
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: What have I done - mistake

    Quote Originally Posted by Macdog
    Showing my ignorance here...Never heard of Rainbow speakers.
    well there about the best when it comes to componets, i wish i had the budget to get the germaniums but thats definetly what you should get for your price range. contact 6spdcoupe, he's a rainbow dealer

    only other company that i would recomend for the sound you want would be cdt's
    probably the hd-62's



    Head Unit: Alpine CDA-9885
    Componet Set: Boston SPZ
    Componet Amp: Zapco Reference 350.2
    Sub: 2 Image Dynamics IDQ10V3.D4
    Sub Amp: Zapco REF1100.1

  9. #9
    Macdog's Avatar
    Macdog is offline Junior Member

    Threadstarter


    Join Date
    Jun 2006
    Location
    NC
    Posts
    7
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: What have I done - mistake

    what amp are you using? power could be your issue...
    A pioneer 4x60w amp.

    I'll check out the rainbows out.




  10. #10
    snoopdan's Avatar
    snoopdan is offline Banned



    Join Date
    Dec 2005
    Location
    Louisville, KY
    Posts
    20,158
    Post Thanks / Like
    Images
    19
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1374 Post(s)

    Re: What have I done - mistake

    Quote Originally Posted by bryantxii
    only other company that i would recomend for the sound you want would be cdt's probably the hd-62's
    no the cdt's are horribly metallic sounding as well....i have a set and i hate them, my $50 lanzars in my jeep sound better




Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum