Search:

Type: Posts; User: rondog

Search: Search took 0.04 seconds.

  1. Replies
    20
    Views
    1,468

    Re: Something is going bad in my audio setup

    gotcha..I am using all 3 pairs of pre outs so I don't have any rca jacks left. I do have a peice of frame right behind the HU I can mount to. Could I just use a single wire, attach one end to a screw...
  2. Replies
    20
    Views
    1,468

    Re: Something is going bad in my audio setup

    what is a ground loop? How would I ground my head unit?
  3. Replies
    20
    Views
    1,468

    Re: Something is going bad in my audio setup

    yeah I figured it out when first I tried a new RCA cable going straight from the deck to the head unit and it still sounded bad, so that ruled out a bad cable. Then I plugged the front speakers into...
  4. Replies
    20
    Views
    1,468

    Re: Something is going bad in my audio setup

    It was my head unit..who woulda thought! The rear output pre outs went bad. I got a new HU today and all is well again
  5. Replies
    20
    Views
    1,468

    Re: Something is going bad in my audio setup

    They are tight at the amp, I'll check if they are tight behind the head unit when I get home. I am running a set of 4 channel RCAs to the 4ch amp. This is my setup
    ...
  6. Replies
    20
    Views
    1,468

    Re: Something is going bad in my audio setup

    I never pull on them, they're under the seats...hardly ever down there
  7. Replies
    20
    Views
    1,468

    Re: Something is going bad in my audio setup

    ok again..so these RCA cables just go bad after a while or what?
  8. Replies
    20
    Views
    1,468

    Re: Something is going bad in my audio setup

    Do RCA wires just go bad? They are connected to my amp. I hope it is the head unit
  9. Replies
    20
    Views
    1,468

    Something is going bad in my audio setup

    I've had this stereo installed about 3 years ago. It's all been fine till now. I have 2 Polk Momo amps...a 4 channel for 4 speakers and 2 tweeters. The other amp powers my 2 10" subs.

    The subs are...
Results 1 to 9 of 9
1e2 Forum