Closed Thread
Results 1 to 5 of 5

Reload Thread: Amp help.....

  1. #1
    mpowered325is's Avatar
    mpowered325is is offline CarAudio.com Elite



    Join Date
    Feb 2009
    Location
    Seatte
    Posts
    592
    Post Thanks / Like
    Mentioned
    2 Post(s)

    Amp help.....

    i just got my sundown saz1500 installed at car toys. i got it online from a member here and there is no output. i knew the guy that did the install. he has been doing installs for 15 years. he tested everything. he says the outputs are dead. i get no sound. anyone local with a amp i can hook up to test everything is working? or anything amp i can buy? is it worth repairing? maybe some tech help over the phone to help with my kenwood deck, maybe the setting arent right? its like a IDrive control on a CD player. its stupid. i hate the newer designs!



    2000 4Runner:
    Power:Yellow Top up front. HC800 out back.
    Deck: Kenwood Exceleron Double Din DVD
    Sub Amp: Earthquake 40UHC Gold
    Subs: DD 1510's x 2
    Sub: Alumapro M16

    Refs: eykang, shinju x4, get_off_me x3, sleazebagger, GlennyD, Patrock




  2. #2
    skavenger's Avatar
    skavenger is offline Junior Member



    Join Date
    Feb 2010
    Location
    GF
    Posts
    15
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp help.....

    The saz-1500d is well worth repairing, If you don't wanna repair it..Send it my way lol




  3. #3
    PHD - USA's Avatar
    PHD - USA is offline I sound better than you PHD - USA is a Supporting Member of the forum!

    PHD - USA is a Supporting Vendor of the forum!

    Join Date
    Apr 2010
    Location
    Enon, Ohio
    Age
    23
    Posts
    6,514
    Post Thanks / Like
    Mentioned
    81 Post(s)

    Re: Amp help.....

    Or to me I would love to have that baby



    PHD Audiophile Systems Dealer


  4. #4
    Deeper_shades's Avatar
    Deeper_shades is offline of underground



    Join Date
    Dec 2009
    Location
    EH?
    Posts
    1,308
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp help.....

    which member did you buy it from?




    Subs : 2 x 12" Sundown Z V.2
    Mids : Focal 165 A3 + 6x9's polk audio db691
    Amps : SAZ 3500 & MB Quart DSC 4125
    HU : JVC El Kameleon KD-AVX44 // EQ : AP EX7
    Batt: 3 x XS power 1400's + 200a Mechman Alt / 50 ft of welding cable / 80sf second skin
    Refs: Sundownz / Mike465 / SicAudio / Rusty_DC / chillin / power-fanatic07 / Silver

  5. #5
    mpowered325is's Avatar
    mpowered325is is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Feb 2009
    Location
    Seatte
    Posts
    592
    Post Thanks / Like
    Mentioned
    2 Post(s)

    Re: Amp help.....

    im not going to mention who just yet till I get my money back. but he is currently refunding me in full. so i will send it back to him. might want to inquire about it through him if you guys want it at "repair" cost. how much would this cost to fix you think? it is in PERFECT shape outside



    2000 4Runner:
    Power:Yellow Top up front. HC800 out back.
    Deck: Kenwood Exceleron Double Din DVD
    Sub Amp: Earthquake 40UHC Gold
    Subs: DD 1510's x 2
    Sub: Alumapro M16

    Refs: eykang, shinju x4, get_off_me x3, sleazebagger, GlennyD, Patrock

Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum