Closed Thread
Results 1 to 7 of 7

Reload Thread: Amp stopped working when subs blew

  1. #1
    bassprobs's Avatar
    bassprobs is offline Junior Member



    Join Date
    Aug 2012
    Location
    Triad, NC
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Amp stopped working when subs blew

    I had two 12" Rockfords hooked up to a Hifonics HFi 1000.1D amp and ending up blowing them not long after i got them hooked up. I was pushing them at a higher power than they were rated for by mistake but now my amp won't get power to any subs hooked up in my car. The amp is getting power but it won't push the subs. Did I damage my amp when I blew the Rockfords?







  2. #2
    05fronty's Avatar
    05fronty is offline SALT PETER



    Join Date
    Nov 2006
    Location
    conway,ar
    Age
    40
    Posts
    11,341
    Post Thanks / Like
    Mentioned
    53 Post(s)

    Re: Amp stopped working when subs blew

    welcome to the site. hope you enjoy it here. come to the dome and hang out



    bought from ridinhi,vitveet,dbr,sicaudio and 99grandprixgt, and more ........... sold to player3,foomasta69, pitbull, brodiesel and dragnix 12887 traded with louisiana crx

    "noobs that come in the dome will get gang raped!"
    nothing but a stock fosgate system with gps and back up camera lol
    2012 nissan sentra spec v with some goodies cumming though

  3. Likes Flex68 liked this post
  4. #3
    SplAffair's Avatar
    SplAffair is offline I lol'd



    Join Date
    Mar 2009
    Location
    Knocksville, TN
    Age
    23
    Posts
    2,116
    Post Thanks / Like
    Mentioned
    5 Post(s)

    Re: Amp stopped working when subs blew

    wrong section... but its possible you were clipping the fuck out of the subs and amp therefore damaging the amp



    Quote Originally Posted by predxen View Post
    Its not as loud as it should be, you stop hearing it about a block away. you should be able to hear it a quarter mile away.
    .
    Quote Originally Posted by hispls View Post
    You need to keep the smoke INSIDE the amplifier. Once you've allowed all the happy smoke to escape the amp will stop working.
    BOYCOTT SKAR AUDIO! SHADY BUSINESS PRACTICES SHOULD NEVER BE ENCOURAGED!

  5. #4
    Flex68's Avatar
    Flex68 is offline dilligaf



    Join Date
    Jan 2012
    Location
    The Backroads
    Posts
    1,613
    Post Thanks / Like
    Images
    1
    Mentioned
    21 Post(s)

    Re: Amp stopped working when subs blew

    The amp is pouting....just give it a couple days



    Quote Originally Posted by Spider Monkey View Post
    Romney will [fornicate] me less than Obama already has and WAY less than what Obama has planned.
    Refs: adamtwo4, basscort2009, burzendowski, clanassa, cthedinger, ikoolguy, its_bacon12, Jew_Bagel, jr711, kreapin, kowboy, Rudy, TheRealDefman, Winter_C

    HU:Eclipse CD7200 MkII
    Subs: Fack Skar Audio
    Front comps: HAT Clarus C61-2 off Sony ES 7547
    Electrical: C&D batt, Big 3 with 1/0, 4ga to amps, Stinger RCA’s
    Damping: 60mil FG panels over holes, full worx from SDS

  6. Likes SplAffair liked this post
  7. #5
    Join Date
    Jan 2007
    Location
    any wet spot i can find
    Posts
    3,280
    Post Thanks / Like
    Mentioned
    50 Post(s)

    Re: Amp stopped working when subs blew

    lol..




    "Bailout: Taking a trillion dollars from the people and giving it to the banks so the banks can loan it back to the people, at interest!"

  8. #6
    mylows10's Avatar
    mylows10 is online now Cali DC PHD & Tantric rep



    Join Date
    Sep 2009
    Location
    monterey , ca
    Age
    50
    Posts
    17,510
    Post Thanks / Like
    Images
    9
    Mentioned
    467 Post(s)

    Re: Amp stopped working when subs blew





    pioneer avhx 5500 dvd, gzpa 1.4000 x 2
    ab vfl 350.4 ,7 pc 2150 and a 150 ah power ware agm ,275 amp singer alt , 2nd one coming soon
    cdt 6.5 es 6 im mids,cdt es 010 tweets,es 02 mids ,mx1000 3 way x overs , sky high and stinger hpm o gauge wires ,also 2 tantric hdd 15's in a 9.5. ^3 ported no wall box 11.5 octo port.
    NOR CAL DB DRAG JUDGE
    http://www.dcsoundlab.com

  9. #7
    JoshC's Avatar
    JoshC is offline The Taco MASTA



    Join Date
    Jul 2011
    Location
    Houston, tx
    Posts
    2,438
    Post Thanks / Like
    Images
    5
    Mentioned
    3 Post(s)

    Re: Amp stopped working when subs blew

    The subs blew cuz u blew the amp..... Buy a multi meter and read the setting gain stickie in the amp sections of the forms





    Pioneer DEH-P9400BH-CDT HD61s-Kenwood&AQ-Obsidian 12
    Doors covered inside and out in AT 60mill

    Sold to: akheathen, audiobaun----Traded with: Mylows10-------Bought from: fasfocus00, Ram_Designs, Mylows10, power-fanatic07, Argento

Closed Thread

Similar Threads

  1. Replies: 4
    Last Post: 10-19-2007, 11:21 PM
  2. Amps stopped working
    By MaxC in forum Wiring, Electrical and Installation Help
    Replies: 5
    Last Post: 05-28-2006, 01:35 PM
  3. My tweeters stop working when Pushed Hard...Ideas?
    By Starky in forum General Discussion
    Replies: 9
    Last Post: 05-13-2006, 08:40 PM
  4. Amp stopped working
    By whiterice in forum Amplifiers
    Replies: 1
    Last Post: 03-04-2006, 04:51 PM
  5. Amp stops working.
    By yo0123yo in forum Amplifiers
    Replies: 20
    Last Post: 08-30-2005, 03:21 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may edit your posts

1e2 Forum