Closed Thread
Results 1 to 2 of 2

Reload Thread: need help?? whats wrong

  1. #1
    Chris Taylor's Avatar
    Chris Taylor is offline Junior Member



    Join Date
    Jun 2011
    Location
    MA
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    need help?? whats wrong

    ok i have a 2000 corvette and i am looking to slam it . i in installed a a custom box specs below
    i have a jl audio w6 and a kicker kx400.1 just does not sound right . what do you all think replay the amp or sub woofer or both .


    Mounting depth - 6 1/8" for 12" sub (based on 6" magnet) 6.75" for 10" sub (based on 6" magnet)

    Mounting hole - 9 1/8" for 10" subs & 11 1/8" for 12" subs (Adjustable by request)

    Total volume of airspace - 1.03ft^3 Adjustable by request (we can only reduce the airspace)

    Airspace per chamber - 1.03ft^3

    Chambers - 1

    Style - Sealed (non Ported)

    Construction - Premium MDF (not the thin, lighweight, porous mdf - we do not sacrifice sound quality to save a couple pounds)

    MDF thickness -0.75"







  2. #2
    sleazebagger's Avatar
    sleazebagger is offline nobody!!!



    Join Date
    May 2010
    Location
    Madison, WI
    Age
    34
    Posts
    3,247
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    349 Post(s)

    Re: need help?? whats wrong

    Welcome to the forum.

    Let me guess: That sub is just laughing at that amp because first off its probably not the proper ohm load and second that thing is a drop in the bucket for the amount of power you can give one of those.

    If I'm correct then the w6 has two 6ohm vc's when run in series demands a 3 ohm load?




Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may edit your posts
1e2 Forum