Closed Thread
Results 1 to 2 of 2

Reload Thread: Has anyone tried running a Dayton plate amp @ 2ohms?

  1. #1
    psych0ticnemes1's Avatar
    psych0ticnemes1 is offline Psych0tic Customs



    Join Date
    Apr 2005
    Location
    Behind You
    Posts
    5,823
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    172 Post(s)

    Icon32 Has anyone tried running a Dayton plate amp @ 2ohms?

    I know it isn't recommended, I'm just curious if it would handle it.

    Thanks.

    -Psych0



    References:

    Ali1, michaellane, cadillac114, chasinSKURT, DaRevrin, rhuff80, sam yung, The215, tukn18s, Xenophontos,nuboot,jfitz97,LuckyDerDer 2x




  2. #2
    keep_hope_alive's Avatar
    keep_hope_alive is offline Acoustics Engineer keep_hope_alive is a Supporting Member of the forum!



    Join Date
    May 2007
    Location
    Quad Cities, IL
    Posts
    6,024
    Post Thanks / Like
    Images
    28
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1157 Post(s)

    Re: Has anyone tried running a Dayton plate amp @ 2ohms?

    Quote Originally Posted by psych0ticnemes1 View Post
    I know it isn't recommended, I'm just curious if it would handle it.

    Thanks.

    -Psych0
    add some fans for cooling and i think it would be fine. i would mount the plate amp in a separate enclosure with fans on both sides. granted you won't get more power out of it (a bit less actually) since you can't exceed current ratings.



    have you been helped by me? i'd love to know. shoot me a PM.

    My 2014 Accord build log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/608637-2014-accord-sport-sq-build-keep_hope_alive.html
    ***My YouTube Channel https://www.youtube.com/channel/UCkYUo2EShW9lgtrfXiDvLNQ/videos
    *My 2001 Accord build log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/536049-2001-accord-ex-sedan-its-long.html
    *2005 Scion tC Build Log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/516096-2005-scion-tc-sq-hertz-audison-pioneer-build-log.html

Closed Thread

Similar Threads

  1. Has anyone heard of > HighEnd car stereo amps??
    By 98preludeSH in forum Subwoofers
    Replies: 2
    Last Post: 11-12-2004, 09:55 AM
  2. has anyone tried those??
    By serg18 in forum Car Video, Security and Electronics
    Replies: 0
    Last Post: 03-04-2004, 10:29 PM
  3. has anyone tried the PG octane R
    By mrburner in forum Amplifiers
    Replies: 0
    Last Post: 03-04-2004, 05:17 PM
  4. Anyone ever run Phoenix Gold ti amps???
    By DJ FURY in forum Amplifiers
    Replies: 1
    Last Post: 02-15-2004, 10:33 AM
  5. Replies: 3
    Last Post: 12-04-2003, 01:12 AM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum