Closed Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 17

Reload Thread: Alpine IDA-X305s won't connect to iPhone

  1. #1
    Face of Fear's Avatar
    Face of Fear is offline GTP KILLA



    Join Date
    May 2008
    Location
    Bettendorf, Ia
    Posts
    525
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Alpine IDA-X305s won't connect to iPhone

    So I recently purchased an Alpine IDA-X305s used and installed it in my car. Love the deck, but for some reason even with the Alpine iPod cable it will not make connection to my iPhone 4S. Keeps saying USB device error. Tried plugging it into the USB and it says the exact same thing.

    Anyone have any ideas or suggestions? This deck is almost worthless to me if I can't plug my iPhone into it.



    Platform: 2002 Grand Prix 4 door
    Deck: Kenwood KDC-BT952HD
    Subwoofers: Undecided
    Amplifier: Undecided
    Wire: Shok Industries 1/0 Power/Ground Wire
    Eletrical Upgrades: Big 3
    Box: 12.5 Cube Wall




  2. #2
    jasonbillnelson's Avatar
    jasonbillnelson is offline LEAD, FOLLOW, OR GTFO!!!



    Join Date
    Oct 2012
    Location
    Andrews AFB, MD
    Age
    27
    Posts
    1,215
    Post Thanks / Like
    Images
    16
    Mentioned
    2 Post(s)

    Re: Alpine IDA-X305s won't connect to iPhone

    Did you have any recent updates on your iPhone?



    SSgt. Jason Nelson
    Andrews AFB, MD USAF

    Dealt with audiobahn, sangthing, 93 saturn sl2, basswiigee, goodstuff, HomeGrown, 06gtmike
    HU: Clarion NX501 Nav Deck
    Amps: C2 Audio Recon 1.6, Sundown SAX50.4
    Speakers: MB Quart ONX216 Components - 2 full sets
    Subwoofer: C2 Audio Threatcon 4 V1 12"
    Wire/Battery: SHCA 1/0 OFC--Shuriken BT-80 and Shuriken BT-35
    Alternator: Mechman 320 amp

  3. #3
    jasonbillnelson's Avatar
    jasonbillnelson is offline LEAD, FOLLOW, OR GTFO!!!



    Join Date
    Oct 2012
    Location
    Andrews AFB, MD
    Age
    27
    Posts
    1,215
    Post Thanks / Like
    Images
    16
    Mentioned
    2 Post(s)

    Re: Alpine IDA-X305s won't connect to iPhone




    SSgt. Jason Nelson
    Andrews AFB, MD USAF

    Dealt with audiobahn, sangthing, 93 saturn sl2, basswiigee, goodstuff, HomeGrown, 06gtmike
    HU: Clarion NX501 Nav Deck
    Amps: C2 Audio Recon 1.6, Sundown SAX50.4
    Speakers: MB Quart ONX216 Components - 2 full sets
    Subwoofer: C2 Audio Threatcon 4 V1 12"
    Wire/Battery: SHCA 1/0 OFC--Shuriken BT-80 and Shuriken BT-35
    Alternator: Mechman 320 amp

  4. #4
    Face of Fear's Avatar
    Face of Fear is offline GTP KILLA

    Threadstarter


    Join Date
    May 2008
    Location
    Bettendorf, Ia
    Posts
    525
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Alpine IDA-X305s won't connect to iPhone

    Haven't done an update in awhile now. My phones jailbroke so I don't update much. It works fine on my old clarion, my kenwood 952hd, and my girls jvc, but won't connect with my alpine. Tried going through those reset steps and still won't connect. Still reads USB device error.



    Platform: 2002 Grand Prix 4 door
    Deck: Kenwood KDC-BT952HD
    Subwoofers: Undecided
    Amplifier: Undecided
    Wire: Shok Industries 1/0 Power/Ground Wire
    Eletrical Upgrades: Big 3
    Box: 12.5 Cube Wall

  5. #5
    jasonbillnelson's Avatar
    jasonbillnelson is offline LEAD, FOLLOW, OR GTFO!!!



    Join Date
    Oct 2012
    Location
    Andrews AFB, MD
    Age
    27
    Posts
    1,215
    Post Thanks / Like
    Images
    16
    Mentioned
    2 Post(s)

    Re: Alpine IDA-X305s won't connect to iPhone

    Ya thats weird. I had an older CDA-9887 that wouldn't connect to an Ipod Classic through the alpine ipod cable. It worked for about 3 months and then nothing. Bought another cable, same issue. Ended up trading my vehicle in and I put a Clarion NX501 in my new ride and never had an issue with ipod touch 4gen or my iPhone 4s. I would call customer support and see if there is an alpine firmware update for your head unit.



    SSgt. Jason Nelson
    Andrews AFB, MD USAF

    Dealt with audiobahn, sangthing, 93 saturn sl2, basswiigee, goodstuff, HomeGrown, 06gtmike
    HU: Clarion NX501 Nav Deck
    Amps: C2 Audio Recon 1.6, Sundown SAX50.4
    Speakers: MB Quart ONX216 Components - 2 full sets
    Subwoofer: C2 Audio Threatcon 4 V1 12"
    Wire/Battery: SHCA 1/0 OFC--Shuriken BT-80 and Shuriken BT-35
    Alternator: Mechman 320 amp

  6. #6
    Face of Fear's Avatar
    Face of Fear is offline GTP KILLA

    Threadstarter


    Join Date
    May 2008
    Location
    Bettendorf, Ia
    Posts
    525
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Alpine IDA-X305s won't connect to iPhone

    I'm prolly gonna have to. I picked this deck up since I don't run CDs anyway, but if I can't get it to connect its useless to me.



    Platform: 2002 Grand Prix 4 door
    Deck: Kenwood KDC-BT952HD
    Subwoofers: Undecided
    Amplifier: Undecided
    Wire: Shok Industries 1/0 Power/Ground Wire
    Eletrical Upgrades: Big 3
    Box: 12.5 Cube Wall

  7. #7
    jasonbillnelson's Avatar
    jasonbillnelson is offline LEAD, FOLLOW, OR GTFO!!!



    Join Date
    Oct 2012
    Location
    Andrews AFB, MD
    Age
    27
    Posts
    1,215
    Post Thanks / Like
    Images
    16
    Mentioned
    2 Post(s)

    Re: Alpine IDA-X305s won't connect to iPhone

    agreed. Call them and get some updates done on your phone.



    SSgt. Jason Nelson
    Andrews AFB, MD USAF

    Dealt with audiobahn, sangthing, 93 saturn sl2, basswiigee, goodstuff, HomeGrown, 06gtmike
    HU: Clarion NX501 Nav Deck
    Amps: C2 Audio Recon 1.6, Sundown SAX50.4
    Speakers: MB Quart ONX216 Components - 2 full sets
    Subwoofer: C2 Audio Threatcon 4 V1 12"
    Wire/Battery: SHCA 1/0 OFC--Shuriken BT-80 and Shuriken BT-35
    Alternator: Mechman 320 amp

  8. #8
    Face of Fear's Avatar
    Face of Fear is offline GTP KILLA

    Threadstarter


    Join Date
    May 2008
    Location
    Bettendorf, Ia
    Posts
    525
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Alpine IDA-X305s won't connect to iPhone

    Even with updates it won't work. My buddies iPhone 5 with all the new updates does the same thing. I think the deck doesn't like the iPhone 4 or 5.



    Platform: 2002 Grand Prix 4 door
    Deck: Kenwood KDC-BT952HD
    Subwoofers: Undecided
    Amplifier: Undecided
    Wire: Shok Industries 1/0 Power/Ground Wire
    Eletrical Upgrades: Big 3
    Box: 12.5 Cube Wall

  9. #9
    Face of Fear's Avatar
    Face of Fear is offline GTP KILLA

    Threadstarter


    Join Date
    May 2008
    Location
    Bettendorf, Ia
    Posts
    525
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Alpine IDA-X305s won't connect to iPhone

    Called alpine. The guy instantly said there was something wrong with the deck. Didn't attempt to trouble shoot it or anything. Very disappointed with the customer service.



    Platform: 2002 Grand Prix 4 door
    Deck: Kenwood KDC-BT952HD
    Subwoofers: Undecided
    Amplifier: Undecided
    Wire: Shok Industries 1/0 Power/Ground Wire
    Eletrical Upgrades: Big 3
    Box: 12.5 Cube Wall

  10. #10
    jasonbillnelson's Avatar
    jasonbillnelson is offline LEAD, FOLLOW, OR GTFO!!!



    Join Date
    Oct 2012
    Location
    Andrews AFB, MD
    Age
    27
    Posts
    1,215
    Post Thanks / Like
    Images
    16
    Mentioned
    2 Post(s)

    Re: Alpine IDA-X305s won't connect to iPhone

    still under warranty???



    SSgt. Jason Nelson
    Andrews AFB, MD USAF

    Dealt with audiobahn, sangthing, 93 saturn sl2, basswiigee, goodstuff, HomeGrown, 06gtmike
    HU: Clarion NX501 Nav Deck
    Amps: C2 Audio Recon 1.6, Sundown SAX50.4
    Speakers: MB Quart ONX216 Components - 2 full sets
    Subwoofer: C2 Audio Threatcon 4 V1 12"
    Wire/Battery: SHCA 1/0 OFC--Shuriken BT-80 and Shuriken BT-35
    Alternator: Mechman 320 amp

  11. #11
    Face of Fear's Avatar
    Face of Fear is offline GTP KILLA

    Threadstarter


    Join Date
    May 2008
    Location
    Bettendorf, Ia
    Posts
    525
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Alpine IDA-X305s won't connect to iPhone

    Bought it used so doubtful. He told me $95 to fix it. That takes it over brand new price. I'm having bad luck with head units. Lol



    Platform: 2002 Grand Prix 4 door
    Deck: Kenwood KDC-BT952HD
    Subwoofers: Undecided
    Amplifier: Undecided
    Wire: Shok Industries 1/0 Power/Ground Wire
    Eletrical Upgrades: Big 3
    Box: 12.5 Cube Wall

  12. #12
    jasonbillnelson's Avatar
    jasonbillnelson is offline LEAD, FOLLOW, OR GTFO!!!



    Join Date
    Oct 2012
    Location
    Andrews AFB, MD
    Age
    27
    Posts
    1,215
    Post Thanks / Like
    Images
    16
    Mentioned
    2 Post(s)

    Re: Alpine IDA-X305s won't connect to iPhone

    $95 to fix?! Better come with a 1 year warranty against that problem again!!! I paid $485 for a refurbished Clarion NX501 Feb 2012 and haven't had any issues. Everything works awesome.



    SSgt. Jason Nelson
    Andrews AFB, MD USAF

    Dealt with audiobahn, sangthing, 93 saturn sl2, basswiigee, goodstuff, HomeGrown, 06gtmike
    HU: Clarion NX501 Nav Deck
    Amps: C2 Audio Recon 1.6, Sundown SAX50.4
    Speakers: MB Quart ONX216 Components - 2 full sets
    Subwoofer: C2 Audio Threatcon 4 V1 12"
    Wire/Battery: SHCA 1/0 OFC--Shuriken BT-80 and Shuriken BT-35
    Alternator: Mechman 320 amp

  13. #13
    Face of Fear's Avatar
    Face of Fear is offline GTP KILLA

    Threadstarter


    Join Date
    May 2008
    Location
    Bettendorf, Ia
    Posts
    525
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Alpine IDA-X305s won't connect to iPhone

    I had a eclipse cd2000 and other than skipping at 152db I had no issues. Sold it and bought a clarion vz401 and loved it. Needed something different after 2 years so I bought a kenwood kdc-bt952hd from worst buy...needless to say it lasted a week and the whole faceplate quit working. Returned it and now I have the alpine. Had great luck up until the last 2 decks.



    Platform: 2002 Grand Prix 4 door
    Deck: Kenwood KDC-BT952HD
    Subwoofers: Undecided
    Amplifier: Undecided
    Wire: Shok Industries 1/0 Power/Ground Wire
    Eletrical Upgrades: Big 3
    Box: 12.5 Cube Wall

  14. #14
    jasonbillnelson's Avatar
    jasonbillnelson is offline LEAD, FOLLOW, OR GTFO!!!



    Join Date
    Oct 2012
    Location
    Andrews AFB, MD
    Age
    27
    Posts
    1,215
    Post Thanks / Like
    Images
    16
    Mentioned
    2 Post(s)

    Re: Alpine IDA-X305s won't connect to iPhone

    That $ucks man.....hope it all works out for you! I'd probably sell it for cheap on here and letting people know it will cost them $95 to fix the issue. Then look into another clarion or something.



    SSgt. Jason Nelson
    Andrews AFB, MD USAF

    Dealt with audiobahn, sangthing, 93 saturn sl2, basswiigee, goodstuff, HomeGrown, 06gtmike
    HU: Clarion NX501 Nav Deck
    Amps: C2 Audio Recon 1.6, Sundown SAX50.4
    Speakers: MB Quart ONX216 Components - 2 full sets
    Subwoofer: C2 Audio Threatcon 4 V1 12"
    Wire/Battery: SHCA 1/0 OFC--Shuriken BT-80 and Shuriken BT-35
    Alternator: Mechman 320 amp

  15. #15
    Face of Fear's Avatar
    Face of Fear is offline GTP KILLA

    Threadstarter


    Join Date
    May 2008
    Location
    Bettendorf, Ia
    Posts
    525
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Alpine IDA-X305s won't connect to iPhone

    I just bought it from a guy on caco a few days ago. I'm waitin on a message back from him. I'm short on funds for the next couple weeks so I'm gonna hang onto it for now so I have music.



    Platform: 2002 Grand Prix 4 door
    Deck: Kenwood KDC-BT952HD
    Subwoofers: Undecided
    Amplifier: Undecided
    Wire: Shok Industries 1/0 Power/Ground Wire
    Eletrical Upgrades: Big 3
    Box: 12.5 Cube Wall

Closed Thread
Page 1 of 2 1 2 LastLast

Similar Threads

  1. What is going on! (Alpine iDA-X305 not reading iPod/iPhone, USB drives only)
    By mckeough in forum Wiring, Electrical and Installation Help
    Replies: 1
    Last Post: 01-20-2012, 03:32 PM
  2. Replies: 1
    Last Post: 07-30-2010, 10:26 PM
  3. Alpine iDA-x305 does not work with iPhone OS 4.0!
    By DanDigital in forum Head Units
    Replies: 2
    Last Post: 06-24-2010, 07:32 PM
  4. Alpine IDA-X305 thoughts
    By JrVtecAccord in forum Head Units
    Replies: 9
    Last Post: 11-21-2009, 01:22 AM
  5. Replies: 0
    Last Post: 06-18-2008, 12:41 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum