Closed Thread
Results 1 to 4 of 4

Reload Thread: Clarion VRX585USB no power problems

  1. #1
    richardcee's Avatar
    richardcee is offline Junior Member



    Join Date
    Mar 2013
    Location
    Central Scotland,Falkirk
    Posts
    2
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Clarion VRX585USB no power problems

    hey guys ive got a Clarion VRX585USB and there dosent seem to be getting any power to it ive checked all the suspected stuff as i am a mechanic but i cant seam to find any problems with it has any one got any ideas ????







  2. #2
    nismos14's Avatar
    nismos14 is offline CarAudio.com Veteran



    Join Date
    Dec 2006
    Location
    Jersey
    Age
    33
    Posts
    14,518
    Post Thanks / Like
    Mentioned
    4 Post(s)

    Re: Clarion VRX585USB no power problems

    Ok, details of what you checked would help.






    Car audio IS an addiction.
    C.A.A.A Member #1
    (Car Audio Addicts Anonymous)
    Refs http://www.caraudio.com/forums/buyer-seller-feedback/278560-nismos14-feedback-refs-thread.html


  3. #3
    richardcee's Avatar
    richardcee is offline Junior Member

    Threadstarter


    Join Date
    Mar 2013
    Location
    Central Scotland,Falkirk
    Posts
    2
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Clarion VRX585USB no power problems

    fuses,wiring harness,the plugs them self, i opened it up and gave it a blow out and i checked the insides were ok buy what i mean nothing on any off the boards looked odd everything looked fine so u made sure all plugs were in and rebuilt it.




  4. #4
    smgreen20's Avatar
    smgreen20 is offline phoenixphorum-com



    Join Date
    Apr 2005
    Location
    Lafayette,IN
    Age
    37
    Posts
    1,172
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Clarion VRX585USB no power problems

    The fuse panel in the vehicle itself?????? Or did you do your testing with the HU removed?




    My install
    http://phoenixphorum.com/viewtopic.php?f=10&t=16998

Closed Thread

Similar Threads

  1. Sony GT420IP No Power Problem
    By mike689 in forum Wiring, Electrical and Installation Help
    Replies: 9
    Last Post: 06-19-2008, 02:01 AM
  2. avh-p7500/avic-80 problem - no power
    By ync in forum Car Video, Security and Electronics
    Replies: 2
    Last Post: 04-13-2005, 09:19 PM
  3. Clarion and no-eject problem
    By malagasy in forum Head Units
    Replies: 3
    Last Post: 10-17-2004, 01:18 PM
  4. Clarion vxd935vd NO POWER
    By armani2 in forum Wiring, Electrical and Installation Help
    Replies: 3
    Last Post: 01-31-2004, 09:12 AM
  5. Weird problem. Dimming, but no power loss? Any suggestions?
    By Aurorav8 in forum General Discussion
    Replies: 31
    Last Post: 09-05-2003, 08:41 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum