Closed Thread
Results 1 to 3 of 3

Reload Thread: Electrical Fire: Now HU Not Turning On, But Car Charger Does Work?

  1. #1
    Shojahan's Avatar
    Shojahan is offline Banned



    Join Date
    Apr 2012
    Location
    San Juan Capistrano
    Posts
    32
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Electrical Fire: Now HU Not Turning On, But Car Charger Does Work?

    The accessories fuse is fine. Last night, smoke started coming out from the base of the steering wheel column and the whole cabin was filled with acrid smoke.

    If it was a short circuit, could it have been because I disconnected the cables inside the sub box in the trunk? Because the subwoofer had stopped working first. What exactly is a short circuit anyway?

    Thanks and Likes for please any answers...







  2. #2
    gckless's Avatar
    gckless is offline CarAudio.com Veteran



    Join Date
    Aug 2011
    Location
    San Antonio
    Posts
    4,106
    Post Thanks / Like
    Mentioned
    28 Post(s)

    Re: Electrical Fire: Now HU Not Turning On, But Car Charger Does Work?

    Quote Originally Posted by Shojahan View Post
    The accessories fuse is fine. Last night, smoke started coming out from the base of the steering wheel column and the whole cabin was filled with acrid smoke.

    If it was a short circuit, could it have been because I disconnected the cables inside the sub box in the trunk? Because the subwoofer had stopped working first. What exactly is a short circuit anyway?

    Thanks and Likes for please any answers...
    You need to open up your dash and find out what actually smoked. Could be important. And google short circuit.



    Quote Originally Posted by ducatipaso View Post
    15inch subs can't play fast beats, they take more power and that taxes the vehicles electrical system. You will wake up and "hear" then see the light at the end of the tunnel and it will be 3 10's pounding so hard you wont even open your trunk or turn your system on because you 15's will sound sloppy & weak.
    Quote Originally Posted by benbenondatrack View Post
    stfu lesbo.why are you worried about me so much? you must want to date me ya little cookie monster but i dont even like sweets. your just a cup full of ice, dirt dead nasty azz ice...without the water.

    Dat Build Log: http://mobileaudioforum.com/forum/showthread.php?2566-1999-Chevrolet-Blazer&highlight=1999+blazer

  3. Thanks Shojahan thanked for this post
    Likes Shojahan liked this post
  4. #3
    Phoenix Risen's Avatar
    Phoenix Risen is offline OG.... Original Ginger



    Join Date
    Jun 2010
    Location
    Dayton/Springfield, Ohio
    Posts
    4,063
    Post Thanks / Like
    Mentioned
    27 Post(s)

    Re: Electrical Fire: Now HU Not Turning On, But Car Charger Does Work?

    also some information on what type of vehicle it is and what all mods have been done to it (that actually effect the electrical system) would help a lot...



    R.I.P. 2008 Hyundai Tiburon GS
    2005 Subaru Baja turbo, build in planing stages.

  5. Thanks Shojahan thanked for this post
    Likes Shojahan liked this post
Closed Thread

Similar Threads

  1. Amp wont turn on, but mute relay does
    By REDz28 in forum Wiring, Electrical and Installation Help
    Replies: 7
    Last Post: 06-14-2012, 09:47 PM
  2. Eclipes Deck not turning on when car turns on
    By dw9000 in forum Wiring, Electrical and Installation Help
    Replies: 2
    Last Post: 09-30-2007, 06:32 PM
  3. Pioneer HU turns on but is dim? HELP!
    By angry monkey in forum Head Units
    Replies: 2
    Last Post: 07-13-2005, 05:11 PM
  4. HU not turning on?
    By chinxtaboi in forum General Discussion
    Replies: 3
    Last Post: 06-11-2003, 03:45 PM
  5. Amp turns on but not off....why???
    By RobWiz in forum General Discussion
    Replies: 4
    Last Post: 04-04-2003, 05:19 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum