Closed Thread
Results 1 to 4 of 4

Reload Thread: kenwood dnx9990 and relay ?

  1. #1
    psylo535's Avatar
    psylo535 is offline Member



    Join Date
    Apr 2006
    Location
    tampa,fl.
    Posts
    111
    Post Thanks / Like
    Mentioned
    0 Post(s)

    kenwood dnx9990 over priced pile of sh.. !

    My 2 month old kenwood 9990 crapped out on me .The startrup screen just keeps rebooting over and over.The shop I bought it from sent it back to kenwood for warranty. Now the shop says the reason this happens is because this unit draws too much power or something like that. They told me to wire a relay between the battery and the headunit and I should be good to go. Has anyone heard of this or is it just a load of crap.I'm pretty pissed off that my new $1000+ headunit already had to go in for service and I had a hole in my dash for over a week. I have read on the kenwood forums that other people have had the same problem but never heard of using a relay to fix it
    Last edited by psylo535; 09-06-2012 at 06:52 AM. Reason: wrong title







  2. #2
    psylo535's Avatar
    psylo535 is offline Member

    Threadstarter


    Join Date
    Apr 2006
    Location
    tampa,fl.
    Posts
    111
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: kenwood dnx9990 and relay ?

    wow, a lot of help here.




  3. #3
    maylar's Avatar
    maylar is offline Electrical Weenie



    Join Date
    Jan 2002
    Location
    Connecticut
    Age
    62
    Posts
    3,433
    Post Thanks / Like
    Mentioned
    13 Post(s)

    Re: kenwood dnx9990 and relay ?

    Sounds like BS to me.



    dave
    ----------
    1999 Buick Park Ave Ultra
    Head Unit: JVC KWHDR720
    EQ: Audiocontrol EQL
    Front Stage: Hybrid Audio Technologies Imagine 5.25 mids, Morel Maximo tweets
    Sub Stage: Boston G3 10", 0.5 cu ft sealed
    Amp: PPI Phantom 900.4
    Rear Fill: Boston SE953 6X9's

  4. #4
    psylo535's Avatar
    psylo535 is offline Member

    Threadstarter


    Join Date
    Apr 2006
    Location
    tampa,fl.
    Posts
    111
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: kenwood dnx9990 and relay ?

    Update. I had kenwood warranty fix the rebooting problem and all was well for about 5-6 weeks. Now I have a new problem that of course kenwoods answer is send it in. I am tired of taking it in and out and being without a stereo. It seems to randomly stop playing music through my front comps and my subwoofers. It goes off for a few seconds and then comes back on. This is at any listening level not just wide open.When the fronts and subs cut out my rear fill wired to the deck itself stays on. I really doubt it is 2 bad amps and 2 bad sets of rca's. I think there is an issue with the preouts on the deck. Any thoughts on this. I have had it with kenwood and their overpriced junk




Closed Thread

Similar Threads

  1. Kenwood Amps and Subs
    By tehon3299 in forum Subwoofers
    Replies: 7
    Last Post: 07-03-2002, 10:55 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum