Closed Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 16

Reload Thread: Dual 6630 Audio Problem

  1. #1
    MarkInTombstone's Avatar
    MarkInTombstone is offline Junior Member



    Join Date
    Dec 2010
    Location
    Tombstone,Az
    Posts
    9
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Dual 6630 Audio Problem

    n00bie here and I have a question that you audio guys might be able to help with.

    I bought a new Dual 6630 with (USB, Bluetooth, iPod)

    I matched all the color wiring to my Jeep GC harness and grounded the head unit chassis as recommended. Go to turn it on and it turns on and all. Lets you program the BT and set the settings. But there's no audio. I don't believe its the head unit cause I exchanged it for another one and same thing, No Audio. I've checked my door jams for wire breaks and found one break. now I know why my passenger window didn't worked. At least thats fixed.

    But can anyone tell me what am I missing here? I know that in 96 Jeep put an amp under the back seat to run the speakers but I don't think they installed amps in 93's.

    I appreciate any help and advice on this matter. Thanks, Mark







  2. #2
    Phoenix Risen's Avatar
    Phoenix Risen is offline OG.... Original Ginger



    Join Date
    Jun 2010
    Location
    Dayton/Springfield, Ohio
    Posts
    4,064
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    350 Post(s)

    Re: Dual 6630 Audio Problem

    first throw that POS dual in the garbage where it belongs.

    and id you just tap directly into your factory harness or did you use a vehicle specific harness?



    R.I.P. 2008 Hyundai Tiburon GS
    2005 Subaru Baja turbo, build in planing stages.

  3. #3
    MarkInTombstone's Avatar
    MarkInTombstone is offline Junior Member

    Threadstarter


    Join Date
    Dec 2010
    Location
    Tombstone,Az
    Posts
    9
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Dual 6630 Audio Problem

    Quote Originally Posted by Phoenix Risen View Post
    first throw that POS dual in the garbage where it belongs.

    and id you just tap directly into your factory harness or did you use a vehicle specific harness?
    LOL @ the POS.

    I have the harness with all the purdy colors that came with the Jeep. I could've got a better model but its a daily driver and I off-road. So why pay high end to have the thing rattle apart. The speaker wires are real thin. Do you think the problem could be there?




  4. #4
    CL1CKCLACK's Avatar
    CL1CKCLACK is offline CarAudio.com Boss



    Join Date
    Dec 2009
    Location
    Land Of The Hicks...
    Age
    24
    Posts
    5,167
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    118 Post(s)

    Re: Dual 6630 Audio Problem

    Get a new HU



    1996 Mitsu Clipse GSX 450whp
    1997 Eagle Talon TSI

    refs:
    wes007parks, ridinswangaz, madmat, treylittlefield, mendezm9
    MHD2000, RetroAudioInc, power-fanatic07, Carnivorous18, Spltuscon
    Ridinhi, Wingsfreak9, Pro-Rabbit, 2000LaDe, nom nom
    DBBOOM, hrtbrk1, dgaf_, dirtbikkerrob, Nik592, SkylineTT

  5. #5
    MarkInTombstone's Avatar
    MarkInTombstone is offline Junior Member

    Threadstarter


    Join Date
    Dec 2010
    Location
    Tombstone,Az
    Posts
    9
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Dual 6630 Audio Problem

    Quote Originally Posted by [zack] View Post
    Get a new HU
    A what?




  6. #6
    CL1CKCLACK's Avatar
    CL1CKCLACK is offline CarAudio.com Boss



    Join Date
    Dec 2009
    Location
    Land Of The Hicks...
    Age
    24
    Posts
    5,167
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    118 Post(s)

    Re: Dual 6630 Audio Problem

    Quote Originally Posted by MarkInTombstone View Post
    A what?
    headunit



    1996 Mitsu Clipse GSX 450whp
    1997 Eagle Talon TSI

    refs:
    wes007parks, ridinswangaz, madmat, treylittlefield, mendezm9
    MHD2000, RetroAudioInc, power-fanatic07, Carnivorous18, Spltuscon
    Ridinhi, Wingsfreak9, Pro-Rabbit, 2000LaDe, nom nom
    DBBOOM, hrtbrk1, dgaf_, dirtbikkerrob, Nik592, SkylineTT

  7. #7
    MarkInTombstone's Avatar
    MarkInTombstone is offline Junior Member

    Threadstarter


    Join Date
    Dec 2010
    Location
    Tombstone,Az
    Posts
    9
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Dual 6630 Audio Problem

    Quote Originally Posted by [zack] View Post
    headunit
    That's what I thought I got. I don't need anything fancy. Just something that works. Who knows maybe someday I'll get a new car. Until then I don't dump a lot of money in this PoS Jeep. Its just transportation and be able to off road on weekends.




  8. #8
    whitedragon551's Avatar
    whitedragon551 is offline Moderator



    Join Date
    Mar 2009
    Location
    IL
    Posts
    13,560
    Post Thanks / Like
    Mentioned
    39 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1406 Post(s)

    Re: Dual 6630 Audio Problem

    Did you get a harness that wires up to the headunits harness and then plugs into the vehicles harness or did you just splice the headunit harness directly into the vehicle harness?



    CA.com FAQ's
    CA.com TOS Agreement
    Forum Rules



    HU: ///Alpine 9887, KCE-400BT, KCE-433IV, KTX-100EQ Imprint, 8Gb iPod Touch
    Front Mids: Eclipse SC6500
    Front Tweeters: Morel made Xtant 28MM Silks
    Subs: Audiomobile Evo 10" TC2+
    Enclosure: 1.1 Cubes sealed with 10 Ounces Poly Fill
    Amp: Audio Systems Twister F6 380 III

  9. #9
    MarkInTombstone's Avatar
    MarkInTombstone is offline Junior Member

    Threadstarter


    Join Date
    Dec 2010
    Location
    Tombstone,Az
    Posts
    9
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Dual 6630 Audio Problem

    Quote Originally Posted by whitedragon551 View Post
    Did you get a harness that wires up to the headunits harness and then plugs into the vehicles harness or did you just splice the headunit harness directly into the vehicle harness?
    Its the harness that was connected to the Pioneer. I cut those wires and matched the colors to the Dual. And then the twin connector deal connects into the vehicles harness out to the speakers.




  10. #10
    MarkInTombstone's Avatar
    MarkInTombstone is offline Junior Member

    Threadstarter


    Join Date
    Dec 2010
    Location
    Tombstone,Az
    Posts
    9
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Dual 6630 Audio Problem

    Sorry to be an annoyance, but I lack in the electronics field and I have no idea what this stuff means as in the book specs. The book says speaker output>4-8ohms, line output voltage>2 volts RMS. Now keep in mind I think the OEM speakers are still in there. And as far as I see the wires look to be about a 22g(real thin).




  11. #11
    plugitin's Avatar
    plugitin is offline She Bangs



    Join Date
    Jul 2009
    Location
    Da U.P. eh?
    Age
    27
    Posts
    6,473
    Post Thanks / Like
    Images
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    111 Post(s)

    Re: Dual 6630 Audio Problem

    new hu is in order



    Team DC Audio


    Refs: absoluteaudio, rab, walnut, seedubs1, dbeez, -leister-, Louisiana_crx, bubbagumper6, DS Autpsports, Mr.Ronin_2U, lil98cabrio, wone, micah_jones, grinder1989

  12. #12
    MarkInTombstone's Avatar
    MarkInTombstone is offline Junior Member

    Threadstarter


    Join Date
    Dec 2010
    Location
    Tombstone,Az
    Posts
    9
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Dual 6630 Audio Problem

    Quote Originally Posted by plugitin View Post
    new hu is in order
    It is a new head unit. And I exchanged it, so this is the 2nd one from the store. How can 2 be bad with same problem?




  13. #13
    plugitin's Avatar
    plugitin is offline She Bangs



    Join Date
    Jul 2009
    Location
    Da U.P. eh?
    Age
    27
    Posts
    6,473
    Post Thanks / Like
    Images
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    111 Post(s)

    Re: Dual 6630 Audio Problem

    lolz, its a dual. Nuff said.



    Team DC Audio


    Refs: absoluteaudio, rab, walnut, seedubs1, dbeez, -leister-, Louisiana_crx, bubbagumper6, DS Autpsports, Mr.Ronin_2U, lil98cabrio, wone, micah_jones, grinder1989

  14. #14
    Phoenix Risen's Avatar
    Phoenix Risen is offline OG.... Original Ginger



    Join Date
    Jun 2010
    Location
    Dayton/Springfield, Ohio
    Posts
    4,064
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    350 Post(s)

    Re: Dual 6630 Audio Problem

    Quote Originally Posted by MarkInTombstone View Post
    Its the harness that was connected to the Pioneer. I cut those wires and matched the colors to the Dual. And then the twin connector deal connects into the vehicles harness out to the speakers.
    did you try to plug the pioneer harness into the dual hu?



    R.I.P. 2008 Hyundai Tiburon GS
    2005 Subaru Baja turbo, build in planing stages.

  15. #15
    MarkInTombstone's Avatar
    MarkInTombstone is offline Junior Member

    Threadstarter


    Join Date
    Dec 2010
    Location
    Tombstone,Az
    Posts
    9
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Dual 6630 Audio Problem

    Quote Originally Posted by Phoenix Risen View Post
    did you try to plug the pioneer harness into the dual hu?
    the plugs at the chassis are different




Closed Thread
Page 1 of 2 1 2 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum