Closed Thread
Results 1 to 5 of 5

Reload Thread: Pioneer head unit problem

  1. #1
    mtm5062's Avatar
    mtm5062 is offline Junior Member



    Join Date
    May 2010
    Location
    Philly PA
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Pioneer head unit problem

    I have had the Pioneer DEH P780MP head unit for over two years now and it worked great untill now. The head unit only displays the colorful screen (with the artist name and song) when it is ejected/ slanted down so that a cd can be inserted. When I hit eject to go back to the normal position the entire screen goes black, but the music still plays. When I eject it while it is hooked up to my ipod, the colorful screen will reappear. I tried cleaning it and that did not help. How do I fix this?







  2. #2
    CRXBMPN's Avatar
    CRXBMPN is offline ---> TEAM B.L.O. ME <---



    Join Date
    Jul 2004
    Location
    Maine
    Age
    34
    Posts
    8,474
    Post Thanks / Like
    Images
    45
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    224 Post(s)

    Re: Pioneer head unit problem

    is there a ribbon? i have had a few pioneers where the screen flickered or went out if not at certain angles... check that.



    Team Bass Lovers Of MainE/The Loud Crowd/CentralMaineBassHeads
    2k5 SLAP Stock 2 National Champion - I feel old...!
    1991 CRX, 2 x SAZ3000d's, Batcap 4000, couple other batts, 2 x FI BL 10's - 152.7 dash/155.1 outlaw


  3. #3
    whitedragon551's Avatar
    whitedragon551 is offline Moderator



    Join Date
    Mar 2009
    Location
    MI
    Posts
    13,112
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1181 Post(s)

    Re: Pioneer head unit problem

    Also clean the gold contacts with alcohol swabs and wipe dry.



    CA.com FAQ's
    CA.com TOS Agreement
    Forum Rules



    HU: ///Alpine 9887, KCE-400BT, KCE-433IV, KTX-100EQ Imprint, 8Gb iPod Touch
    Front Mids: Eclipse SC6500
    Front Tweeters: Morel made Xtant 28MM Silks
    Subs: Audiomobile Evo 10" TC2+
    Enclosure: 1.1 Cubes sealed with 10 Ounces Poly Fill
    Amp: Audio Systems Twister F6 380 III

  4. #4
    mtm5062's Avatar
    mtm5062 is offline Junior Member

    Threadstarter


    Join Date
    May 2010
    Location
    Philly PA
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Pioneer head unit problem

    What do you mean by ribbon? I tried cleaning it and that did not work.




  5. #5
    mtm5062's Avatar
    mtm5062 is offline Junior Member

    Threadstarter


    Join Date
    May 2010
    Location
    Philly PA
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Pioneer head unit problem

    Now the head unit will not even power on at all. I checked the 10w radio fuse and 15w car audio fuse and they were fine. Is this fixable?




Closed Thread

Similar Threads

  1. Pioneer Head Unit Problem
    By CamryMTX in forum Head Units
    Replies: 15
    Last Post: 07-01-2008, 03:28 PM
  2. Pioneer head unit problem
    By Muftobration in forum Head Units
    Replies: 0
    Last Post: 10-06-2007, 02:38 PM
  3. Pioneer Head Unit Problem
    By ip33610 in forum General Discussion
    Replies: 0
    Last Post: 04-21-2007, 11:11 PM
  4. Pioneer Head Unit Problem
    By ip33610 in forum Head Units
    Replies: 0
    Last Post: 04-20-2007, 02:36 AM
  5. Pioneer head unit problem
    By mvT-Bird in forum General Discussion
    Replies: 2
    Last Post: 05-14-2004, 01:52 AM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum