Closed Thread
Results 1 to 10 of 10

Reload Thread: Where can I go to get help with my Imprint device?

  1. #1
    grampi's Avatar
    grampi is offline CarAudio.com Elite



    Join Date
    Aug 2002
    Location
    Cheyenne
    Posts
    723
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Where can I go to get help with my Imprint device?

    I sent my KTX-100EQ with my 9887 to United Radio Service to see if they could get it to work with my HU as I could not. They said this item could not be field repaired so they can't even try to use it. Should I try to find a local shop that sells Alpine stuff to take it to to see if they can figure out why it won't work? I called Alpine tech support when I was trying to get it to work and they basically were no help. I would really like to get it to work, but I don't what else to do here.







  2. #2
    bigbirney420's Avatar
    bigbirney420 is offline CarAudio.com Veteran



    Join Date
    Feb 2005
    Location
    Omaha, NE
    Age
    38
    Posts
    2,395
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Where can I go to get help with my Imprint device?

    Take it to Authorized Alpine delaer, thats your best bet



    2009 Pontiac G8 GT, New Era Intake, Doug Thorley Exhaust, Patrick G Tune
    Building: Hybrid Imagine 6.5 front, Image Dynamics CTX 5.25 rear doors. Peerless SLS 8's rear deck off of Kicker ZXSum8 and ZX 700.5

    2007 Toyota 4Runner
    Eclipse XA100 sub amp and Incriminator 187 10 in 1.6 cubes
    Working on Double Din, nice 6.5 Seperates and 6.5 coaxs rear

    Refs: Pike110,Hintzyboy,dcmcki, qcsfinest704, MagickMan, allstar1500bd, ravemeister, Team PSI, Jntar, Brian Owens, and others....so many

  3. #3
    frzninvt's Avatar
    frzninvt is offline CarAudio.com Elite



    Join Date
    Apr 2005
    Location
    Vermont
    Posts
    528
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Where can I go to get help with my Imprint device?

    FYI United Radio is a premier authorized repair facility for Alpine products, the one in Syracuse, NY is anyway a 5 star one at that. If they can't service it I would take it back where you bought it for an exchange (oops forgot I read your other thread so return is not an option for you) or send it directly to Alpine in CA, they have a service facility there. Just give them a call and report to them what United Radio passed onto you.

    United Radio had trouble diagnosing the issue I was having with my 7998 awhile back and were going to deem it unrepairable that is when I called Alpine directly to discuss options and was told they have a place that does service work for them. UR must have put one of their Senior techs on my unit and they found a power supply problem (bad trace) and finally got it solved and working correctly.

    As electronics get more complex they get tougher to service probably alot of surface mount components that require specialized equipment to service.



    1995 Oriental Blue BMW 525i 5 Speed
    Stock Alpine System Actively Crossed Over & Amped w/CD 6-Disc Changer System with a/d/s 235is comps in front (3-Ways front, 2-Ways rear) sounds really good. All functions are displayed on the dash's check control display module.

  4. #4
    grampi's Avatar
    grampi is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Aug 2002
    Location
    Cheyenne
    Posts
    723
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Where can I go to get help with my Imprint device?

    Quote Originally Posted by frzninvt View Post
    FYI United Radio is a premier authorized repair facility for Alpine products, the one in Syracuse, NY is anyway a 5 star one at that. If they can't service it I would take it back where you bought it for an exchange (oops forgot I read your other thread so return is not an option for you) or send it directly to Alpine in CA, they have a service facility there. Just give them a call and report to them what United Radio passed onto you.

    United Radio had trouble diagnosing the issue I was having with my 7998 awhile back and were going to deem it unrepairable that is when I called Alpine directly to discuss options and was told they have a place that does service work for them. UR must have put one of their Senior techs on my unit and they found a power supply problem (bad trace) and finally got it solved and working correctly.

    As electronics get more complex they get tougher to service probably alot of surface mount components that require specialized equipment to service.
    It would be nice if I had another complete Imprint kit to work with. That way I could replace one item at a time and figure out exactly which piece is causing the problem. The only way I could see being able to do that would be to find an Alpine dealer that also does installations that has an Imprint. Sending mine into Alpine wouldn't really make me aware of a possible compatibility problem between my Imprint device and my 9887, or possibly a software compatibility issue between the Imprint software and my laptop. There are so many things in the loop that COULD be causing the problem, it's almost going to be impossible to determine exactly what it is without having two complete Imprint kits to work with. That's probably why Alpine tech support could offer no help over the phone.




  5. #5
    grampi's Avatar
    grampi is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Aug 2002
    Location
    Cheyenne
    Posts
    723
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Where can I go to get help with my Imprint device?

    You know, a light just went off in my head and maybe you guys can help figure out if it's a short, or I'm actually on to something. Something triggered something in my memory about a conversation in this or one of the other forums about the front and rear preouts on the 9887 actually being bass ackwards. In other words, I think they concluded that the preouts marked front (the top pair looking at the back of the unit) and the rear were actually just the opposite. I didn't think anything of it at the time, but when I hooked up my 9887 I remember I had the rca's plugged into the front jacks (the top ones) on the HU. I remember how strange it seemed that I could only fade the front speakers when the rear speakers were selected on the HU's menu. Nothing happened when I tried fading them when I had the front speakers selected. If the preouts are actually the opposite of what they're designated, then that would explain why the system was saying there was no front left speaker connected. I don't currently have the HU or I could just swap them and try it out.




  6. #6
    grampi's Avatar
    grampi is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Aug 2002
    Location
    Cheyenne
    Posts
    723
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Where can I go to get help with my Imprint device?

    SOB!!!!! I am sssssssssoooooooooo frickin' stupid!!!!!!!!!!!

    I was just looking at the manual for my 9887 and on the connections page (page 40) in the manual it says the top preamp connectors are for the rear speaker amp, and the middle pair are for the front. That's why my Imprint was saying my front left speaker wasn't connected. I am such a *******!




  7. #7
    iamamp3pimp's Avatar
    iamamp3pimp is offline Bass Heads Entertainment



    Join Date
    Nov 2003
    Location
    Tampa FL
    Age
    33
    Posts
    13,103
    Post Thanks / Like
    Mentioned
    10 Post(s)

    Re: Where can I go to get help with my Imprint device?

    you figured it out tho...
    ood about that.

    wat is imprint anyway?


    feel g



    www.BassHeadsENT.net for all your custom enclosure needs
    Offering build service and expertise in the Tampa area as well as enclosures shipped nationwide!
    Robin@BassHeadsENT.net


    Check this thread for all the build logs being posted.
    http://www.caraudio.com/forums/suppo...ks-thread.html

  8. #8
    grampi's Avatar
    grampi is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Aug 2002
    Location
    Cheyenne
    Posts
    723
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Where can I go to get help with my Imprint device?

    Quote Originally Posted by iamamp3pimp View Post
    you figured it out tho...
    ood about that.

    wat is imprint anyway?


    feel g
    It's a device that connects to the HU to automatically adjust your system's crossover points, time correction, and make EQ adjustments to improve the overall SQ.




  9. #9
    nismos14's Avatar
    nismos14 is offline CarAudio.com Veteran



    Join Date
    Dec 2006
    Location
    Jersey
    Age
    33
    Posts
    14,518
    Post Thanks / Like
    Mentioned
    4 Post(s)

    Re: Where can I go to get help with my Imprint device?

    FYI, I was messing with my setup and noticed that with going active, the tweet is on the top, mid in the middle and sub on the bottom.






    Car audio IS an addiction.
    C.A.A.A Member #1
    (Car Audio Addicts Anonymous)
    Refs http://www.caraudio.com/forums/buyer-seller-feedback/278560-nismos14-feedback-refs-thread.html


  10. #10
    grampi's Avatar
    grampi is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Aug 2002
    Location
    Cheyenne
    Posts
    723
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Where can I go to get help with my Imprint device?

    Quote Originally Posted by nismos14 View Post
    FYI, I was messing with my setup and noticed that with going active, the tweet is on the top, mid in the middle and sub on the bottom.
    Yeah, I finally figured out the I had the front RCA's connected the rear outputs, which is probably why my Imprint wasn't working.




Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum