Closed Thread
Results 1 to 5 of 5

Reload Thread: Pioneer Premier Headunit and amps stopped working! Please help.

  1. #1
    mpbojangles's Avatar
    mpbojangles is offline Junior Member



    Join Date
    Oct 2004
    Location
    Akron OH
    Posts
    23
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Pioneer Premier Headunit and amps stopped working! Please help.

    I've had a Pioneer Premier headunit that I bought about 2-3 years ago which was top of the line at the time. Its age might be the problem in itself but heres what happened. One day, the faceplate stopped folding down to reveal the LCD display, but everything still worked fine. About a month later, the headunit stopped working all together. It wouldnt turn on when the car was on. All of a sudden it came back on one day and everything was fine. All speakers were working. Few weeks later, the headunit was still working, but all of a sudden, the amps (JL 300x2 powering front components and a sub amp) would not power on. The only sound that I was getting was the unamped rear speakers. And now of course, the headunit won't even turn on.

    I'm a little confused whether the problem is with the head unit, amps, or car electronics in general. I've checked all fuses that I know about (car fuse box, sub amp fuse) and checked general connections (into back of headunit, made sure component RCA's were connected properly).

    Might it be a simple problem being the wiring harness to the headunit is just old? Any feedback is greatly appreciated. Thanks in advance.







  2. #2
    Join Date
    Dec 2005
    Location
    Mt. Juliet, TN
    Age
    28
    Posts
    1,490
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Pioneer Premier Headunit and amps stopped working! Please help.

    What kind of car is this all in?

    My obvious guess might be your ground somewhere. Check the ones that go from the battery to the chassis or the engine block. I had a problem with the remote grounding out and not putting out any sound to the speakers, but that doesn't sound like your problem.

    I would almost say to go to harbor freight and get you a $10 DMM and start checkin everything you can find.





    Quote Originally Posted by xploit2 View Post
    OneKrazyKeebler BEST AVATAR EVER!! OWWWWEEEEEEEEEEEEEE!
    Refs:
    so long ago, they dont effin count anymore, get over it

  3. #3
    RandyShaw's Avatar
    RandyShaw is offline Member



    Join Date
    Oct 2007
    Location
    Eau Claire, Mi
    Posts
    105
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Pioneer Premier Headunit and amps stopped working! Please help.

    I cant even think to comment this threat. That Avatar got me stuck.



    HU: Pioneer DEH-P390MP
    Dash: Infinity 3012
    Door: Infinity 6412cfp
    Rear Deck: Infinity 9613i
    Sub: (1) Kicker CVR15
    Amp: (1) SSL 1FD1500

    " The Sky Is the Limit "

  4. #4
    mpbojangles's Avatar
    mpbojangles is offline Junior Member

    Threadstarter


    Join Date
    Oct 2004
    Location
    Akron OH
    Posts
    23
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Pioneer Premier Headunit and amps stopped working! Please help.

    The car is a '98 Acura 2.3 CL. Thanks for the suggestion. I'll look into that. Anyone else?




  5. #5
    trd_camry's Avatar
    trd_camry is offline Member



    Join Date
    Jan 2006
    Location
    Eau Claire, WI
    Posts
    82
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Pioneer Premier Headunit and amps stopped working! Please help.

    same happen to me...i got last year premier p780mp. once in a while the unit wont eject my cd..sometime the control knob dont even work like it suppose to...My guess is that if you listen music through your pioneer HU for a long period of time..(like me) it'll get very hot and it will cause it to not to work proplery.




Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum