Closed Thread
Results 1 to 6 of 6

Reload Thread: Ok, I think im screwed

  1. #1
    bdavies11's Avatar
    bdavies11 is offline Senior VIP Member



    Join Date
    Sep 2005
    Location
    Florida
    Age
    30
    Posts
    356
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    4 Post(s)

    Ok, I think im screwed

    Ok im having problems with my 780mp. Its got terrible noise coming through the tweeters. I've tried grounding the RCA's to the metal frame of the H/U but still no luck. It didnt even help a little bit. Is there anything else i can do or am i totally screwed?



    2000 Camaro

    Head Unit: Premier DEH-P780MP
    Frontstage: 6-1/2" Pioneer Rev Comps
    Front amp: Profile AP1040
    Subs: 1 12" Shiva-x 3 cubes sealed
    Sub Amp: Kenwood KAC-9152D




  2. #2
    btlking's Avatar
    btlking is offline Registered User



    Join Date
    Oct 2006
    Location
    Uranus
    Posts
    2,716
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Ok, I think im screwed

    try regroudning the whole hu




  3. #3
    nosaj070's Avatar
    nosaj070 is offline CarAudio.com Veteran



    Join Date
    Feb 2003
    Location
    Chicago, IL
    Age
    29
    Posts
    2,393
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Ok, I think im screwed

    Reground the HU to something substantial, it might take a decent wire run. Reground the amp, Profiles are fine amps but they have a tendency to pick up ground loops pretty easily.



    Alpine CDA-7995, A/D/S 3 Series Comps, ED 8A, SoundStream Reference 604, 98 Civic Sedan
    AIM: nosaj070

  4. #4
    bdavies11's Avatar
    bdavies11 is offline Senior VIP Member

    Threadstarter


    Join Date
    Sep 2005
    Location
    Florida
    Age
    30
    Posts
    356
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    4 Post(s)

    Re: Ok, I think im screwed

    What do u mean regrounding? Do you mean grounding the HU to another location? Because thats what i did. The previous ground was using the factory ground wire which i quickly learned you shouldnt do that with this H/U. So i regrounded it to the metal frame of the H/U and also grounded the RCA's to the metal frame in the same location.



    2000 Camaro

    Head Unit: Premier DEH-P780MP
    Frontstage: 6-1/2" Pioneer Rev Comps
    Front amp: Profile AP1040
    Subs: 1 12" Shiva-x 3 cubes sealed
    Sub Amp: Kenwood KAC-9152D

  5. #5
    Goindef154's Avatar
    Goindef154 is offline Nothing



    Join Date
    Feb 2007
    Location
    Phoenix, AZ
    Age
    29
    Posts
    5,256
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    47 Post(s)

    Re: Ok, I think im screwed

    you should ground the headunit to a metal spot on the car, like the chassis or something and make sure you scrape paint on the surface away.



    Official Shok Dealer
    Car: 2001 Chevy Silverado LS
    Deck: Pioneer 750MP
    Subs: 2 Shok FLO-1k 10's
    Mids: Shok Components
    Amps: Shok II and Shok 100x4

    Feedback: http://www.caraudio.com/forums/buyer-seller-feedback/250172-goindef154.html

  6. #6
    bdavies11's Avatar
    bdavies11 is offline Senior VIP Member

    Threadstarter


    Join Date
    Sep 2005
    Location
    Florida
    Age
    30
    Posts
    356
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    4 Post(s)

    Re: Ok, I think im screwed

    Quote Originally Posted by Goindef154 View Post
    you should ground the headunit to a metal spot on the car, like the chassis or something and make sure you scrape paint on the surface away.
    Ok, well i wont have the time to do that until probably this weekend. But i certainly will give it a try. This still makes me very upset. Im still worried there maybe something internally wrong that i cannot fix.



    2000 Camaro

    Head Unit: Premier DEH-P780MP
    Frontstage: 6-1/2" Pioneer Rev Comps
    Front amp: Profile AP1040
    Subs: 1 12" Shiva-x 3 cubes sealed
    Sub Amp: Kenwood KAC-9152D

Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum