Closed Thread
Results 1 to 3 of 3

Reload Thread: Need Help

  1. #1
    hydedabeast's Avatar
    hydedabeast is offline Junior Member



    Join Date
    Dec 2006
    Location
    ARIZONA
    Posts
    24
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Need Help

    Basically i go to turn my car on this morninig and i found out my HU wont cut on nor my lights inside the car? i checked my battery, my wires and theres nothing wrong what could be the problem? and how would i fix it?

    someone help



    SUZUKI GRAND VITARA 2000
    candy apple paint w/orange act
    2 mtx 4500 300rms
    poweraucoustic amp 1000watts briged
    Inerell Capacitor 1.0 farad

    Future Upgrades:
    2 12"hifonics squares zues
    Hifonics TXi 5006 1000 watt amp
    5 screens (2invisor)(2headrest)dash
    "Pop trunk actuator"
    18"wheels was going to go 20




  2. #2
    Brad H.'s Avatar
    Brad H. is offline Member



    Join Date
    May 2006
    Location
    Louisiana
    Posts
    31
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Need Help

    Did you check your fuses?




  3. #3
    hydedabeast's Avatar
    hydedabeast is offline Junior Member

    Threadstarter


    Join Date
    Dec 2006
    Location
    ARIZONA
    Posts
    24
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Need Help

    just put new ones in i have no clue why it wont give any surge to the hu.



    SUZUKI GRAND VITARA 2000
    candy apple paint w/orange act
    2 mtx 4500 300rms
    poweraucoustic amp 1000watts briged
    Inerell Capacitor 1.0 farad

    Future Upgrades:
    2 12"hifonics squares zues
    Hifonics TXi 5006 1000 watt amp
    5 screens (2invisor)(2headrest)dash
    "Pop trunk actuator"
    18"wheels was going to go 20

Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum