Closed Thread
Results 1 to 8 of 8

Reload Thread: Pioneer HU problem

  1. #1
    suprapimpa's Avatar
    suprapimpa is offline Junior Member



    Join Date
    Apr 2004
    Location
    Tampa, FL
    Posts
    4
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Pioneer HU problem

    A couple months ago the battery in my brothers crown vic was reinstalled improperly and burnt out a couple things in the car, windshield, blinkers, etc. Along with this it hurt the radio but I don't know if its toast or repairable. It will turn on and all the buttons work but the radio will not come through the speakers and when I put in a cd it will spin really quick for a second and stop and nothing will happen. Is there any fix for this or is it done for?

    I was thinking maybe it was just the internal amp, if I hooked up an external amp do you think it would work?

    Thanks,
    Shawn







  2. #2
    Slaugh's Avatar
    Slaugh is offline CarAudio.com Moron



    Join Date
    May 2005
    Location
    São Paulo, Brazil
    Age
    30
    Posts
    1,246
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Pioneer HU problem

    All i can say is WOW!, you got an Pioneer.
    Its the best HU in existence you know, absolutely nothing better in that price range, nope.
    Enjoy your awesome broken ***
    Pioneer.


































    serious reply: yes, could be only the internal amps that fried... id check using an external amp... find someone who has one and do this test, dont go buyign without knowing whats causing the problem




  3. #3
    mr Tibbs's Avatar
    mr Tibbs is offline CarAudio.com Elite



    Join Date
    Oct 2004
    Location
    Utah
    Posts
    840
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Pioneer HU problem

    Quote Originally Posted by suprapimpa
    A couple months ago the battery in my brothers crown vic was reinstalled improperly and burnt out a couple things in the car, windshield, blinkers, etc. Along with this it hurt the radio but I don't know if its toast or repairable. It will turn on and all the buttons work but the radio will not come through the speakers and when I put in a cd it will spin really quick for a second and stop and nothing will happen. Is there any fix for this or is it done for?

    I was thinking maybe it was just the internal amp, if I hooked up an external amp do you think it would work?

    Thanks,
    Shawn

    Burnt out the windshield??? This I have to see!! Pics now please!!




  4. #4
    suprapimpa's Avatar
    suprapimpa is offline Junior Member

    Threadstarter


    Join Date
    Apr 2004
    Location
    Tampa, FL
    Posts
    4
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Pioneer HU problem

    Quote Originally Posted by mr Tibbs
    Burnt out the windshield??? This I have to see!! Pics now please!!
    windshield wipers, my bad




  5. #5
    zachzchw's Avatar
    zachzchw is offline CarAudio.com Veteran



    Join Date
    Dec 2004
    Location
    ohio
    Posts
    6,640
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Pioneer HU problem

    Wont be the internal amp if the cd doesnt even play.
    Contact Pioneer, they will do a one time courtesy fix on it, if its a current model.
    Who the hell put his battery in wrong, anyway?




  6. #6
    94CamryBumpin's Avatar
    94CamryBumpin is offline Reppin' the Gen III Camry



    Join Date
    May 2005
    Location
    Kansas
    Age
    26
    Posts
    672
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Pioneer HU problem

    is there a way to put a battery in wrong? i mean there is a positive and negative terminal...u connect the corresponding batt terminals to the corresponding terminals on the battery and voila a new battery installed?




    Refs
    LeX
    Moe Lester
    Dgrun09 (SD)
    BUMPING150S

  7. #7
    seth350's Avatar
    seth350 is offline CarAudio.com Elite



    Join Date
    Jan 2005
    Location
    Union City,TN
    Age
    26
    Posts
    1,380
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Pioneer HU problem

    Pioneers are notorious for blowing their internal amps for some reason.
    At least all the ones Ive seen anyways......

    Hopefully my AVH-6400CD wont do it :P



    refs:voa_nightmare, nikosbuddy, mjbailey21, Mr.Loki, jeremyzach, ghostface, Raven02011, imaspaceguy, ownage9, dmcfirestar500,wcarson8911, jeepintn, Flipx99

  8. #8
    zachzchw's Avatar
    zachzchw is offline CarAudio.com Veteran



    Join Date
    Dec 2004
    Location
    ohio
    Posts
    6,640
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Pioneer HU problem

    Quote Originally Posted by seth350
    Pioneers are notorious for blowing their internal amps for some reason.
    At least all the ones Ive seen anyways......

    Hopefully my AVH-6400CD wont do it :P

    Never heard of them blowing the internal amps......The problem that occurs is something in the ground trace in the deck, and causes noise to come from the rcas hooked to your amps.
    Doesnt sound like thats what his problem is.




Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum