Closed Thread
Results 1 to 5 of 5

Reload Thread: sub pops when i crank it up

  1. #1
    JDoggHSTX's Avatar
    JDoggHSTX is offline Member



    Join Date
    Dec 2001
    Location
    Texas
    Age
    29
    Posts
    77
    Post Thanks / Like
    Mentioned
    0 Post(s)

    sub pops when i crank it up

    ive got 3 jl 12w3's running off a Lanzar Vibe 1200d. i recently rewired all the subs in series(see my other post) but after i did, the sub pops sometimes when i crank the bass. it made a noise similar to this popping before i rewired it, but then it was a constant noise. what is causing this?



    98 Red Dodge Ram
    3 JL 12w3's
    Lanzar Vibe 1200d
    Pioneer HU
    Pair of JL 6x9's

    One Serious Headache




  2. #2
    kimamandal's Avatar
    kimamandal is offline Junior Member



    Join Date
    Jan 2002
    Location
    Meriden Ct
    Age
    34
    Posts
    16
    Post Thanks / Like
    Mentioned
    0 Post(s)
    you may blowen out the spider in thesub, or the sub wiring could be crossed or the sub is blowen




  3. #3
    natem33's Avatar
    natem33 is offline Senior VIP Member



    Join Date
    Jan 2002
    Location
    St.Paul, MN
    Posts
    415
    Post Thanks / Like
    Mentioned
    0 Post(s)

    blown sub?

    Yes the sub could very well be blown. Check the yellow flat coil type material between the cone and magnet. This is called the spider. Sometimes you can see an actual tear in the material. When the spider rips, sometimes you get a popping noise. If the popping is only happening when your stereo is realy cranked loud, then your sub could be bottoming out. Back the gain down a little bit and see if that helps.




  4. #4
    JDoggHSTX's Avatar
    JDoggHSTX is offline Member

    Threadstarter


    Join Date
    Dec 2001
    Location
    Texas
    Age
    29
    Posts
    77
    Post Thanks / Like
    Mentioned
    0 Post(s)

    its only when ive got it cranked

    it only pops when ive really got it cranked loud, usually with the bass turned up a bit. i turned the gains and low pass down and it doesnt do it near as bad now. the spider is fine, cause i checked it when i rewired the sub.



    98 Red Dodge Ram
    3 JL 12w3's
    Lanzar Vibe 1200d
    Pioneer HU
    Pair of JL 6x9's

    One Serious Headache

  5. #5
    RangerMan's Avatar
    RangerMan is offline Premium Member RangerMan is a Supporting Member of the forum!



    Join Date
    Jan 2002
    Location
    NC
    Posts
    8,214
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)
    Its a Lanzar Vibe amp, so i'd say that there is probaly an interal problem with the amp if you have rewired it.




Closed Thread

Similar Threads

  1. Sub Pops & Makes Noise When Turned On
    By U n K n O w N ? in forum General Discussion
    Replies: 8
    Last Post: 12-12-2009, 11:39 AM
  2. sub/amp pops when buttons on head unit are pushed
    By sweetbrett in forum Wiring, Electrical and Installation Help
    Replies: 10
    Last Post: 02-17-2009, 09:08 PM
  3. amp makes sub fart when i turn car off... help!!!
    By g30ffr3y in forum Amplifiers
    Replies: 3
    Last Post: 02-05-2005, 11:36 AM
  4. Help with sub popping when turning car off
    By peteman70 in forum Subwoofers
    Replies: 2
    Last Post: 10-31-2004, 07:05 PM
  5. no sub output when using cassette adapter?
    By Darwin in forum General Discussion
    Replies: 0
    Last Post: 04-26-2004, 05:59 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum