+ Reply to Thread
Results 1 to 5 of 5

Reload Thread: Hello everyone need some assistance please!!!!!

  1. #1
    Sigurros's Avatar
    Sigurros is offline Junior Member



    Join Date
    Feb 2018
    Location
    San Diego
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Hello everyone need some assistance please!!!!!

    So just today my pioneer avic- n4 radio stopped working! Basically, it powers up when I start
    The car but there is no sound and touch screen is black.
    I double checked and changed all the fuses and still no sound. The cd eject works and all the buttons on faceplate power up. The two rear passenger seat monitors power up and you can see the picture.
    Iíve tried resetting it hasnít helped, tried taking battery cable off hasnít helped nor unplugging it and restarting it. If anyone could help me I like to try and fix things before I give up and take it in. Greatly appreciated
    EHello everyone need some assistance please!!!!!-efe4a3e0-e32f-47a5-a15a-aebaaed6a42e.jpgClick image for larger version

Name:	EFE4A3E0-E32F-47A5-A15A-AEBAAED6A42E.jpg
Views:	9
Size:	16.5 KB
ID:	26557217Attachment 26557217







  2. #2
    Boomin_tahoe's Avatar
    Boomin_tahoe is offline Hurtin' feelings errrday.



    Join Date
    Jul 2005
    Location
    WA
    Posts
    14,230
    Post Thanks / Like
    Images
    2
    Mentioned
    41 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    6022 Post(s)

    Re: Hello everyone need some assistance please!!!!!

    Did you buy it new?



    97 4 dr. Tahoe
    Interstate battery
    Alpine 9835
    Polk Audio MM6501 comps
    Soundstream Rubicon 1.2500D & 4.500 amps
    2 Sundown Audio X 15's Tuned @ 30Hz.
    Knukonceptz/Royal Excelene wiring

  3. #3
    Sigurros's Avatar
    Sigurros is offline Junior Member

    Threadstarter


    Join Date
    Feb 2018
    Location
    San Diego
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Hello everyone need some assistance please!!!!!

    No I did not. Iíve had it since it was installed when I bought the car. Iíve had the car for about 4 years now.




  4. #4
    Sigurros's Avatar
    Sigurros is offline Junior Member

    Threadstarter


    Join Date
    Feb 2018
    Location
    San Diego
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Hello everyone need some assistance please!!!!!

    Quote Originally Posted by Boomin_tahoe View Post
    Did you buy it new?

    No I did not. I’ve had it since it was installed when I bought the car. I’ve had the car for about 4 years now.




  5. #5
    audiobaun's Avatar
    audiobaun is online now CarAudio.com Veteran



    Join Date
    Jun 2011
    Location
    Tx
    Posts
    9,316
    Post Thanks / Like
    Mentioned
    27 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2169 Post(s)

    Re: Hello everyone need some assistance please!!!!!

    It may be time for a new unit.There are some computer repair stores that may be able to repair it cheaper. I found one local a few years back



    2)American Bass VFL Mini Hybrid [email protected] Ea 4)American Bass XFL DVC 4ohm [email protected] Ft [email protected] CDT 6,5 HD6 Briax.,CDT CL60,CDT 25 tweets,Kicker KS25 tweets Autotek Mean Machine [email protected],Autotek BTX [email protected] AlterStarts Alt 255A/Dallas,Tx,2)Orileys Super Start AGM batts(1more coming)Cadence CCA 0ga on Big 6,AudioTechnix 0ga CCA Kicker Kq9 Eq,Eclipse CD3000(lookingfor upgrade)StingerPro Distro,3)XS Scorpian 8in Scroll Fans 1998 3dr Xcab Chevy(under construction,but operational)

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum