+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 19

Reload Thread: I need help.

  1. #1
    srobinson's Avatar
    srobinson is offline Junior Member



    Join Date
    Apr 2017
    Location
    Pomey Town, SC
    Posts
    10
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1 Post(s)

    I need help.

    Hey, good people. I have a question. So, I'm in the process of putting a Pyle PLMR18 aftermarket radio into my 2001 Pontiac Grand Am but hit a little snag. I need to remove the outer part of the faceplate in order to put the radio in a harness. This is the only problem I'm having right now. I've been trying on and off for about 2 hours without any luck. What is this part called and how do I take it off?








  2. #2
    ilikeradios's Avatar
    ilikeradios is offline Senior VIP Member



    Join Date
    Sep 2011
    Location
    Pigeon Forge, TN
    Posts
    354
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    203 Post(s)

    Re: I need help.

    1) That $46 radio is going to sound worse than the factory radio you are replacing.

    2) just pull the trim ring off, it is just press fitted on there.




  3. #3
    Boomin_tahoe's Avatar
    Boomin_tahoe is offline Hurtin' feelings errrday.



    Join Date
    Jul 2005
    Location
    WA
    Posts
    9,077
    Post Thanks / Like
    Images
    2
    Mentioned
    19 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    3762 Post(s)

    Re: I need help.

    Quote Originally Posted by ilikeradios View Post
    1) That $46 radio is going to sound worse than the factory radio you are replacing.

    2) just pull the trim ring off, it is just press fitted on there.
    Gonna add to your comment: The two tabs(in between red arrows), the 9'oclock position and 3'oclock position is whgat it looks like just gently snaps off or use a small flathead.



    97 4 dr. Tahoe
    Optima redtop
    Alpine 9835
    Polk Audio MM6501 comps
    Soundstream Rubicon 1.2500D & 4.500 amps
    2 Sundown Audio X 15's Tuned @ 30Hz.
    Knukonceptz/Royal Excelene wiring

  4. #4
    srobinson's Avatar
    srobinson is offline Junior Member

    Threadstarter


    Join Date
    Apr 2017
    Location
    Pomey Town, SC
    Posts
    10
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1 Post(s)

    Re: I need help.

    Quote Originally Posted by Boomin_tahoe View Post
    Gonna add to your comment: The two tabs(in between red arrows), the 9'oclock position and 3'oclock position is whgat it looks like just gently snaps off or use a small flathead.
    Yup. Those tabs were the first thing I tried with a flathead. It still refuses to budge an inch.




  5. #5
    garychoffmann's Avatar
    garychoffmann is offline CarAudio.com Elite



    Join Date
    Mar 2011
    Location
    Missouri
    Posts
    1,839
    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    479 Post(s)

    Re: I need help.

    It's a marine radio so either the bezel is part of the housing or it is sealed on there so water can't get in.




  6. #6
    srobinson's Avatar
    srobinson is offline Junior Member

    Threadstarter


    Join Date
    Apr 2017
    Location
    Pomey Town, SC
    Posts
    10
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1 Post(s)

    Re: I need help.

    Well, that would explain why the manual doesn't explain how to take off the faceplate and outer trim ring.

    EDIT

    Ok. I managed to take it off! FINALLY!!!!
    Last edited by srobinson; 04-20-2017 at 11:27 AM.




  7. #7
    srobinson's Avatar
    srobinson is offline Junior Member

    Threadstarter


    Join Date
    Apr 2017
    Location
    Pomey Town, SC
    Posts
    10
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1 Post(s)

    Re: I need help.

    One last question. How am I supposed to connect the red wire to this wiring harness? Why did it come not connected?

    EDIT

    Hmm... Ok. So, I noticed that the wiring adapter this GMRC-01 connects to also does not have the red wire. And I don't see any loose red wires in the console. So.... Does this mean I don't have to worry about it?





  8. #8
    Boomin_tahoe's Avatar
    Boomin_tahoe is offline Hurtin' feelings errrday.



    Join Date
    Jul 2005
    Location
    WA
    Posts
    9,077
    Post Thanks / Like
    Images
    2
    Mentioned
    19 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    3762 Post(s)

    Re: I need help.

    There should be a red wire already from the harness. From the looks of it, doesn't appear so. Why so many harnesses? You sure you have the correct one?



    97 4 dr. Tahoe
    Optima redtop
    Alpine 9835
    Polk Audio MM6501 comps
    Soundstream Rubicon 1.2500D & 4.500 amps
    2 Sundown Audio X 15's Tuned @ 30Hz.
    Knukonceptz/Royal Excelene wiring

  9. #9
    srobinson's Avatar
    srobinson is offline Junior Member

    Threadstarter


    Join Date
    Apr 2017
    Location
    Pomey Town, SC
    Posts
    10
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1 Post(s)

    Re: I need help.

    The two black wiring adapters came with the radio. The GMRC-01 adapter is the white one. When I looked into the dash I noticed that the wiring adapter doesn't have a red wire either.




  10. #10
    YukonXL04's Avatar
    YukonXL04 is offline Member



    Join Date
    Apr 2017
    Location
    Arlington,TX
    Posts
    74
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    35 Post(s)

    Re: I need help.

    You run the red wire to the fuse box for acc power. And it hooks to the acc of the radio




  11. #11
    Boomin_tahoe's Avatar
    Boomin_tahoe is offline Hurtin' feelings errrday.



    Join Date
    Jul 2005
    Location
    WA
    Posts
    9,077
    Post Thanks / Like
    Images
    2
    Mentioned
    19 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    3762 Post(s)

    Re: I need help.

    Take a pic of the opening of the radio in your car.

    Something isn't adding up. I thought that all radios/aftermarket harnesses just use 1 harness, not two.



    97 4 dr. Tahoe
    Optima redtop
    Alpine 9835
    Polk Audio MM6501 comps
    Soundstream Rubicon 1.2500D & 4.500 amps
    2 Sundown Audio X 15's Tuned @ 30Hz.
    Knukonceptz/Royal Excelene wiring

  12. #12
    YukonXL04's Avatar
    YukonXL04 is offline Member



    Join Date
    Apr 2017
    Location
    Arlington,TX
    Posts
    74
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    35 Post(s)

    Re: I need help.

    Quote Originally Posted by Boomin_tahoe View Post
    Take a pic of the opening of the radio in your car.

    Something isn't adding up. I thought that all radios/aftermarket harnesses just use 1 harness, not two.
    Pretty much all of the normal brands do. But pyle, boss, lanzar.... I have seen plenty of theirs with 2 plugs. Basically 1 plug for power and ground. The other plug for speaker wires. Which if your running a 4ch then you could leave it unplugged and have 8 less wires behind the radio....




  13. #13
    srobinson's Avatar
    srobinson is offline Junior Member

    Threadstarter


    Join Date
    Apr 2017
    Location
    Pomey Town, SC
    Posts
    10
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1 Post(s)

    Re: I need help.

    Quote Originally Posted by YukonXL04 View Post
    You run the red wire to the fuse box for acc power. And it hooks to the acc of the radio
    Ok. Is that a difficult job or should I consider getting the GMRC-01 with a chimebox?




  14. #14
    YukonXL04's Avatar
    YukonXL04 is offline Member



    Join Date
    Apr 2017
    Location
    Arlington,TX
    Posts
    74
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    35 Post(s)

    Re: I need help.

    Quote Originally Posted by srobinson View Post
    Ok. Is that a difficult job or should I consider getting the GMRC-01 with a chimebox?
    That's entirely up to you. I prefer to delete all the chimes. Don't like them, don't want them...

    As far as difficult, just get a add a fuse thing from the auto store, and plug it into a fuse that has 12v key on only power and your good to go.




  15. #15
    srobinson's Avatar
    srobinson is offline Junior Member

    Threadstarter


    Join Date
    Apr 2017
    Location
    Pomey Town, SC
    Posts
    10
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1 Post(s)

    Re: I need help.

    Quote Originally Posted by YukonXL04 View Post
    That's entirely up to you. I prefer to delete all the chimes. Don't like them, don't want them...

    As far as difficult, just get a add a fuse thing from the auto store, and plug it into a fuse that has 12v key on only power and your good to go.
    I went ahead and ordered a new GMRC-01 wiring harness with red wire and chimebox because I don't want to goof anything up. I want the installation to be as simple as possible.




+ Reply to Thread
Page 1 of 2 1 2 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum