+ Reply to Thread
Results 1 to 4 of 4

Reload Thread: Need some help/advice

  1. #1
    jdes28's Avatar
    jdes28 is offline Junior Member



    Join Date
    Nov 2013
    Location
    Maine
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Need some help/advice

    So I have an (older) Kenwood DNX7120 DVD/GPS head unit in my 04 Silverado. I've been getting a super high pitch "squeal" out of the blue. When it happens, my head unit starts rolling through the different modes it has, tuner to dvd to video and then stops once it's found a mode in which it "likes". I thought it might be the head unit itself, but I purchased a unit exactly like the one I have (just without the GPS feature) and it's still happens. It doesn't happen all the time with either, just kind of randomly. My local audio shop says its the head unit (without even looking into it). But the same problem with two different units? I don't think its the case. Please give any help or thoughts.
    Thanks a ton.







  2. #2
    Babykinns's Avatar
    Babykinns is offline Senior VIP Member



    Join Date
    Oct 2012
    Location
    Nelsonville, OH
    Posts
    151
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Need some help/advice

    Quote Originally Posted by jdes28 View Post
    So I have an (older) Kenwood DNX7120 DVD/GPS head unit in my 04 Silverado. I've been getting a super high pitch "squeal" out of the blue. When it happens, my head unit starts rolling through the different modes it has, tuner to dvd to video and then stops once it's found a mode in which it "likes". I thought it might be the head unit itself, but I purchased a unit exactly like the one I have (just without the GPS feature) and it's still happens. It doesn't happen all the time with either, just kind of randomly. My local audio shop says its the head unit (without even looking into it). But the same problem with two different units? I don't think its the case. Please give any help or thoughts.
    Thanks a ton.
    possibly a bad ground try running your own ground to bare metal




  3. #3
    Side Show's Avatar
    Side Show is offline Bringin The Noise



    Join Date
    Aug 2007
    Location
    Australia
    Posts
    3,339
    Post Thanks / Like
    Mentioned
    1 Post(s)

    Re: Need some help/advice

    ^^ THIS, also try a reset button on the faceplate of the deck, and try take the unit out and check all wiring and connections (check inbuilt fuse too)




  4. #4
    Side Show's Avatar
    Side Show is offline Bringin The Noise



    Join Date
    Aug 2007
    Location
    Australia
    Posts
    3,339
    Post Thanks / Like
    Mentioned
    1 Post(s)

    Re: Need some help/advice

    ^^ THIS, also try a reset button on the faceplate of the deck, and try take the unit out and check all wiring and connections (check inbuilt fuse too)




+ Reply to Thread

Similar Threads

  1. Need some help/advice
    By Funnyman in forum General Discussion
    Replies: 1
    Last Post: 10-26-2009, 04:37 PM
  2. Alright guys need some help / advice
    By Intensity in forum Speakers
    Replies: 3
    Last Post: 04-22-2006, 12:34 AM
  3. newbie here..need some help/advice
    By 02blackws679ta in forum General Discussion
    Replies: 13
    Last Post: 11-06-2005, 12:45 PM
  4. Need some help&advice from you experts :)
    By 92supra in forum General Discussion
    Replies: 2
    Last Post: 01-21-2004, 11:09 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum