Closed Thread
Results 1 to 3 of 3

Reload Thread: Amp Question

  1. #1
    Join Date
    Jan 2013
    Location
    Lincoln, NE
    Posts
    136
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    61 Post(s)

    Amp Question

    Could I run a dual 1.5 ohm sub off of an Alpine MRP-M500?







  2. #2
    UnderFire's Avatar
    UnderFire is offline CarAudio.com Veteran



    Join Date
    Apr 2011
    Location
    Dayton, OR, 97114
    Posts
    2,047
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    529 Post(s)

    Re: Amp Question

    Depends on what kind of power the sub needs, but simple answer is yes, at 3 ohms.



    97 4runner, 3RZ, 5 Speed

    Headunit: Alpine CDA-9887
    Mids: CDT HD-6CF
    Tweets: CDT DRT-25
    Fronts Amp: Hertz HDP4
    Sub Amp: American Bass VFL150.1
    Substage: 18" SSA ZCON
    Electrical: 160 Amp Alt, Duralast Gold, C&D270FR, 2/0 Throughout

  3. #3
    03Bonneville's Avatar
    03Bonneville is offline Member

    Threadstarter


    Join Date
    Jan 2013
    Location
    Lincoln, NE
    Posts
    136
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    61 Post(s)

    Re: Amp Question

    Quote Originally Posted by UnderFire View Post
    Depends on what kind of power the sub needs, but simple answer is yes, at 3 ohms.
    My friend has a JL W7 and his amp bit the dust so we were wondering if it would run fine off of my amp? I think the W7 is like 1500 rms, correct me if I'm wrong.




Closed Thread

Similar Threads

  1. Amp question
    By adam182002 in forum Amplifiers
    Replies: 8
    Last Post: 02-09-2002, 10:34 PM
  2. Amp question
    By Adam182002 in forum Wiring, Electrical and Installation Help
    Replies: 6
    Last Post: 02-08-2002, 05:32 PM
  3. Amp Question
    By RangerMan in forum Subwoofers
    Replies: 2
    Last Post: 02-03-2002, 03:16 PM
  4. Xplod Amp Question
    By Unregistered in forum Amplifiers
    Replies: 2
    Last Post: 01-26-2002, 10:39 PM
  5. Amp question
    By Albokid in forum Amplifiers
    Replies: 1
    Last Post: 01-23-2002, 01:41 AM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum