Closed Thread
Page 6 of 7 FirstFirst 1 2 3 4 5 6 7 LastLast
Results 76 to 90 of 104

Reload Thread: Not impressed

  1. #76
    RicksI30's Avatar
    RicksI30 is offline CarAudio.com Elite



    Join Date
    May 2011
    Location
    Tucson, Az
    Age
    26
    Posts
    588
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    189 Post(s)

    Re: Not impressed

    I'll be looking forward to hearing your opinion of it in the new enclosure.
    Last edited by RicksI30; 01-22-2013 at 09:39 PM.



    Head unit: Kenwood Excelon KDC-X996
    Front stage: Alpine Type X PRO mids Vifa Neo 1" silk tweeters
    Front stage amp: PPI Bk800.4
    Subs: SSA XCON 12's in 4.5 cubes tuned to 34hz
    Sub amp: PPI Bk1300.1
    Sound Deadening: Second Skin Damplifier Pro, Spectrum, and Sludge


    Team SSA




  2. #77
    Hookedup12's Avatar
    Hookedup12 is offline Senior VIP Member

    Threadstarter


    Join Date
    Jan 2012
    Location
    NC
    Posts
    179
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    56 Post(s)

    Re: Not impressed

    Quote Originally Posted by denim View Post
    Couple of things from what I have read.

    #1 The Dcon is not broken in yet.
    #2 The most logical option for the output desires is to port the Dcon first
    #3 Keep in mind this is a 300 rms ratted SQ biased sub woofer, please don't expect Xcon level of output from the Dcon.

    So once it is ported and broken in, I really feel you will like the output as the performance per dollar ratio of the Dcon is very hard to beat.
    I think I will too! From the vids on fb and word of mouth it'll sound good I know, I was just thinking what malfunction wise could be wrong with this sub so I pushed even across the sub in my sealed enclosure and when it went down it was smooth didn't feel like anything was wrong and then I said man that went down easy and I pushed down again and low and behold a heard air coming out of the box so its a pretty big leak. And it was a prefab junkie so its expected.




  3. #78
    RicksI30's Avatar
    RicksI30 is offline CarAudio.com Elite



    Join Date
    May 2011
    Location
    Tucson, Az
    Age
    26
    Posts
    588
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    189 Post(s)

    Re: Not impressed

    Quote Originally Posted by Hookedup12 View Post
    I think I will too! From the vids on fb and word of mouth it'll sound good I know, I was just thinking what malfunction wise could be wrong with this sub so I pushed even across the sub in my sealed enclosure and when it went down it was smooth didn't feel like anything was wrong and then I said man that went down easy and I pushed down again and low and behold a heard air coming out of the box so its a pretty big leak. And it was a prefab junkie so its expected.
    And yeah I only linked my XCON video in reference to your post about upgrading to a different SSA 12. Obviously the xcon and the dcon are completely different animals.



    Head unit: Kenwood Excelon KDC-X996
    Front stage: Alpine Type X PRO mids Vifa Neo 1" silk tweeters
    Front stage amp: PPI Bk800.4
    Subs: SSA XCON 12's in 4.5 cubes tuned to 34hz
    Sub amp: PPI Bk1300.1
    Sound Deadening: Second Skin Damplifier Pro, Spectrum, and Sludge


    Team SSA

  4. #79
    denim's Avatar
    denim is offline SSAudio.com



    Join Date
    Oct 2002
    Location
    SSA HQ East
    Age
    37
    Posts
    28,255
    Post Thanks / Like
    Images
    15
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    622 Post(s)

    Re: Not impressed

    Quote Originally Posted by Hookedup12 View Post
    I think I will too! From the vids on fb and word of mouth it'll sound good I know, I was just thinking what malfunction wise could be wrong with this sub so I pushed even across the sub in my sealed enclosure and when it went down it was smooth didn't feel like anything was wrong and then I said man that went down easy and I pushed down again and low and behold a heard air coming out of the box so its a pretty big leak. And it was a prefab junkie so its expected.
    A leak will cause issues. Hope you can get a solid ported box built.





    CarAudio.com mod(original)

  5. Likes Hookedup12 liked this post
  6. #80
    Hookedup12's Avatar
    Hookedup12 is offline Senior VIP Member

    Threadstarter


    Join Date
    Jan 2012
    Location
    NC
    Posts
    179
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    56 Post(s)

    Re: Not impressed

    Ok update I have it in the new box tuned the amp with a dmm and eq flat it still has a rattle right behind the dust cap possibly tinsel slap or loose cap but pounds either way holy shiz this drops on decaf music like its nobody's business. It's not bottoming out I have the hpf set 5hz under tuning and what not the rattle is annoying but that has nothing to do with this box... Holy hell this things slams thanks double 07 for this box it was perfect. Now if I can fix this rattle ill be in business. It's almost like someone set a screw on the dust cap while playing and it's only on the punchy notes, the low notes I don't hear a thing.




  7. #81
    Hookedup12's Avatar
    Hookedup12 is offline Senior VIP Member

    Threadstarter


    Join Date
    Jan 2012
    Location
    NC
    Posts
    179
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    56 Post(s)

    Re: Not impressed

    Any ideas?




  8. #82
    neo_styles's Avatar
    neo_styles is offline AKA Pop Twidget



    Join Date
    Sep 2012
    Location
    Porter Ranch, CA
    Age
    28
    Posts
    3,613
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1693 Post(s)

    Re: Not impressed

    Think you might have overloaded it when trying to get it to sing sealed. Doubt it's tinsel slap on a 400W sub. Could also be air leakage, but I'd get it checked out ASAP before you do worse damage.



    Deck: JVC KD-A95BT
    Speakers: PHD FB mid, JBL MS tweets
    Amps: Boston Acoustics GT-2125, Zed Minotaur III (x2)
    Sub: 10" SSA ICON, IA Death Penalty 18" (coming soon)
    Starr Mountain Sound Nuthugger #2 (I'm a #2 lol)
    dcarcustoms Nuthugger #1
    Spotify: http://open.spotify.com/user/neo_styles/playlist/6t9ru42j0wbEsuo4bXqXD8
    PROUD MEMBER OF TEAM VERTEX

  9. #83
    double 07's Avatar
    double 07 is offline CarAudio.com Elite



    Join Date
    Nov 2011
    Location
    Etowah, TN
    Posts
    1,955
    Post Thanks / Like
    Images
    13
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    622 Post(s)

    Re: Not impressed

    The only air coming out of this box better be the port....lol














  10. Likes Hookedup12 liked this post
  11. #84
    Hookedup12's Avatar
    Hookedup12 is offline Senior VIP Member

    Threadstarter


    Join Date
    Jan 2012
    Location
    NC
    Posts
    179
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    56 Post(s)

    Re: Not impressed

    I screwed this thing down as tight as possible I don't know if its that. I never gave it a lot of gain less than quarter I he way up on either box. It just had my bass and what not up on my hu I don't think it ever even saw 300w.




  12. #85
    neo_styles's Avatar
    neo_styles is offline AKA Pop Twidget



    Join Date
    Sep 2012
    Location
    Porter Ranch, CA
    Age
    28
    Posts
    3,613
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1693 Post(s)

    Re: Not impressed

    Talk to @denim ; yet about it? Like I said, it might need to be inspected.



    Deck: JVC KD-A95BT
    Speakers: PHD FB mid, JBL MS tweets
    Amps: Boston Acoustics GT-2125, Zed Minotaur III (x2)
    Sub: 10" SSA ICON, IA Death Penalty 18" (coming soon)
    Starr Mountain Sound Nuthugger #2 (I'm a #2 lol)
    dcarcustoms Nuthugger #1
    Spotify: http://open.spotify.com/user/neo_styles/playlist/6t9ru42j0wbEsuo4bXqXD8
    PROUD MEMBER OF TEAM VERTEX

  13. #86
    Hookedup12's Avatar
    Hookedup12 is offline Senior VIP Member

    Threadstarter


    Join Date
    Jan 2012
    Location
    NC
    Posts
    179
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    56 Post(s)

    Re: Not impressed

    Quote Originally Posted by double 07 View Post
    The only air coming out of this box better be the port....lol










    It's not the box I'm fo sho lol I got that surround on it too and it's tight as possible




  14. #87
    gramser57's Avatar
    gramser57 is offline Senior VIP Member



    Join Date
    Dec 2011
    Location
    Washington
    Posts
    151
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    41 Post(s)

    Re: Not impressed

    Double check the foam padding is still behind the tinsel leads, mine came off after a while.



    B16 SE-R

  15. #88
    Hookedup12's Avatar
    Hookedup12 is offline Senior VIP Member

    Threadstarter


    Join Date
    Jan 2012
    Location
    NC
    Posts
    179
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    56 Post(s)

    Re: Not impressed

    Quote Originally Posted by neo_styles View Post
    Talk to @denim ; yet about it? Like I said, it might need to be inspected.
    On sent a lil while ago hoping to hear back shortly




  16. #89
    Hookedup12's Avatar
    Hookedup12 is offline Senior VIP Member

    Threadstarter


    Join Date
    Jan 2012
    Location
    NC
    Posts
    179
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    56 Post(s)

    Re: Not impressed

    Quote Originally Posted by gramser57 View Post
    Double check the foam padding is still behind the tinsel leads, mine came off after a while.
    When I pulled the sub out the old box it was a lil loose and hanging off so I pushed it back on and to think of it I didn't hear it at first web it was playing maybe it shook loose again at the glue hardened on the side and the hard spot is flopping against the back of the cone.




  17. #90
    Hookedup12's Avatar
    Hookedup12 is offline Senior VIP Member

    Threadstarter


    Join Date
    Jan 2012
    Location
    NC
    Posts
    179
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    56 Post(s)

    Re: Not impressed

    But it sounds like its coming from that area where the leads were at




Closed Thread
Page 6 of 7 FirstFirst 1 2 3 4 5 6 7 LastLast

Similar Threads

  1. Rsd65CS installed and not impressed
    By itzme218 in forum General Discussion
    Replies: 4
    Last Post: 05-25-2007, 07:14 AM
  2. installed and not impressed
    By RipDaJacka in forum General Discussion
    Replies: 92
    Last Post: 05-24-2007, 12:36 AM
  3. LostSoul & Digital B - not impressed
    By Pr0d1gy in forum *Negative* Feedback
    Replies: 6
    Last Post: 10-23-2006, 04:17 AM
  4. 12" W6 not impressed
    By joshpoints in forum Subwoofers
    Replies: 17
    Last Post: 06-21-2005, 04:32 PM
  5. not impressed with the L5
    By Brock in forum Subwoofers
    Replies: 12
    Last Post: 11-01-2002, 12:25 PM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum