Closed Thread
Results 1 to 13 of 13

Reload Thread: Is the system I have good? Need some advice !

  1. #1
    Deadlocked's Avatar
    Deadlocked is offline Junior Member



    Join Date
    Nov 2012
    Location
    West Hartford, CT
    Posts
    26
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Icon32 Is the system I have good? Need some advice !

    Hey all so I'm a complete noob at audio, just bought an RSX type s 06 and it came with 2 amplifiers a Kenwood KAC-9103D Class D Mono power Amplified and a Alpine V Power 4 Channel power amplfier MRP-F250, It's hooked up to a Alpine Type R 12" subwoofer and it's got a Rockford Fosgate IFD 1 Farad Digital Capicitator rolling around even though its like hooked up its just in my trunk rolling around not secured to anything. What do I do? Is this a good set up so far?

    Also my head unit was a Alpine something But i removed it and bought a AVH P8400bh double din only to find out that the OEM mounting bracket is missing so I had to buy it now I'm waiting on that. Will the amps be able to power everything? Is this a good set up? I'm looking into buying new speakers as well for the front any good suggestions? I think my front takes 6.5 inches?







  2. #2
    Dtrom's Avatar
    Dtrom is offline MAF



    Join Date
    Jul 2012
    Location
    43450
    Posts
    3,997
    Post Thanks / Like
    Images
    4
    Mentioned
    29 Post(s)

    Re: Is the system I have good? Need some advice !

    Looks good I would replace the sub amp with some a lil bigger like 600+ rms. And id ditch the capacitor.






    REFS alot

  3. #3
    jungstah's Avatar
    jungstah is offline Senior VIP Member



    Join Date
    May 2012
    Location
    san francisco
    Posts
    278
    Post Thanks / Like
    Mentioned
    2 Post(s)

    Re: Is the system I have good? Need some advice !

    budget for upgrades? what you got now is a decent budget system; typical audio shop or best buy equipment probably.

    Also, ditch the cap or at least secure it somehow



    Pioneer AVH-P2400BT
    Stock Pioneer 4" components
    Hifonics Brutus BRZ1700.1D
    Two SA-12's
    cruddy prefab ported box----new box otw

  4. #4
    Deadlocked's Avatar
    Deadlocked is offline Junior Member

    Threadstarter


    Join Date
    Nov 2012
    Location
    West Hartford, CT
    Posts
    26
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Is the system I have good? Need some advice !

    Any recommendations guys? Well the bass is pretty heavy I think enough for me maybe? Idk budget is around $400 I would say, are the amps powerful enough for everything or am I lacking in anything? Point me in the right direction (:

    ---------- Post added at 05:59 PM ---------- Previous post was at 05:59 PM ----------

    Why ditch the cap? I don't even know what it is lol, how do I secure it and to what?




  5. #5
    gckless's Avatar
    gckless is online now CarAudio.com Veteran



    Join Date
    Aug 2011
    Location
    San Antonio
    Posts
    3,965
    Post Thanks / Like
    Mentioned
    28 Post(s)

    Re: Is the system I have good? Need some advice !

    Remove the cap, it's only a hazard rolling around like that. "Good" is a relative term. Does it sound good to you? Do you want more?



    Quote Originally Posted by ducatipaso View Post
    15inch subs can't play fast beats, they take more power and that taxes the vehicles electrical system. You will wake up and "hear" then see the light at the end of the tunnel and it will be 3 10's pounding so hard you wont even open your trunk or turn your system on because you 15's will sound sloppy & weak.
    Quote Originally Posted by benbenondatrack View Post
    stfu lesbo.why are you worried about me so much? you must want to date me ya little cookie monster but i dont even like sweets. your just a cup full of ice, dirt dead nasty azz ice...without the water.

    Dat Build Log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/578701-1999-chevrolet-blazer.html

  6. Likes DoesDad liked this post
  7. #6
    Deadlocked's Avatar
    Deadlocked is offline Junior Member

    Threadstarter


    Join Date
    Nov 2012
    Location
    West Hartford, CT
    Posts
    26
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Is the system I have good? Need some advice !

    So I just remove it from my system? Ill see if I can do that wouldn't know what to do then, whats it for anyway ? And I think a little more would be nice, what if I were to get another alpine type r subwoofer 12 inch would that be better? Would the amps be able to power it and my HU?




  8. #7
    nkrell11's Avatar
    nkrell11 is offline CarAudio.com Elite



    Join Date
    Oct 2012
    Location
    Mt. Pleasant, MI
    Posts
    511
    Post Thanks / Like
    Mentioned
    7 Post(s)

    Re: Is the system I have good? Need some advice !

    Caps are designed to help reduce the strain on your electrical system when your amp draws current however, they tend to put more strain on your electrical than they prevent alpine makes decent gear for being so mainstream also I'd suggest a non pre fabricated ported box otherwise it sounds like a decent entry level set-up.
    Last edited by nkrell11; 11-26-2012 at 06:06 PM. Reason: More Info



    Car:2004 Grand Prix
    H/U: Alpine CDE-102
    Wires: Tsunami 1/0 OFC Positive Run, Audio Technix 1/0 CCA Negative Run, KNU Big 3 1/0
    Batteries: Kinetik HC2400 Rear, Duralast Gold AGM Front
    Amp: Crescendo BC2000D
    Substage:Rebuild Time

  9. #8
    Deadlocked's Avatar
    Deadlocked is offline Junior Member

    Threadstarter


    Join Date
    Nov 2012
    Location
    West Hartford, CT
    Posts
    26
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Is the system I have good? Need some advice !

    Is there any particular box I should look into?




  10. #9
    husker77's Avatar
    husker77 is offline CarAudio.com Elite



    Join Date
    Apr 2012
    Location
    Nebraska
    Posts
    662
    Post Thanks / Like
    Mentioned
    5 Post(s)

    Re: Is the system I have good? Need some advice !

    You would want one that is designed specifically for your sub and vehicle. There are several box designers on this site, and probably some local to you also.

    Pro rabbit DC Creations
    mobile enclosures Welcome to Mobile Enclosures! - Mobile Enclosures - Custom subwoofer boxes
    starr mountain Home
    buck's box design(I think he is having health issues right now) http://www.caraudio.com/forums/buck-...sign-pics.html

    Then there are a few other guys that don't really advertise

    catman
    kangaraux




  11. #10
    bgowdy31's Avatar
    bgowdy31 is offline I GOT LOUD FOR $648



    Join Date
    Apr 2011
    Location
    Campbellsville, Ky
    Posts
    5,986
    Post Thanks / Like
    Images
    79
    Mentioned
    10 Post(s)

    Re: Is the system I have good? Need some advice !

    i mean for daily use i think its a pretty good starter system. but yea a we bit more amp would probly make it a bit louder tho



    MY 95 BLAZER~(HIGHEST SCORE 147+DB 30 SEC MUSIC AVG-BB2400 & 1 HDC3-18 W/STOCK ELEC)
    2 OBSIDIAN V2 18'S ~ 10 CUBES @ 38HZ ~ SOUNDSTREAM TA1.3000D @ .5
    DC 220A ALT ~ 2 AGMS + 1 STOCK BATT ~ 4 RUNS OGA(2 POS & 2 NEG)

    WIFEYS 03 FOCUS SE TRUNK SYSTEM ~ 143+DB 30 SEC MUSIC AVG
    1 KICKER L7 15 ~ 5.6 CUBE @ 38HZ ~ KICKER ZX1000.1 @ 2 OHM
    STOCK ELECTRICAL ~ 1 BATT(YELLOW TOP OPTI) ~ ONLY 6GA WIRE


    2010 FCBC 450 STREET 3RD PLACE & 2011 FCBC 450 STREET CHAMPION
    TEAM UNRESTRICTED ~ MY YOUTUBE CHANNELS-> *bgowdy31 & bgowdy3131*

  12. #11
    gckless's Avatar
    gckless is online now CarAudio.com Veteran



    Join Date
    Aug 2011
    Location
    San Antonio
    Posts
    3,965
    Post Thanks / Like
    Mentioned
    28 Post(s)

    Re: Is the system I have good? Need some advice !

    Quote Originally Posted by nkrell11 View Post
    Caps are designed to help reduce the strain on your electrical system when your amp draws current however, they tend to put more strain on your electrical than they prevent alpine makes decent gear for being so mainstream also I'd suggest a non pre fabricated ported box otherwise it sounds like a decent entry level set-up.
    Only when your electrical isn't good enough to provide proper power to the amp without the cap. Unfortunately, that's when most people use them because they are told that from best buy or something like that. They are useful when you have a proper electrical system, providing you know what they do and what to expect.



    Quote Originally Posted by ducatipaso View Post
    15inch subs can't play fast beats, they take more power and that taxes the vehicles electrical system. You will wake up and "hear" then see the light at the end of the tunnel and it will be 3 10's pounding so hard you wont even open your trunk or turn your system on because you 15's will sound sloppy & weak.
    Quote Originally Posted by benbenondatrack View Post
    stfu lesbo.why are you worried about me so much? you must want to date me ya little cookie monster but i dont even like sweets. your just a cup full of ice, dirt dead nasty azz ice...without the water.

    Dat Build Log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/578701-1999-chevrolet-blazer.html

  13. #12
    jungstah's Avatar
    jungstah is offline Senior VIP Member



    Join Date
    May 2012
    Location
    san francisco
    Posts
    278
    Post Thanks / Like
    Mentioned
    2 Post(s)

    Re: Is the system I have good? Need some advice !

    if you get another type r you will need a bigger sub amp. the 4 channel puts out 40w x 4. you can find some decent speakers to handle the power to match, look into pioneer d series



    Pioneer AVH-P2400BT
    Stock Pioneer 4" components
    Hifonics Brutus BRZ1700.1D
    Two SA-12's
    cruddy prefab ported box----new box otw

  14. #13
    husker77's Avatar
    husker77 is offline CarAudio.com Elite



    Join Date
    Apr 2012
    Location
    Nebraska
    Posts
    662
    Post Thanks / Like
    Mentioned
    5 Post(s)

    Re: Is the system I have good? Need some advice !

    You might want to get some pics also so we can see if there are any glaring problems.




Closed Thread

Similar Threads

  1. Replies: 0
    Last Post: 08-13-2009, 01:41 AM
  2. Replies: 4
    Last Post: 12-29-2004, 08:14 PM
  3. will the Focal 130CA have good midbass
    By DbRufus1234 in forum Speakers
    Replies: 2
    Last Post: 11-16-2003, 10:33 PM
  4. Is the ALPINE MRD-M500 Good?
    By StockDX in forum Amplifiers
    Replies: 6
    Last Post: 08-05-2003, 12:57 PM
  5. first system, i need some advice plz
    By blackbird2004 in forum General Discussion
    Replies: 13
    Last Post: 07-24-2002, 12:29 AM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum