Closed Thread
Results 1 to 2 of 2

Reload Thread: (installers) Got any pics of the worst installs you have had to fix/redo 2012 version

  1. #1
    d77543020's Avatar
    d77543020 is offline CarAudio.com Veteran



    Join Date
    Dec 2005
    Location
    stockton ca
    Posts
    2,509
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    393 Post(s)

    (installers) Got any pics of the worst installs you have had to fix/redo 2012 version

    this was a thread back in 08 anybody has some 2012 crappy installs







  2. #2
    Rhythm's Avatar
    Rhythm is offline Junior Member



    Join Date
    Jun 2012
    Location
    Chicago burbs, IL
    Posts
    29
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    17 Post(s)

    Re: (installers) Got any pics of the worst installs you have had to fix/redo 2012 ver

    I feel like the first time I'll try to install something would be a solid contribution to this thread.




Closed Thread

Similar Threads

  1. (installers) Got any pics of the worst installs you have had to fix/redo
    By Hybrid90accord in forum General Discussion
    Replies: 113
    Last Post: 03-11-2011, 10:23 AM
  2. speSome old pics of the aker install i did to my bimmer....
    By BMWAUDIO in forum Car Audio Build Logs - Cars/Trucks/SUVs
    Replies: 1
    Last Post: 08-15-2008, 07:24 PM
  3. Just a Few quick pics of the Maxima Install
    By snb778 in forum Car Audio Build Logs - Cars/Trucks/SUVs
    Replies: 14
    Last Post: 04-23-2008, 12:30 PM
  4. Pics of the New Install **Not 56K Friendly**
    By 94CamryBumpin in forum General Discussion
    Replies: 20
    Last Post: 07-26-2005, 12:59 AM
  5. Do u all have any pic of the back of your H/u ??
    By WiCHo in forum General Discussion
    Replies: 41
    Last Post: 02-28-2003, 02:02 PM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum