Closed Thread
Results 1 to 9 of 9

Reload Thread: New SoundStream amp going into protect

  1. #1
    low00ranger's Avatar
    low00ranger is offline Senior VIP Member



    Join Date
    Sep 2005
    Location
    USA
    Posts
    234
    Post Thanks / Like
    Mentioned
    0 Post(s)

    New SoundStream amp going into protect

    I just got a new SoundStream Rubicon 1.700 this week along with a pair of new JL 10W3v3s. I got everything wired and connected with the subs wired in series at 2 ohms. The first time I powered up the amp, the speakers popped and the amp went into protect immediately. I turned the car off and made sure all connections were solid, as they were. Turned the car back on and the amp goes into protect again. I verified that:

    *14.3v power coming into the amp
    *13.5v coming from remote wire
    *Amp is seeing a 2.1 ohm load from speakers

    I turned the car off and disconnected the RCA leads and speaker output wiring. Turn the car back on with just power, remote, and ground leads and it STILL goes into protect. Is this amp defective?



    2005 Dodge Magnum R/T

    SOLD TO: rickymac21, j&b4ever, mysilver02alty




  2. #2
    Kangaroux's Avatar
    Kangaroux is offline I put on



    Join Date
    Dec 2010
    Location
    Maine
    Posts
    9,604
    Post Thanks / Like
    Mentioned
    82 Post(s)

    Re: New SoundStream amp going into protect

    What's your ground look like? Did you make sure nothing is being shorted out?




  3. #3
    mylows10's Avatar
    mylows10 is offline Dc,tantric,singer,phd rep mylows10 is a Supporting Member of the forum!

    mylows10 is a Supporting Vendor of the forum!

    Join Date
    Sep 2009
    Location
    monterey , ca
    Age
    51
    Posts
    19,012
    Post Thanks / Like
    Images
    9
    Mentioned
    493 Post(s)

    Re: New SoundStream amp going into protect

    sounds bad




    pioneer avhx 5500 dvd, gzpa 1.4000 x 2
    ab vfl 350.4 ,7 pc 2150 and a 150 ah power ware agm ,275 amp singer alt , 2nd one coming soon
    cdt 6.5 es 6 im mids,cdt es 010 tweets,es 02 mids ,mx1000 3 way x overs , sky high and stinger hpm o gauge wires ,also 2 tantric hdd 15's in a 9.5. ^3 ported no wall box 11.5 octo port.
    NOR CAL DB DRAG JUDGE
    http://www.dcsoundlab.com

  4. #4
    VWGolfMKVI's Avatar
    VWGolfMKVI is offline StarrMountainSoundNutHugr



    Join Date
    Oct 2005
    Location
    Minot, North Dakota, United States
    Posts
    1,358
    Post Thanks / Like
    Mentioned
    3 Post(s)

    Re: New SoundStream amp going into protect

    Yeah unfortunately sounds like a bad amp.




  5. #5
    ThatChevyGuy's Avatar
    ThatChevyGuy is offline i heart Jager



    Join Date
    Jul 2006
    Location
    Arkansas
    Posts
    12,313
    Post Thanks / Like
    Mentioned
    12 Post(s)

    Re: New SoundStream amp going into protect

    Did you ground to the body and scrape the paint? make sure it wasn't a seat belt bracket or something... Otherwise sounds defective.



    REFS:
    Squeak9798, Kumbos310w6, BigBangTheory, Jmanpc, MillzThaYungin, WLDock, -Leister-, ThomasG, J31Rob (and a few more I have forgotten)
    Quote Originally Posted by Spider Monkey View Post
    eat my asshole you insignificant bastard child of a retarded dingleberry cunt wrinkle fuck toy
    Quote Originally Posted by subzero View Post
    her pussy better be that nicest pussy you ever ever ever had. she better suck, swallow, jack off, eat ass and snatch, make sammiwich, do yard work and fix the vehicals while nude. Because a bitch like that is definately gonna cause alot of stress in your life, even thou she keeps your wallet and your balls drained.
    Quote Originally Posted by 05fronty View Post
    bitch you better swallow and not make a mess

  6. #6
    low00ranger's Avatar
    low00ranger is offline Senior VIP Member

    Threadstarter


    Join Date
    Sep 2005
    Location
    USA
    Posts
    234
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: New SoundStream amp going into protect

    First I grounded it to a new location on the car's body. Drilled a new hole and scraped the paint around the area. Now it is grounded to the same point where the battery is grounded (my battery is in the hatch close to the amp). I guess the last thing I'll try is grounding directly to the battery in the slight chance that amp's ground connection still isn't good enough since I have 3 ring terminals stacked in the same grounding location (sub amp, mid amp, battery ground). I have a mid/high amp grounded to the same point I'm trying now and it doesn't have an issue.



    2005 Dodge Magnum R/T

    SOLD TO: rickymac21, j&b4ever, mysilver02alty

  7. #7
    low00ranger's Avatar
    low00ranger is offline Senior VIP Member

    Threadstarter


    Join Date
    Sep 2005
    Location
    USA
    Posts
    234
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: New SoundStream amp going into protect

    Ran the 4 gauge ground wire direct to battery, 18 inches of wire, with no ring terminals or other connectors. The amp still goes into protect as soon as it turns on without RCA or speaker connections. It reads 12.4v across the power and ground terminals with the car off. One thing I noticed is usually the ground wire sparks when I actually connect it to ground.... this isn't happening with this amp.



    2005 Dodge Magnum R/T

    SOLD TO: rickymac21, j&b4ever, mysilver02alty

  8. #8
    thevic24's Avatar
    thevic24 is offline my silence is deadly...



    Join Date
    Apr 2007
    Location
    right behind you
    Posts
    5,822
    Post Thanks / Like
    Images
    7
    Mentioned
    0 Post(s)

    Re: New SoundStream amp going into protect

    Make sure you do not have any stray strands of wire shorting out at the amp terminals.

    Other than that, my vote is a bad amp.
    The pop you herd was most likely the amp sending a DC signal to the speakers....thus kicking in the protection circuit.



    Silently stalking you through glass....

  9. #9
    Steveopevo's Avatar
    Steveopevo is offline Senior VIP Member



    Join Date
    Nov 2008
    Location
    phoenix, az
    Posts
    234
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: New SoundStream amp going into protect

    deleted




Closed Thread

Similar Threads

  1. amp going into protection... again
    By btmorris972 in forum Amplifiers
    Replies: 17
    Last Post: 11-10-2005, 11:12 PM
  2. Need help with amp going into protect...
    By Rawr-DQ in forum Amplifiers
    Replies: 6
    Last Post: 04-14-2005, 09:10 PM
  3. amp going into protect
    By orioles26 in forum Amplifiers
    Replies: 18
    Last Post: 10-05-2004, 06:06 PM
  4. amp going into protection mode
    By psprowler in forum Wiring, Electrical and Installation Help
    Replies: 1
    Last Post: 03-17-2004, 10:05 AM
  5. sub amp going into protection when low notes hit
    By B|2imstone in forum Amplifiers
    Replies: 7
    Last Post: 12-08-2003, 03:12 AM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum