Closed Thread
Page 1 of 3 1 2 3 LastLast
Results 1 to 15 of 40

Reload Thread: my subwoofer starts to smell after extneded period of use

  1. #1
    Join Date
    Jul 2007
    Location
    Phoenix, AZ
    Posts
    47
    Post Thanks / Like
    Mentioned
    0 Post(s)

    my subwoofer starts to smell after extneded period of use

    what could be causing it? it's a kicker CVR12 with this amp i believe: adence Acoustics ZRS C9 600 Watt Peak


    what could be causing it? my first sub already blew, even started smoking...i've been keeping this one turned down. could it be the box? the foam on the inside of the box? i had the same set up in my old car (except two of the kickers) and never had a problem







  2. #2
    Kangaroux's Avatar
    Kangaroux is offline I put on



    Join Date
    Dec 2010
    Location
    Maine
    Posts
    9,472
    Post Thanks / Like
    Mentioned
    81 Post(s)

    Re: my subwoofer starts to smell after extneded period of use

    Do you have any bass boosts turned on? What volume do you go to on your headunit? Did you set your gain with a multi meter or did you just eye ball it?




  3. #3
    GAMEOVERCCA's Avatar
    GAMEOVERCCA is offline INCRIMINATOR AUDIO



    Join Date
    Jun 2011
    Location
    Hickory NC
    Posts
    1,762
    Post Thanks / Like
    Images
    8
    Mentioned
    10 Post(s)

    Re: my subwoofer starts to smell after extneded period of use

    to much power
    Last edited by GAMEOVERCCA; 04-30-2012 at 03:03 PM.



    Subs
    2 IA Death penalty 15's
    Highs and Mids
    2 IA Comp sets
    Amps
    1 AB VFL200.1
    1 Mmats SQ4150

    Batteries
    3 Deka intimidator 1000amp 100ah AGM's

  4. #4
    winkychevelle's Avatar
    winkychevelle is offline CarAudio.com Veteran



    Join Date
    Jun 2009
    Location
    Ponchatoula, La
    Age
    23
    Posts
    3,320
    Post Thanks / Like
    Mentioned
    8 Post(s)

    Re: my subwoofer starts to smell after extneded period of use

    if you had two kicker 12s in the same box and now you only have one i would guess your box is entirely to big, and the sub can only take a few hundred watts in a box that big



    2014 Chevrolet Cruze Diesel
    Big sq install on the horizon if money stays good
    2012 Nissan Versa Hatch
    Deadened but stock, girls ride now

  5. #5
    Cody Is Cool's Avatar
    Cody Is Cool is offline Member

    Threadstarter


    Join Date
    Jul 2007
    Location
    Phoenix, AZ
    Posts
    47
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: my subwoofer starts to smell after extneded period of use

    no it was a dual box. then i bought a single box. bass boosts no. i turn down the low EQ setting, also turn down the subwoofer control a few notches




  6. #6
    Cody Is Cool's Avatar
    Cody Is Cool is offline Member

    Threadstarter


    Join Date
    Jul 2007
    Location
    Phoenix, AZ
    Posts
    47
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: my subwoofer starts to smell after extneded period of use

    Quote Originally Posted by Kangaroux View Post
    Do you have any bass boosts turned on? What volume do you go to on your headunit? Did you set your gain with a multi meter or did you just eye ball it?
    idk the shop did it all. my bass doesn't seem all that loud, most the time



    so i can rule out the option that it could be the anything regarding the box?




  7. #7
    audiobaun's Avatar
    audiobaun is offline Premium Member audiobaun is a Supporting Member of the forum!



    Join Date
    Jun 2011
    Location
    rockwall,Tx
    Posts
    6,558
    Post Thanks / Like
    Mentioned
    46 Post(s)

    Re: my subwoofer starts to smell after extneded period of use

    Quote Originally Posted by GAMEOVERCCA View Post
    its a kicker lol...
    nothing wrong w kickers bro,they bang just fine with the right enclosure built,i still have a dvc 2ohm l5-10 that will bang its a s s off!...check your wiring configuration also make sure you are not running the wrong ohms load to the sub,and amps stability as well




  8. Thanks 09civic thanked for this post
  9. #8
    winkychevelle's Avatar
    winkychevelle is offline CarAudio.com Veteran



    Join Date
    Jun 2009
    Location
    Ponchatoula, La
    Age
    23
    Posts
    3,320
    Post Thanks / Like
    Mentioned
    8 Post(s)

    Re: my subwoofer starts to smell after extneded period of use

    Quote Originally Posted by Cody Is Cool View Post
    no it was a dual box. then i bought a single box. bass boosts no. i turn down the low EQ setting, also turn down the subwoofer control a few notches
    ported i assume since you can smell it. do you know the specs of the box of is it just a prefab? if it is a prefab and you are trying to play low bass like sub 40 hz depending on the sub it can cause damage to the sub.

    and what deck and where is the gain knob set it should never be more than 2/3s up rarely above half. the box might be to small making you want to crank the radio up more to make up for the loss in volume at lower frequencies



    2014 Chevrolet Cruze Diesel
    Big sq install on the horizon if money stays good
    2012 Nissan Versa Hatch
    Deadened but stock, girls ride now

  10. #9
    Cody Is Cool's Avatar
    Cody Is Cool is offline Member

    Threadstarter


    Join Date
    Jul 2007
    Location
    Phoenix, AZ
    Posts
    47
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: my subwoofer starts to smell after extneded period of use

    Quote Originally Posted by audiobaun View Post
    nothing wrong w kickers bro,they bang just fine with the right enclosure built,i still have a dvc 2ohm l5-10 that will bang its a s s off!...check your wiring configuration also make sure you are not running the wrong ohms load to the sub,and amps stability as well


    i am such a newb. i do know they're both 2ohm




  11. #10
    Cody Is Cool's Avatar
    Cody Is Cool is offline Member

    Threadstarter


    Join Date
    Jul 2007
    Location
    Phoenix, AZ
    Posts
    47
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: my subwoofer starts to smell after extneded period of use

    Quote Originally Posted by winkychevelle View Post
    ported i assume since you can smell it. do you know the specs of the box of is it just a prefab? if it is a prefab and you are trying to play low bass like sub 40 hz depending on the sub it can cause damage to the sub.

    and what deck and where is the gain knob set it should never be more than 2/3s up rarely above half. the box might be to small making you want to crank the radio up more to make up for the loss in volume at lower frequencies





    and i have a jvc in dash dvd




  12. #11
    bgowdy31's Avatar
    bgowdy31 is offline I GOT LOUD FOR $648



    Join Date
    Apr 2011
    Location
    Campbellsville, Ky
    Posts
    6,290
    Post Thanks / Like
    Images
    82
    Mentioned
    10 Post(s)

    Re: my subwoofer starts to smell after extneded period of use

    Quote Originally Posted by GAMEOVERCCA View Post
    its a kicker lol...
    ^^^^this.......... my wife has a l7 square 15 in here car. it always begins to smell after like 4 mins of playing. no her amp aint clipping nor is she over powering(zx1000.1)
    its simply just kicker.. and i say this because every kicker i have had did this., its not a "omg the subs n fire smell" jus like the coils are heated up.... not trashing kicker because hers sounds really good and she pops decent numbers on TL with music...



    MY NEW RIDE- 2001 HYUNDAI SANTA FE (BEST SCORE 147+DB 30-SEC MUSIC-BB2400 & 1 HDC3-18 W/STOCK ELEC)
    2 SOUNDQUBED SDC2.5-15'S ~ 7.06 CUBE @ 37HZ ~ SHARK 2500(FOR NOW,2 STRAPPED LATER)@ 1OHM
    STOCK ALT ~ 1 STOCK DEKA & 2 AGM'S ~ 4 RUNS OF 1/0(2+/2-)


    WIFEYS 03 FOCUS SE TRUNK SYSTEM ~ 143+DB 30 SEC MUSIC AVG
    1 KICKER L7 15 ~ 5.6 CUBE @ 38HZ ~ KICKER ZX1000.1 @ 2 OHM
    STOCK ALT ~ 1 STOCK BATTERY ~ ONLY 6GA POWER WIRE


    2010 FCBC 450SD 3RD OVERALL~2011 FCBC 450SD CHAMPION~YOUTUBE->bgowdy31 & bgowdy3131

  13. #12
    Ionakron's Avatar
    Ionakron is offline Member



    Join Date
    Apr 2012
    Location
    OR, United States
    Posts
    147
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: my subwoofer starts to smell after extneded period of use

    I must be doing something wrong.... my kickers don't smell :l




  14. #13
    winkychevelle's Avatar
    winkychevelle is offline CarAudio.com Veteran



    Join Date
    Jun 2009
    Location
    Ponchatoula, La
    Age
    23
    Posts
    3,320
    Post Thanks / Like
    Mentioned
    8 Post(s)

    Re: my subwoofer starts to smell after extneded period of use

    Quote Originally Posted by bgowdy31 View Post
    ^^^^this.......... my wife has a l7 square 15 in here car. it always begins to smell after like 4 mins of playing. no her amp aint clipping nor is she over powering(zx1000.1)
    its simply just kicker.. and i say this because every kicker i have had did this., its not a "omg the subs n fire smell" jus like the coils are heated up.... not trashing kicker because hers sounds really good and she pops decent numbers on TL with music...
    see im lost with this cause i fed my comps 900 between two and they never got smelly and the coils are still shiny and clean



    2014 Chevrolet Cruze Diesel
    Big sq install on the horizon if money stays good
    2012 Nissan Versa Hatch
    Deadened but stock, girls ride now

  15. #14
    Cody Is Cool's Avatar
    Cody Is Cool is offline Member

    Threadstarter


    Join Date
    Jul 2007
    Location
    Phoenix, AZ
    Posts
    47
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: my subwoofer starts to smell after extneded period of use

    Quote Originally Posted by bgowdy31 View Post
    ^^^^this.......... my wife has a l7 square 15 in here car. it always begins to smell after like 4 mins of playing. no her amp aint clipping nor is she over powering(zx1000.1)
    its simply just kicker.. and i say this because every kicker i have had did this., its not a "omg the subs n fire smell" jus like the coils are heated up.... not trashing kicker because hers sounds really good and she pops decent numbers on TL with music...

    so i should ignore the smell? it's possible i didn't smell it before because it was in a trunk...but i mean i just had one start smoking and blew and had to put in my back up




  16. #15
    audiobaun's Avatar
    audiobaun is offline Premium Member audiobaun is a Supporting Member of the forum!



    Join Date
    Jun 2011
    Location
    rockwall,Tx
    Posts
    6,558
    Post Thanks / Like
    Mentioned
    46 Post(s)

    Re: my subwoofer starts to smell after extneded period of use

    Quote Originally Posted by Cody Is Cool View Post
    i am such a newb. i do know they're both 2ohm
    so you were @2ohms bridged..ya your at 4ohms now,a little more than half power you are used too.run that at 4ohms till you can afford another sub to get back to 2ohms mono,and keep the gain down,and try not to cook what you have left,maybe look into getting a single box made for each sub, so you can get most out of the subs.better have one made than prefab.only prefab box ive ever used was pro boxes, even they are mediokra,but better than most prefabs.get one made to specs for the sub same price or cheaper, and will make a huge difference,even @4 OHMS RUNNING the smell is from sub getting hot /gains up pretty high,turn it down to 12 oclock-1 oclock position with bass boost @0,and dont go more than 3-4 on sub increase,with no loud button on.will not be same banging, but safe for the sub you got, and keep from having to buy a pair than just one sub needed to get back to where you were..ya know




Closed Thread
Page 1 of 3 1 2 3 LastLast

Similar Threads

  1. KDC-BT945U volume drop after a period of time
    By olds97_lss in forum Head Units
    Replies: 9
    Last Post: 10-14-2011, 01:00 AM
  2. Is my battery supposed to smell?
    By Ayy in forum General Discussion
    Replies: 23
    Last Post: 07-06-2009, 11:29 PM
  3. Speakers stopped working after 3 hours of use?
    By RoachForLife in forum General Discussion
    Replies: 3
    Last Post: 08-27-2008, 09:02 AM
  4. My 2 15" hdc3 alum are blown after 3 hours of use!
    By da box king in forum General Discussion
    Replies: 111
    Last Post: 08-14-2008, 11:53 PM
  5. Panasonic CQ-C7301 turns off after 10 minutes of use
    By mutti_wilson in forum Head Units
    Replies: 1
    Last Post: 08-23-2007, 05:36 AM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum