Closed Thread
Results 1 to 4 of 4

Reload Thread: Did I blow my midrange and tweeter

  1. #1
    Quaker13's Avatar
    Quaker13 is offline Junior Member



    Join Date
    Nov 2011
    Location
    Dc
    Posts
    23
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Did I blow my midrange and tweeter

    Just recently I had to reconfigure my audison bit ten and inorder to de-equalize and re=equalize my factory headunit i had to turn up the volume on my stereo to the loudest setting without clipping or distortion. I did. Since I set everything up agains my passenger door tweeter is very faint and my midrange doesn't play unless bang on it with my fist or hit a pothole. Driver side mids and tweeters are just fine.







  2. #2
    big_ol_meat's Avatar
    big_ol_meat is offline Member



    Join Date
    Aug 2006
    Location
    Pine Bluff,AR
    Posts
    40
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    13 Post(s)

    Re: Did I blow my midrange and tweeter

    Sounds like it might be a loose wire on the crossover.




  3. Likes nateberrier liked this post
  4. #3
    Quaker13's Avatar
    Quaker13 is offline Junior Member

    Threadstarter


    Join Date
    Nov 2011
    Location
    Dc
    Posts
    23
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Did I blow my midrange and tweeter

    how would you explain the passenger door tweeter sounding airy and driverside tweeter sounding normal and full??




  5. #4
    nateberrier's Avatar
    nateberrier is offline ******



    Join Date
    Jun 2009
    Location
    Douche, Ohio
    Posts
    4,641
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    202 Post(s)

    Re: Did I blow my midrange and tweeter

    Loose wire broham. It takes a bit of power to move through the circuits inside those xovers. So it might still reach the tweeter and not the mid. Check your connections. Your **** is not blown.



    Refs: mrmakinmoves[SCAMMER] AKA ICHASEPAPER2010, skydeaner, fukinmovin, mossberg385t, grimreper912003, LBC99, Dbeez, Michaellane, thegreatestpenn, truckstoy, ge_off_me, btr, cupid6969, johnprdeye, jh8909, tylerj, UMWDawg92, nu2spl, zerosktr111, SPLAUDIO, $LICK CALIFA$, jfroghobo

    http://www.execution-audio.com/

Closed Thread

Similar Threads

  1. Did i blow my tweeters?
    By 4OZGLOVES in forum Wiring, Electrical and Installation Help
    Replies: 4
    Last Post: 04-08-2009, 03:54 PM
  2. Did I blow my tweeters or ruin my xovers?
    By aadadams in forum Speakers
    Replies: 8
    Last Post: 03-30-2006, 02:15 PM
  3. Please Help! Did I Blow My Amp?!?!?!?!
    By CrEaMXxPuFf in forum Amplifiers
    Replies: 4
    Last Post: 07-09-2002, 02:06 PM
  4. Did i blow my amp?
    By <Confused_beginner> in forum Wiring, Electrical and Installation Help
    Replies: 11
    Last Post: 05-04-2002, 02:12 PM
  5. Did I blow my Vega?
    By <IowaBoomer> in forum Wiring, Electrical and Installation Help
    Replies: 12
    Last Post: 01-11-2002, 05:55 AM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum