Closed Thread
Page 3 of 3 FirstFirst 1 2 3
Results 31 to 32 of 32

Reload Thread: New amp MORE power, car sluggish to start.

  1. #31
    MEMPHISLOVERST7's Avatar
    MEMPHISLOVERST7 is offline Junior Member



    Join Date
    Sep 2011
    Location
    Naples,Fl
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: New amp MORE power, car sluggish to start.

    Buy a Optima red top or yellow for front battery and get a shrukien 950 amp battery for the amp. I have a nasty set-up and and blast my system and never have any light dimming problems. Power caps are a waste of space, extra batterys are the key to having enough power to slam your ride to the max. Audio America has some good deals especialy if you know someone who works there then you get everything at dealer price. The hell with paying for retail. Good luck on your battery hunting.







  2. #32
    Join Date
    Oct 2008
    Location
    Spartanburg, SC
    Age
    31
    Posts
    1,526
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    20 Post(s)

    Re: New amp MORE power, car sluggish to start.

    I have a 130 amp stock alt and a deka 9a31 upfront. I dont drop below 14v while driving and 13v at idle with the same amp. He shouldn't be having this problem. As mentioned earlier I would have the alt and batt checked, especially the alt.




Closed Thread
Page 3 of 3 FirstFirst 1 2 3

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum