Closed Thread
Results 1 to 10 of 10

Reload Thread: Unsure if I just screwed my sub or not?

  1. #1
    xmakeafistx's Avatar
    xmakeafistx is offline CarAudio.com Elite



    Join Date
    Mar 2011
    Location
    Kenosha, WI
    Age
    20
    Posts
    1,089
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    51 Post(s)

    Unsure if I just screwed my sub or not?

    Okay, so I was testing out a broken amp that some guy gave to me on cragislist, and when I plugged it into my sub, it just made a popping sound, and the suspension lifted & it just stayed that way.

    Then when I tried it with my working amp, it didn't have any reaction at all, then I tried putting it on the "broken" amp, and the suspension stayed up.

    Whats happening? lol. I'm thinking maybe it didn't work with my working amp because it only has specs for 4 ohms, & I was running the sub at six.

    I figured maybe the amp would be able to keep up.







  2. #2
    jco1385's Avatar
    jco1385 is offline expert jcologist



    Join Date
    Sep 2007
    Location
    Mobile, AL
    Posts
    18,196
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    285 Post(s)

    Re: Unsure if I just screwed my sub or not?

    umm, you know the amp is bad... so you decide to hook it up to your sub? wtfbbq



    1994 Thunderbird
    JVC KD-AV7010
    Alpine 6x9 3-ways
    Pioneer 6x8 3-ways (rear)
    JVC CH-X1500 12-disc MP3 Changer
    Alpine Type X 12" 2 cubes @ 30hz
    MTX 404 runs the inside
    MTX 1501d runs the X
    Optima G75/25 RT up front
    2x Optima G31 YT in the trunk
    200a EA HO Alt (1/0 Big 3)
    ALL MY WIRE IS WELDING CABLE
    Quote Originally Posted by Johnny Drama View Post
    I always knew I was a feggot.
    Quote Originally Posted by Rashaddd View Post
    We're all feggots on the inside
    Quote Originally Posted by ToledoTom View Post
    I am sure the administration will be having a few words with you when they catch wind of your language.
    DO NOT SEND ME ANYTHING USING UPS. I WILL NOT DEAL WITH THEM EVER AGAIN
    OFFICIAL FEEDBACK THREAD

  3. #3
    xmakeafistx's Avatar
    xmakeafistx is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Mar 2011
    Location
    Kenosha, WI
    Age
    20
    Posts
    1,089
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    51 Post(s)

    Re: Unsure if I just screwed my sub or not?

    The guy told me it just simply didn't turn on, so I figured it wouldn't do anything bad? o.O lol.




  4. #4
    jco1385's Avatar
    jco1385 is offline expert jcologist



    Join Date
    Sep 2007
    Location
    Mobile, AL
    Posts
    18,196
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    285 Post(s)

    Re: Unsure if I just screwed my sub or not?

    do you have a DMM? is the sub 'stuck'? if it is, then



    1994 Thunderbird
    JVC KD-AV7010
    Alpine 6x9 3-ways
    Pioneer 6x8 3-ways (rear)
    JVC CH-X1500 12-disc MP3 Changer
    Alpine Type X 12" 2 cubes @ 30hz
    MTX 404 runs the inside
    MTX 1501d runs the X
    Optima G75/25 RT up front
    2x Optima G31 YT in the trunk
    200a EA HO Alt (1/0 Big 3)
    ALL MY WIRE IS WELDING CABLE
    Quote Originally Posted by Johnny Drama View Post
    I always knew I was a feggot.
    Quote Originally Posted by Rashaddd View Post
    We're all feggots on the inside
    Quote Originally Posted by ToledoTom View Post
    I am sure the administration will be having a few words with you when they catch wind of your language.
    DO NOT SEND ME ANYTHING USING UPS. I WILL NOT DEAL WITH THEM EVER AGAIN
    OFFICIAL FEEDBACK THREAD

  5. #5
    xmakeafistx's Avatar
    xmakeafistx is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Mar 2011
    Location
    Kenosha, WI
    Age
    20
    Posts
    1,089
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    51 Post(s)

    Re: Unsure if I just screwed my sub or not?

    After I unhooked it, it went straight back down. Is this a good sign?




  6. #6
    Buck's Avatar
    Buck is offline always low Buck is a Supporting Member of the forum!



    Join Date
    May 2008
    Location
    Nashville
    Posts
    18,378
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    971 Post(s)

    Re: Unsure if I just screwed my sub or not?

    The amp is fuxered, it's outputting DC current and not AC. Your sub should be fine.



    Alpine - ASE (local) - Batcap - C&D Tech - CT Sounds - DC - eD - Excessive Amperage - Rainbow

  7. #7
    xmakeafistx's Avatar
    xmakeafistx is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Mar 2011
    Location
    Kenosha, WI
    Age
    20
    Posts
    1,089
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    51 Post(s)

    Re: Unsure if I just screwed my sub or not?

    Thanks buck ^ Would it be easy to fix an amp like that?




  8. #8
    pro-rabbit's Avatar
    pro-rabbit is offline Moderator pro-rabbit is a Supporting Member of the forum!

    pro-rabbit is a Supporting Vendor of the forum!

    Join Date
    Jan 2004
    Location
    OKC, OK
    Age
    32
    Posts
    12,395
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2522 Post(s)

    Re: Unsure if I just screwed my sub or not?

    Quote Originally Posted by xmakeafistx View Post
    Would it be easy to fix an amp like that?
    If you are asking that question then perhaps sending it someone who is a reputable amplifier repairman is the best option for you.




  9. #9
    Buck's Avatar
    Buck is offline always low Buck is a Supporting Member of the forum!



    Join Date
    May 2008
    Location
    Nashville
    Posts
    18,378
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    971 Post(s)

    Re: Unsure if I just screwed my sub or not?

    Quote Originally Posted by xmakeafistx View Post
    Thanks buck ^ Would it be easy to fix an amp like that?
    No, I think not.



    Alpine - ASE (local) - Batcap - C&D Tech - CT Sounds - DC - eD - Excessive Amperage - Rainbow

  10. #10
    grandam888's Avatar
    grandam888 is offline Senior VIP Member



    Join Date
    Dec 2010
    Location
    houston, tx
    Age
    26
    Posts
    445
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Unsure if I just screwed my sub or not?

    sounds like a common issue you see on rockfords. unless you plan on getting into fixing amps, i would suggest having someone repair it for you. there a guy who KNOWS HIS ****, @ diyaudio.com. im not giving you his name etc, but i will give you his website and you can email him from their about your amp. he is very reasonable on pricing, and hes trustworthy.


    also this is directly from his site"If you've ever seen a damaged amp that pushed or pulled the speaker cone to its limits when the amp powered up (common on some Rockford amplifiers), that was almost certainly due to a shorted output transistor."


    Basic Car Audio Electronics


    this site is also VERY helpful if you decide to work on it yourself. if it is a shorted output transistor, the repair is not to difficult, just need to know how to use a DMM and have a decent soldering iron.



    FI BTL 18" Fully Loaded
    6cuFT box after all displacements( spl box 4.79 after displ.)
    Planet Audio BB2400.1
    2 runs of 1/0 Gauge Wire
    Kinetic HC800
    Crappy Pioneer HU
    doing 162db in port, 147db in kickpanel

Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum