Closed Thread
Results 1 to 5 of 5

Reload Thread: New setup question

  1. #1
    molurus73's Avatar
    molurus73 is offline Senior VIP Member



    Join Date
    Oct 2003
    Location
    Middletown, OH
    Posts
    283
    Post Thanks / Like
    Mentioned
    0 Post(s)

    New setup question

    Does anyone have an Oldsmobile alero or similar GM car with a wimpy 110 amp alt. I am just curious if that size alt will support a 500 watt sub amp and about 100 - 150 per side amp for comps? I don't really want to upgrade my electrical system. I am trying to get something loud but sensible. I may go with a strong 4 channel amp but I can't find just the one I want. Any ideas?







  2. #2
    ss3079's Avatar
    ss3079 is offline Eh Dere Hi Dere Ho-ser



    Join Date
    Mar 2002
    Location
    Up North
    Posts
    22,571
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: New setup question

    Wimpy 110amp alt ? Try an older, maybe even newer too, Mazda or Honda or something similar ... we're talkin 60amp there

    You should be ok with your stock alternator with the power you want to run. Only one way to find out though ... plug 'er in and let it rip.

    - Steve



    Moderator

    2007 Chrysler 300C

    2005 Chevrolet Silverado 2500HD Crew Cab
    Optima, Volant, Bully Dog, Corsa, Gibson, Powermaster, California Super Trucks, Fox Racing, Airaid
    Alpine 7998, Alpine HDA-5460, Arc Audio MEQ-30, (2) Adire Audio Shiva, Image Dynamics CD-2COMP, Image Dynamics CX64, (2) Image Dynamics ID8V.2, Arc Audio 2100CXL, Arc Audio 4150CXL, Arc Audio 1500D-R

    2006 Kawasaki Ninja ZX14
    Quote Originally Posted by DJGTSR
    I dont mean to be rude, but what is the highest level of education that you finished?

  3. #3
    DJ FURY's Avatar
    DJ FURY is offline Senior VIP Member



    Join Date
    Feb 2004
    Location
    TX
    Posts
    491
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: New setup question

    Yeah its def a plug and play.




  4. #4
    Berry47's Avatar
    Berry47 is offline CarAudio.com Elite



    Join Date
    Dec 2003
    Location
    My Pants
    Age
    31
    Posts
    1,076
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)

    Re: New setup question

    I have a 90 amp alt in my pathy and I am running over 1200 watts of power rms.



    Mine: CDT, Eclipse, Diamond Audio, Dayton, Aura

    Wifey: Infinity, Concept, Pioneer, Profile, JBL

    Refs: Ruckus, MSSOKC

  5. #5
    allyourblood's Avatar
    allyourblood is offline kill the fakes



    Join Date
    Jan 2004
    Location
    San Diego, CA
    Posts
    319
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: New setup question

    i got 400RMS running on a 75 amp alternator... i'm sure you'll be fine.

    abe m.




Closed Thread

Similar Threads

  1. Multi Amp setup wring question.
    By playa1 in forum Amplifiers
    Replies: 8
    Last Post: 12-29-2003, 06:47 PM
  2. Which setup for best sound (sub positioning question)
    By CELLERBR in forum General Discussion
    Replies: 2
    Last Post: 11-04-2003, 11:25 AM
  3. Replies: 3
    Last Post: 09-01-2003, 02:52 PM
  4. Setup question...opinions very welcome!
    By ChuteBoxe515 in forum General Discussion
    Replies: 1
    Last Post: 08-31-2003, 02:39 AM
  5. Help with speaker setup!!
    By ChuckNaked in forum Speakers
    Replies: 5
    Last Post: 08-30-2003, 11:04 AM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum